Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: WAGO Stepper_03.lib durchsuchen

  1. #1
    Registriert seit
    14.05.2007
    Ort
    M nähe Sbg in AUT
    Beiträge
    159
    Danke
    35
    Erhielt 1 Danke für 1 Beitrag

    Ausrufezeichen


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mahlzeit zusammen.


    Kurz und bündig, da in der Arbeit:

    Gibt es eine Möglichkeit sich den Source-Code der Stepper_03.lib im detail anzusehen?
    Erste Versuche scheitern ja am vergebenen Kennwort der Fa. WAGO.

    Vielleicht hatte ja schon jemand einblick in diese Lib und kann mir zumindest auszugsweiße was zukommen lassen.

    Arbeite aktuell mit dem 750-673 - Controller.


    Danke vorab!

    Andy
    Geändert von Andy082 (04.07.2013 um 23:44 Uhr)
    >> Gefährlich wird es für Andere erst dann, wenn die Dummen fleißig werden! <<
    Zitieren Zitieren Steppercontroller 750-673 dezetral per 750-333 durch Siemens SPS steuern  

  2. #2
    Avatar von Andy082
    Andy082 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.05.2007
    Ort
    M nähe Sbg in AUT
    Beiträge
    159
    Danke
    35
    Erhielt 1 Danke für 1 Beitrag

    Standard

    So, da ich nun einen Tag mit nem' Kollegen schon daran tüfftle und nun beinahe die 324 Seiten des Handbuchs durch hab, aber irgendwie nicht schlauer wurde, kann ich nun Abends und zuhause das Problem genauer beschreiben....

    Ich habe für einen Fertigungsanlage zum Vereinzeln von Trays einen Steppermotor des Typs EPCO incl. Geber & Bremse verbaut. Auf die original Controllerbaugruppe von FESTO hatte ich iwi keine Lust, denn das Teil ist als dezentrale Baugruppe ja riesig groß.
    Zur Ansteuerung würde ich denn nun gerne den StepperController 750-673 von Wago verwenden, welcher über eine 750-333 Kopfbaugruppe über DP an einer Siemens SPS werkelt.

    Zur Konfiguration des Controllers hatte ich dann von WAGO in Rekordzeit auch noch ein Programm zur Konfiguration erhalten. (Daumen hoch, danke!!!)

    Mein Problem nun:
    Ich kann irgendwie die Jog-Funktion nicht, wie im Handbuch beschrieben auf Bits umlegen auch welche ich direkt über die Controllbytes beschreiben kann, sondern diese nur über die DI verwenden.
    Zudem hab ich keinen Plan, wie ich einen der Ausgänge so umbeschalten (bzw. verlinken) kann, damit dieser bei einem Positionierauftrag die Bremse des Motors öffnet. Interessant ist nämlich, dass ich in der Konfiguration sehr wohl die Bremsein- & -auszeiten einstellen kann, aber keinen Ausgang dafür habe.
    Weiters interessant: Ich würde gerne die Eingänge der Referenzsensoren auf high abfragen (Schliesser, anstatt Öffner).

    Vielleicht hat sich also schon mal jemand durch die Konfiguration gearbeitet, bzw. könnte mir ein paar Tips geben, wie ich diese Ansteuerung mit einer Siemens SPS sauber lösen kann, wobei ich die Mailboxfunktion absolut nicht einsetzen will. Eine direkte Steuerung über die Status- und Controllbytes wäre perfekt.
    In CodeSys siehts und funktionierts mit der beiliegenden Stepper_03.lib ja ganz "einfach".

    Danke!

    Andy
    >> Gefährlich wird es für Andere erst dann, wenn die Dummen fleißig werden! <<

  3. #3
    Registriert seit
    23.07.2003
    Beiträge
    209
    Danke
    22
    Erhielt 14 Danke für 12 Beiträge

    Standard

    Moin moin ...

    der Bremsenausgang wird ueber ein Output Bitfield eingestellt, siehe Handbuch 140/141,

    ich habe diese Karten an einer Simatic gehabt, da ging das ganze bis auf gewisse Probleme recht gut.

    Nur mit der Referenzfahrt war irgendwas, da muesst ich jedoch in der Software nachschaun ...

    Gruss,
    michael

  4. Folgender Benutzer sagt Danke zu nekron für den nützlichen Beitrag:

    Andy082 (05.07.2013)

  5. #4
    Avatar von Andy082
    Andy082 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.05.2007
    Ort
    M nähe Sbg in AUT
    Beiträge
    159
    Danke
    35
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke.

    Das Break-Bit hatte ich doch glatt überlesen.
    Im Linking der Konfiguration mit WagoIOcheck 3 (nochmals danke an die Kollegen der Fa. Wago für die rasche Übermittlung) einfach dem Ausgang 1 das Bit 24 zugewiesen und schon öffnet und schließt die Bremse. -Perfekt-

    Was ich nun noch nicht ganz durchblickt habe, ist das "Linken" der Jog+/- Eingänge auf Controllbits. ggf. kann ich, sofern nicht benötigte Controllbits vorhanden sind, diese ja freimachen. Wären immerhin nur 2. Hat hier eventuell noch jemand eine Idee!?
    Auf den Rückruf des deutschen Supports warte ich leider immer noch....


    mfg,
    Andy
    >> Gefährlich wird es für Andere erst dann, wenn die Dummen fleißig werden! <<

Ähnliche Themen

  1. Wago Probleme mit LIB VISU Scheduler 3
    Von c-teg74 im Forum WAGO
    Antworten: 15
    Letzter Beitrag: 16.01.2017, 13:02
  2. Antworten: 32
    Letzter Beitrag: 06.05.2015, 10:28
  3. Wago Seicom.Lib Modbus/ASCII
    Von Markus Rupp im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 09.02.2011, 21:56
  4. Wago Lib
    Von Manba im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 19.11.2009, 12:49
  5. Wago M-Bus. lib
    Von wero im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 22.07.2008, 17:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •