Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Bugreport an WAGO bezüglich BACnet-Configurator, Kundendienst bitte durchlesen!

  1. #1
    Registriert seit
    21.02.2011
    Ort
    Deutschland, Baden-Würtemberg
    Beiträge
    990
    Danke
    115
    Erhielt 125 Danke für 100 Beiträge

    Böse


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich stelle hier mal einen kleinen BUG-Report rein. Vieleicht hilft dieser, den Configurator von WAGO zu verbessern.

    Mein System:

    - WIN 7 64 BIT
    - BACnet-Configurator Version 1.7.0.5 (anscheinend die neuste Version)

    "Versuchsaufbau":

    Meine Steuerung:

    - WAGO 750-830 BACnet-Controller mit 1x 750-1405 und 1x 750-1504 DI/DO Klemme
    - Programmierung mittels Codesys Version 2.3.9.28
    - Eingebundene .libs: BACnet_02.lib, BACnetAccess.lib
    - Importierte files: BACNETOBJECTS.EXP
    - Objectanzahl "Values" der PLC: ca. 160

    Kommunikation mit:

    - Siemens Steuerungskomponenten
    - 97 BACnet-Geräten
    - Jedes Gerät stellt ca. 1000 Values, Objekte, Notification_Classes, usw. zur Verfügung


    So nun die Auftretenden Fehler:

    - Öffnen der Software
    - Scannen des Netzwerkes - 97 gefundenene Geräte werden angezeigt, dannach hängt sich die Software auf, egal wie lange man wartet.
    - Ausschalten der Automatischen Scan-Funktion : Eingabe der Objekt-Instanzen manuell, funktioniert.
    - Rechtsklick auf meine PLC im Bereich "Database" - Erneuter Scan des gesamten Netzwerkes trotz ausgeschalter Scanfunktion --> Programm hängt sich auf!

    Nun das schlimmste:

    - Download der Configuration auf den Controller --> ERNEUTER SCAN des Netzwerkes noch wärend dem Download. Der Controller wird nach dem Neustart gesucht. Wieso wird nicht nur nach der expliziten Objekt-Instanz gescannt? Für mich nicht bereiflich....

    Abhilfe:

    - Download der Configuration, dann sofortiges Abziehen des Netzwerkkabels. Client Mappings oder sonstiges durchführen (offline).
    - Speichern, Programm schließen, Programm neustarten
    - Downloaden und hoffen, dass der Download ohne Scan durchgeführt wird.

    Alles in allem hat mich mein Siemens Kollege in dem Moment ausgelacht und ich habe mich leider für die WAGO-Software schämen müssen.
    Mir wurde durch den Configurator ein sehr langer Samstag und Sonntag voller entspannender Nervereien beschert.

    In diesem "kleinen" Netzwerk waren nun nur 97 BACnet-Geräte. Hätte ich weiterarbeiten wollen, hätte ich mich in einem Netzwerk mit über 1000 BACnet-Geräten einloggen müssen -------------> Nicht möglich....

    Weitere Bugs:

    - EDE-File von Siemens ließ sich nicht öffnen, Fehler: Header Error: Expected keyword PROJECT_NAME
    "Try to parse the file anyway?" --> Klick auf Yes führt zu folgender Fehlermeldung:

    Error while importing EDE file.

    The returned error was: Column 11 {} in line 35 could not be parsed.

    Spalte 11, Linie 35 der Excel-File ist aber leer.....


    Das war mal alles.
    Vieleicht kann ich durch diesen kleinen Report ja etwas an der aktuellen Software ändern.

    Viele Grüße,
    Florian

    Update 16.10.2013:

    - Habe vor Ort eine EDE-File von genau diesem Gerät erstellt. Die Files unterscheiden sich überhaupt nicht voneinander. Dennoch kann ich die neu erstellte .csv-Datei - öffnen. Die EDE von Siemens aber nicht....

    - Das Öffnen meines BACnet-Projektes hatte nicht mehr funktioniert. Nach dem Download des allerneusten BACnet-Configurators kann ich sie (zum Glück!!!!!) wieder öffnen.
    Geändert von KingHelmer (16.10.2013 um 10:58 Uhr)
    Zitieren Zitieren Bugreport an WAGO bezüglich BACnet-Configurator, Kundendienst bitte durchlesen!  

  2. #2
    Avatar von KingHelmer
    KingHelmer ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.02.2011
    Ort
    Deutschland, Baden-Würtemberg
    Beiträge
    990
    Danke
    115
    Erhielt 125 Danke für 100 Beiträge

    Standard

    Und weiter gehts:

    - Seit heute kann ich eine bestehende Projektdatei nicht mehr öffnen, in welche ca. 5 Stunden Arbeit (Client Mappings) geflossen sind.

  3. #3
    Registriert seit
    18.02.2013
    Ort
    Hönow
    Beiträge
    4
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Moin KingHelmer

    Die BACnet-Configurator Version 1.7.0.5 hat bei mir auch nicht funktioniert.
    Ich verwende die Version 1.7.0.8_Small.
    Das dickste Netzwerk, was ich damit bearbeitet habe hat allerdings nur ca. 2500 Objekte und um die 35 Geräte.
    Die Codesys Version ist bei mir 2.3.9.40
    Möglicherweise kann Dir diese Information weiter helfen.
    Du kannst auch gern mal ein EDE File mir zusenden, dann probiere ich das Einlesen mal aus.

    Und nur aus reiner Neugier, wer hat bei Siemens gelacht, der Industrizweig oder die Building-Boys?

  4. Folgender Benutzer sagt Danke zu KunoH für den nützlichen Beitrag:

    KingHelmer (15.10.2013)

  5. #4
    Avatar von KingHelmer
    KingHelmer ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.02.2011
    Ort
    Deutschland, Baden-Würtemberg
    Beiträge
    990
    Danke
    115
    Erhielt 125 Danke für 100 Beiträge

    Standard

    Erst mal danke für die Info, ich werde dir morgen eine File senden, wäre nett wenn du das Öffnen testen könntest.

    Habe heute versucht, mich auf MAINWAGO einzuloggen, um nach der aktuellen Version des Configurators zu schauen. Leider habe ich mein passwort vergessen ?! und daher "Passwort vergessen" gedrückt.
    Aus den "maximal 30 Minuten" Wartezeit auf die E-Mail sind mittlerweile 13 Stunden geworden, weiter zunehmend.....

    Und nur aus reiner Neugier, wer hat bei Siemens gelacht, der Industrizweig oder die Building-Boys?
    Ein Building-Boy Dieser hat nur mit solchen Netzwerken zu tun

    Grüße,
    Flo

  6. #5
    Registriert seit
    16.11.2007
    Beiträge
    730
    Danke
    32
    Erhielt 144 Danke für 113 Beiträge

    Standard

    Zitat Zitat von KunoH Beitrag anzeigen
    ... die Building-Boys?
    Desigo PX mit XWorks - daneben wirkt ein Wago mit Configurator/Codesys wie Spielzeug, auch wenn ich sonst grosse Stücke auf die 750er halte.

  7. #6
    Registriert seit
    24.10.2010
    Beiträge
    239
    Danke
    56
    Erhielt 28 Danke für 22 Beiträge

    Standard

    Ich verwende dan Configurator 1.7.0.8
    und CoDeSys 2.3.9.35
    750-830
    Meine Projekte waren zwar noch nicht so groß, aber am kämpfen bin ich auch ständig.

    Die Liste wäre ewig.
    Im Programm selber gibts einige Bugs.
    Das schlimmste ist, dass ich nach Änderungen nicht weiß, ob noch alles funktioniert oder nicht.
    Manchmal lassen sich die BACnet-Objekte nicht mehr ansprechen, manchmal sind Mappings weg.

    Am Montag habe ich an einer Anlage etwas geändert, Zeit Änderung CoDeSys 5 Minuten, Zeit um den Controller danach wieder zum Laufen zu bekommen 2Stunden.
    Am Freitag zuvor bei einer ähnlichen Anlage, Programm getestet alles läuft 17:00, noch kurz kontrollieren ob auf der BACnet-Seite auch alles passt, denkste um 19:30 war ich dann fertig.

    Ich arbeite zwar auch gerne mit Wago, aber für zukünftige Projekte mit BACnet muss man mich schon zwingen.

  8. #7
    Avatar von KingHelmer
    KingHelmer ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.02.2011
    Ort
    Deutschland, Baden-Würtemberg
    Beiträge
    990
    Danke
    115
    Erhielt 125 Danke für 100 Beiträge

    Standard

    Code:
    aber für zukünftige Projekte mit BACnet muss man mich schon zwingen.
    Aber welche Optionen gibt es denn schon groß, wenn man seine Produkte auf WAGO zugeschnitten hat und BACnet verwenden muss.
    Da es bei mir wohl nur Einzelfälle sein werden, passt das schon.

    Sollten vermehrt solche Projekte kommen, muss ich mir auch was überlegen.
    Theoretisch sollte es ja nicht soooo schwierig sein, auf andere Systeme umzustellen, wenn man im Codesys programmiert hat.

    Grüße

  9. #8
    Registriert seit
    24.10.2010
    Beiträge
    239
    Danke
    56
    Erhielt 28 Danke für 22 Beiträge

    Standard

    Da bin ich etwas freier.
    Bei HLK-Anwendungen habe ich schon Alternativen
    Bei Gebäudeautomation (Beschattung, Licht, etc) wirds schon schwieriger, hier benötige ich aber nicht allzu oft BACnet (wird aber mehr).

    Soeben habe ich bei uns in der Firma was mit dem BACnet Controller getestet und die SPS ist sofort wieder angelaufen. Manchmal klappts eben doch.

    Alles in allem ist mir die vorherige Version des Configurators stabiler vorgekommen.
    Mann kann erkennen, dass der Configurator einen Zusatzsoftware ist, welche auf CoDeSys "aufsitzt". Ich bins gewohnt von DDC-Systemen, dass das Ganze BACnet-Handling in der Programmiersoftware verarbeitet wird und jeder Datenpunkt der angelegt wird gleich ein BACnet-Objekt ist.

  10. #9
    Registriert seit
    27.04.2006
    Beiträge
    124
    Danke
    16
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo zusammen,

    hab beim BACnet Konfigurator die Version 1.6.0.27 und Codesys Version 2.3.9.35 (build May 9 2012), dazu die Firmware:750-830_010433(00).hex
    Ist laut einem Wago Mitarbeiter die "Version" die "funktioniert". Na ja, ein bischen Geduld muss man schon mitbringen.

    Hervorgehoben wird das Wago BACnet mit flexibel,variabel, usw., dass dies aber einen sehr hohen Aufwand an Engineering bedeutet bedenkt niemand, da Wago die Produkte verkaufen will, sprich Umsatz machen auf Kosten der Systemintegratoren.

    Wago ja, aber nur ohne BACnet.
    Nicht schön zu sehen dass andere mit den gleichen Problem kämpfen.

    Gruss

    mzva

  11. #10
    Registriert seit
    22.11.2009
    Ort
    OWL
    Beiträge
    31
    Danke
    1
    Erhielt 7 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen,

    ich habe gerade ein Siemens DESIGO Px Projekt, bei dem ich jetzt zusätzlich noch ein paar Bacnet Variablen von einem 750-830 aufnehmen soll. Die Bacnet Variablen der Wago werden im Bacnet Browser anzeigt. Das Dort erstelle EDE File habe ich auch im Siemens Xworks eingebunden. Leider kommen aber keine Daten an, bzw. der PX Controller kennt denn Teinehmer nicht.

    Hat jemand noch ein paar Tipps für mich ? Wie seit ihr beim Verbinden der beiden Steuerungen vorgegangen ?

    Viele Grüße

    Benjamin

Ähnliche Themen

  1. Wago 750-830 BACnet
    Von Wu Fu im Forum WAGO
    Antworten: 28
    Letzter Beitrag: 16.02.2014, 22:14
  2. Antworten: 19
    Letzter Beitrag: 11.06.2013, 19:20
  3. Verkaufe WAGO 750-830 BACNet Ethernet Controller
    Von pete_colo_Sima im Forum Suche - Biete
    Antworten: 5
    Letzter Beitrag: 01.12.2010, 11:55
  4. Allgemeine fragen bezüglich S7
    Von Kraft im Forum Simatic
    Antworten: 24
    Letzter Beitrag: 15.07.2007, 17:02
  5. Melsoft GX Configurator-DP
    Von Gast_Klaus im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 18.02.2006, 14:22

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •