Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: WAGO 750-880: Systemzeit ist nicht die Zeit auf dem System

  1. #1
    Registriert seit
    16.12.2009
    Beiträge
    75
    Danke
    3
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    kann jemand von Euch nachvollziehen ( oder hat selbst schon gesehen ), was hier auf meiner Steuerung "schief" läuft?
    Code:
    VAR
        lokal_Zeit_DT :           DT ;
        lokal_Zeit_Sekunde :      BYTE ;
        lokal_Zeit_Minute :       BYTE ;
        lokal_Zeit_Stunde :       BYTE ;
        lokal_Zeit_Tag :          BYTE ;
        lokal_Zeit_Monat :        BYTE ;
        lokal_Zeit_Jahr :         INT ;
        lokal_Zeit_Wochentag :    BYTE ;                    (* 1-Mo 2-Di 3-Mi 4-Do 5-Fr 6-Sa 7-So *)
    
        aktuelleZeit :            CurTimeEx ;
        SystemZeit64 :            SysTime64 ;
        SystemZeitInt :           SystemTimeDate ;
    
    END_VAR
    
    lokal_Zeit_DT := SysRtcGetTime ( TRUE ) ;
    
    aktuelleZeit ( SystemTime := SystemZeit64 , TimeDate := SystemZeitInt ) ;
    Systemzeit.jpg

    Nach dem Screenshoot scheinen auf dem System zwei unterschiedliche "Systemzeiten" zu laufen?!
    Was SysRtcGetTime zurück liefert, "hinkt" 22 Sekunden hinter CurTimeEx hinterher...
    Dabei passt SysRtcGetTime zu "Time on Device" aus dem WebInterface, CurTimeEx eher zur Zeit vom Windows Rechner ( rechts unten das ist die Zeit aus dem Systemtray von Windows 8 )

    nächtliche Grüße
    Tom
    Geändert von Tom... (07.12.2014 um 12:56 Uhr)
    Zitieren Zitieren WAGO 750-880: Systemzeit ist nicht die Zeit auf dem System  

  2. #2
    Registriert seit
    29.08.2008
    Beiträge
    68
    Danke
    1
    Erhielt 8 Danke für 7 Beiträge

    Standard

    Hallo,

    es gibt das Tool "Wago Ethernet Settings". Da kannst du dich über Ethernet oder über die Service-Schnittstelle mit der Wago verbinden. Dort gibt es einen Reiter für die Zeit. Und da siehst du auch die Zeit auf der Wago. Da kann man die Zeit auf der Wago mit der PC-Systemzeit auch synchronisieren.

    Ob man das auch über das "Web Tool" machen kann weiß ich jetzt nicht. Bei Bedarf kann ich morgen das genauer beschreiben. Kann mich dann mit einer Wago online verbinden.

    Gruß

    Georg

  3. #3
    Tom... ist offline Benutzer
    Themenstarter
    Registriert seit
    16.12.2009
    Beiträge
    75
    Danke
    3
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von georg_demmler Beitrag anzeigen
    Hallo,

    es gibt das Tool "Wago Ethernet Settings". Da kannst du dich über Ethernet oder über die Service-Schnittstelle mit der Wago verbinden. Dort gibt es einen Reiter für die Zeit. Und da siehst du auch die Zeit auf der Wago. Da kann man die Zeit auf der Wago mit der PC-Systemzeit auch synchronisieren.

    Ob man das auch über das "Web Tool" machen kann weiß ich jetzt nicht. Bei Bedarf kann ich morgen das genauer beschreiben. Kann mich dann mit einer Wago online verbinden.

    Gruß

    Georg
    ...soweit, so gut!
    Das entspricht dann dem Wert, den SysRtcGetTime zurück gibt.
    Aber was ist das in CurTimeEx?

    Grüße Tom ( weiter ratlos )

Ähnliche Themen

  1. Antworten: 26
    Letzter Beitrag: 12.12.2017, 10:46
  2. Antworten: 3
    Letzter Beitrag: 23.06.2014, 21:14
  3. Antworten: 0
    Letzter Beitrag: 19.06.2014, 12:15
  4. Antworten: 1
    Letzter Beitrag: 06.05.2014, 05:40
  5. Antworten: 3
    Letzter Beitrag: 14.08.2012, 16:19

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •