Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Wago 750-842 nur mit USB Kabel progrmmieren?

  1. #1
    Registriert seit
    21.09.2012
    Ort
    67433 Neustadt
    Beiträge
    65
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich bin zur Zeit dran eine Wago 750-842 für meine Wohnung zu programmieren. Leider konnte ich bis jetzt noch kein Programm auf die Steuerung übermitteln. Vor kurzem hatte ich noch ein Beckhoff USB Kabel, welches überhaupt keine Verbindung aufbaute. Habe jetzt ein WAGO 750-923 USB Kabel, mit dem die Kommunikation klappt. Leider muss ich Codesys über ne virtuelle Maschine laufen lassen und konnte bis jetzt noch keine Etherschnittstelle funktionstüchtig konfigurieren. Deshalb muss ich auf die USB Schnittstelle ausweichen. Nur kann ich das Programm nicht übertragen. Entweder habe ich einen Kommunikationsfehler #0 oder die Schnittstellen würden nicht überein passen.

    Was und wo genau muss ich einstellen damit ich erstmal über USB das Programm übertragen und testen kann.
    Zitieren Zitieren Wago 750-842 nur mit USB Kabel progrmmieren?  

  2. #2
    Registriert seit
    07.10.2013
    Beiträge
    96
    Danke
    7
    Erhielt 11 Danke für 10 Beiträge

    Standard

    Besorgen WAGO Ethernet Settings.
    Schnittstelle einstellen (RS232=COM1 meistens?) USB/Com ev. Gerätemanager im Windows befragen.
    Die ist zu finden unter Einstellungen/Kommunikation in der WAGO Software.
    Wenn die Identifikation positiv, dann kannst du über Codesys dein Programm einspielen.
    Dein WaGO Kabel bitte in die nächste Tonne werfen, besorge dir einen Beckhoff KS2000-Z2-USB
    Adapter. Der Stecker für PLC ist etwas fummelig, wenn man auf Gewaltanwendung verzichtet, kann man den nicht falsch anbringen.
    Eventuell muss noch neue Firmware rein (FW17). Danach geht es auch
    über TCP.


    Irek

  3. #3
    Registriert seit
    21.02.2011
    Ort
    Deutschland, Baden-Würtemberg
    Beiträge
    990
    Danke
    115
    Erhielt 125 Danke für 100 Beiträge

    Standard

    HI,

    1. Die Verbindung über USB zum Controller funktioniert ja anscheinend bei dir. Das heißt du kannst über die Ethernet settings auf den Controller.

    2. Um im Codesys auch auf den Controller zuzugreifen musst du auf Online-Kommunikationsparameter
    Dort kannst du dir einen neuen Parameter anlegen und den COM port wählen. Über die PFEILTASTEN(bin mir nicht mehr ganz sicher) kannst du dann den COMport deines USB Kabels sehen.
    TIPP: Den COM-Port findest du raus indem du dir die Kommunikationseinstellungen der WAGO Ethernet Settings anschaust. Dort wird die Portnummer des Com-Ports angezeigt.

    Oder aber auch im Gerätemanager.

    ACHTUNG: die com-port nummer kann sich nach Entfernen und neu Verbinden des Kabels ändern, dann musst du die neu angeben.
    ACHTUNG2: Die Übertragung von Programmen über das USB Kabel ist WAHNSINNIG langsam. Eine etwas größere Visu kann da schon mal ne halbe stunde dauern (nicht übertrieben)

    Grüße,
    Flo

  4. #4
    Registriert seit
    13.09.2007
    Beiträge
    566
    Danke
    50
    Erhielt 65 Danke für 57 Beiträge

    Standard

    Moin
    Welche VM benutzt du?
    Ich habe eine USB auf Ethernet Schnittstelle und diese auf der echten Maschine installiert.
    Beim VMware Player hab ich die virtuelle Ethernet Schnittstelle auf den Modus " genattet " eingestellt.
    Ich benutze indraworks und auch twincat und auch die 3s Umgebung in den vm Maschinen.


    Sent from my iPhone using Tapatalk

  5. #5
    Registriert seit
    21.09.2012
    Ort
    67433 Neustadt
    Beiträge
    65
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Danke für die Antworten! Bei Kommunikationsparameter in Codesys 2.3 habe ich bereits die Einstellungen eingegeben wie sie auch von Wago Ethernet Settings Programm angegeben. Des Weiteren habe ich diese Werte ( 19200, Parity: Keine, usw. ) über Gerätemanager eingestellt. Der richtige COM Port habe ich auch in Codesys eingestellt. Leider ist trotzdem keine Verbindung möglich.
    Eine Ethernetverbindung wäre mir eigentlich sehr viel lieber, aber leider kann ich keine richtige Verbindung zwischen der virtuellen Netzwerkkarte in VM Ware 9.0.0 ( Workstation ) mit Windoof XP SP3 und meiner reellen Netzwerkkarte in Win 8.1 herstellen.
    Ich habe bereits versucht Codesys in Win 8.1 zu installieren, jedoch kommt bei der Installation ständig die Meldung das ein Problem mit Codesys und ENI Server aufgetreten ist. Somit kann ich inzwischen Codesys nur über XP betreiben.
    Ich möchte jetzt eigentlich erstmal die Steuerung und die Karten selbst testen. Ich habe vor, nach dem Funktionstest einen All-in-One PC über Ethernet anzuschließen und darüber die Visu laufen zu lassen.

    Ich hatte vorher noch das Beckhoff Kabel, welches aber überhaupt nicht mit funktionierte, aber das war leider so ein Ding aus Ebay und vielleicht sogar kein Orginales.

  6. #6
    Registriert seit
    29.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    136
    Danke
    7
    Erhielt 67 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Renegade37,

    als Anlage habe ich Dir zum Vergleichen drei Screenshots eingefügt, wo die korrekten Einstellungen der Parameter für die Kommunikation mittels dem WAGO-USB Servicekabel (750-923) zu sehen sind.

    CoDeSys_Kommunikationsparameter.jpg

    Ethernet Settings.jpg

    Gerätemanager_Win7.jpg

    Zusätzlich kann mit Ethernet Settings unter dem Reiter Status der Zustand des Controllers ausgelsen werden. Der Zustand wird in Fehlercode und Fehlerargument unterteilt. Im Fenster ist darunter eine kurze Beschreibung zu lesen, wenn ein Fehler ansteht.
    Zusätzlich wird ein Fehler über die rot blinkende I/O Led am Controller kenntlich gemacht. Wenn Sie grün leuchtet steht kein Fehler an.
    Im Folgenden ist hier der Link zum Handbuch des Controllers. Im Kapitel (10) Diagnose findest Du eine ensprechende Beschreibung für alle Fehler.

    http://www.wago.de/suche/index.jsp?q=750-842&action=search&frontendId=frontendGeneral_cms_de-de&lang=de?utm_source=de_port&utm_medium=forum&utm_content=sps-forum&utm_term=MAN

    Ein Fehler kann ebenfalls eine Ursache sein, warum ein Programmdownload verhindert wird.
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com

    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  7. Folgender Benutzer sagt Danke zu .:WAGOsupport:. für den nützlichen Beitrag:

    GUNSAMS (11.02.2015)

Ähnliche Themen

  1. Wago 750-842 mit Beckhoff Karten
    Von TheTrick im Forum WAGO
    Antworten: 2
    Letzter Beitrag: 14.10.2013, 21:00
  2. Antworten: 1
    Letzter Beitrag: 27.06.2013, 15:02
  3. Verkaufe Wago 750-842 + 750-556 + 750-403 + 750-504
    Von kaiuweb im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 16.12.2012, 12:16
  4. ModbusMaster mit WAGO 750-842
    Von April im Forum CODESYS und IEC61131
    Antworten: 4
    Letzter Beitrag: 14.12.2009, 18:11
  5. Mit Wago 750-842 emails auslesen
    Von Checker15D im Forum Sonstige Steuerungen
    Antworten: 5
    Letzter Beitrag: 16.07.2008, 16:39

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •