Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Wago 750-652 Registerkommunikation

  1. #1
    Registriert seit
    21.11.2004
    Beiträge
    154
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin,

    ich wollte eine 750-652 per Programm einstellen. Im Handbuch findet man ja das Thema Registerkommunikation, aber wie macht man das?

    Ich habe bisher kein Beispiel gefunden. Wie schreibt man diese Control- und Statusbytes? Meine Karte hat die Anfangsadresse %IB0 %QB0 24 Bytes lang.



    Hat jemand sowas schon mal gemacht?


    Lars
    Zitieren Zitieren Wago 750-652 Registerkommunikation  

  2. #2
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

    Standard

    Zitat Zitat von Lars123 Beitrag anzeigen
    Ich wollte eine 750-652 per Programm einstellen.
    Was willst du einstellen ?

    Warum über Registerkommunikation ?
    Karl

  3. #3
    Registriert seit
    21.11.2004
    Beiträge
    154
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich hatte hier bei mir das Problem das sich die Karte wieder in Default stellt....deswegen wollte ich nach jedem Neustart die Karte richtig stellen...24Bytes...rs485...9600baut usw

  4. #4
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

    Standard

    Zitat Zitat von Lars123 Beitrag anzeigen
    Ich hatte hier bei mir das Problem das sich die Karte wieder in Default stellt....deswegen wollte ich nach jedem Neustart die Karte richtig stellen...24Bytes...rs485...9600baut usw
    24 Bytes ist default, diese reichen normalerweise auch. (Habe bis jetzt noch KEINE 48 bit benötigt)
    Ob sich diese per Initialisierung anpassen lassen weiß ich nicht.


    RS485 und 9600 Baud --> default.

    Die o.g. werden bei der Initialisierung gesetzt.
    Z.b. kannst du beim Aufruf RS232 und 19200 baud setzen.
    Karl

  5. #5
    Registriert seit
    21.11.2004
    Beiträge
    154
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Mhh komisch warum stand meine auf RS232.....Mhhh

  6. #6
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

    Standard

    Zitat Zitat von Lars123 Beitrag anzeigen
    Mhh komisch warum stand meine auf RS232.....Mhhh
    Grundsätzlich kannst du die Baud, RS232, RS485 . . . setzen.
    Auch Start, Stop, Protokoll RTS/CTS/xOn/xOff . . .
    Karl

  7. #7
    Registriert seit
    21.11.2004
    Beiträge
    154
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Aber wie macht man das? Ich blicke da noch nicht so durch mit diesen Status und Control Byttes wie setzt man diese

  8. #8
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

    Standard

    Zitat Zitat von Lars123 Beitrag anzeigen
    Aber wie macht man das? Ich blicke da noch nicht so durch mit diesen Status und Control Byttes wie setzt man diese
    Hi
    Da gibt es LIBs dafür (Von Wago)

    Hier examples zum "einstieg".
    Angehängte Dateien Angehängte Dateien
    Karl

  9. #9
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

  10. #10
    Registriert seit
    29.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    136
    Danke
    7
    Erhielt 67 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Lars123,

    alternativ zu der Dir schon zur Verfügung gestellten Bibliothek "Serial_Interface_01.lib", können bei den Klemmen „750-65x/003-000“ die Übertragungsparameter mit dem Programm „WAGO-I/O-Check 3“ verändert und in die Klemme geschrieben werden.
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com

    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

Ähnliche Themen

  1. Antworten: 13
    Letzter Beitrag: 11.07.2014, 10:58
  2. Wago 750-652 auf RS232 einstellen.
    Von gravieren im Forum WAGO
    Antworten: 0
    Letzter Beitrag: 25.04.2014, 19:45
  3. Antworten: 0
    Letzter Beitrag: 05.03.2014, 17:01
  4. Probleme mit WAGO Modul 750-652
    Von steffen_73 im Forum CODESYS und IEC61131
    Antworten: 7
    Letzter Beitrag: 02.11.2011, 11:55
  5. Wago 750-464 parametrieren über Registerkommunikation
    Von Hetschi im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 11.11.2010, 10:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •