Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 33

Thema: Eltako MS Multisensor & Wago 750-653

  1. #1
    Registriert seit
    28.07.2013
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich habe einen Eltako MS Multisensor und dieser soll an einer Wago RS485 Schnittstelle(750-653) betrieben werden.
    Die RS485 hat feste Werte(RS 485/ 9600/ N/ 8/ 1) und kann nicht parametriert werden. Funktioniert das mit der Wetterstation?


    Gruß Griel
    Zitieren Zitieren Eltako MS Multisensor & Wago 750-653  

  2. #2
    Registriert seit
    07.06.2006
    Ort
    Bayern
    Beiträge
    624
    Danke
    27
    Erhielt 156 Danke für 139 Beiträge

    Standard

    meines Wissens arbeiten die Multisensoren mit 19200 Baud - wird dann wohl nicht funktionieren.

  3. #3
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Also wenn du eine wirklich einfache Lösung willst (auch unter beibehaltung der einfachen 750-653):

    "http://www.elsner-elektronik.de/modbus.html?&L=2%252520and%2525205%3D6%252520union%252520select%2525200x5E5B7D7E %252520--&tx_bmproducts_pi1[product_uid]=151&cHash=fe19ea25a871480c44804862394c4616"

    Die Eltako-Variante davon liest sich jetzt nicht so, als wenn das Protokoll da offen gelegt wäre.

    Mfg
    Manuel
    Geändert von MSB (03.01.2015 um 14:46 Uhr) Grund: Link funktioniert nicht
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  4. #4
    Registriert seit
    10.05.2005
    Beiträge
    2.005
    Danke
    220
    Erhielt 234 Danke für 205 Beiträge

    Standard

    Zudem hat Wago hat auch ein fertiges Example für die Elsner-Wetterstation.
    Karl

  5. #5
    griel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.07.2013
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Preislich liegen die Wetterstation ja auch weit voneinander entfernt. Und GPS benötige ich nicht.
    Würde es mit der Wago 750-653/000-006 gehen? Von der Geschwindigkeit ja, aber sonst auch? Wofür steht die 5 Byte?

    Wago 750-653/000-006 RS 485/ 19200/ N/ 8/ 1/ 5 Byte

  6. #6
    Registriert seit
    07.06.2006
    Ort
    Bayern
    Beiträge
    624
    Danke
    27
    Erhielt 156 Danke für 139 Beiträge

    Standard

    Zitat Zitat von griel Beitrag anzeigen
    Wofür steht die 5 Byte?
    Die Klemme hat einen Empfangspuffer von 120 Byte und einen Sendepuffer von 16 Byte.
    Das steht in der Doku:

    Link

    Das Prozessabbild der Klemme ist jedoch "nur" 5-Byte gross.
    Über das Prozessabbild wird die Klemme mit der SPS verbunden.

    Wenn du jetzt Beispielsweise ein Telegramm mit 100 Byte empfangen willst, dann muß man diese 100 Byte in 5 Byte-Blöcken von der Klemme zur SPS übertragen.
    Wobei pro SPS-Zyklus dann jeweils nur 5-Byte übertragen werden können. Für die 100-Byte benötigst du dann also 20 Zyklen.
    D.h. die Kommunikation zur Klemme muss u.U. in einer Task mit schneller Zykluszeit programmiert sein.
    Wenn du beispielsweise mit hohen Baudraten sehr große Datemengen empfangen möchtest, und es nicht schaffst die Daten schnell genug von der Klemme abzuholen, dann verlierst du Telegramme, da der Empfangspuffer der Klemme überläuft.

    Die RS485 Elsner-Wetterstation hat ja ca. 60 Byte Nutzdaten.
    Die normale RS485-Variante von Elsner sendet jetzt jede Sekunde diese 60-Byte.
    Du brauchst jetzt also mit der 5-Byte Klemme 12 Zyklen, um diese 60-Byte einzulesen.
    Diese 12-Zyklen müssen dann aber innerhalb von 1 Sekunde erledigt sein.
    D.h. die Kommunikation muss in einer schnellen Taskzeit ausprogrammiert sein.

    Aus diesem Grund gibt es bei Elsner ja auch eine spezielle Wago-Variante der Wetterstation.
    Diese sendet nur alle 3 Sekunden ihre Werte.

    Noch sicherer bist du dann mit der Modbus-Variante der Wetterstation, da du bei dieser ja die Geschwindigkeit und die Datenmenge selber in der Hand hast.


    Ich würde mir eher die 750-653/003-000 anschaffen - bei dieser Klemme kann man die Schnittstellenparameter frei einstellen.

    Es gibt auch noch die 750-652 - die hätte dann ein Prozessabbild von 24 bzw. 48 Byte.

  7. #7
    griel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.07.2013
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe mir die Wago 750-653/003-000 zugelegt und müsste diese noch parametrieren(19200/ N/ 8/ 1).
    Unter CoDeSys finde ich da aber nichts. Geht das etwa nur über die kostenpflichtige Software WAGO-I/O-CHECK 2?

  8. #8
    Registriert seit
    09.11.2013
    Beiträge
    19
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo SPS-ler,

    ich habe die Elsner Elektronik 30146 P03/3-Modbus Wetterstation für Modbus und die Wago 750-653/003-000 eingebaut. Jetzt in der kalten Jahreszeit wollte ich die Zeit nutzen und die Wetterstation einbinden.
    Die Parameter lassen sich mit der
    WAGO-I/O-CHECK "3" anpassen. Doch wen ich die Parameter enspiele, zerschieße ich mir die ganze Steuerung.

    Nach der Fehlerursache bin ich auf die 3 und 5 Byte Variante aufmerksam geworden. Die Wago karte ist als 0750-0653/0003-0000#03 RS485 Interface (Adjustable), 3Bytes[VAR] in der Steuerung angelegt, Laut Handbuch sollte es die 5 Byte Version sein. Liegt es daran, dass ich mir die Steuerung bei der Parametrierung zerschieße? Welche Reihenfolge ist die richtige für die Anpassung?

    Wäre über einen Tipp sehr erfreut. Damit meine Frauen nicht schon wieder im Dunkeln sitzen

  9. #9
    griel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.07.2013
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von PaladurSPS Beitrag anzeigen

    Die Parameter lassen sich mit der
    WAGO-I/O-CHECK "3" anpassen.
    Nur mit dem Programm oder gibt´s da eine kostenlose Alternative?

  10. #10
    Registriert seit
    09.11.2013
    Beiträge
    19
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ist mir nicht bekannt das es Alternativen gibt. Aber da kann bestimmt ein Profi genaueres sagen. Ich habe mir die 3 er geholt, ist es auch Wert trotz des relativ hohen Preises.

Ähnliche Themen

  1. Step 7 Eltako Multisensor MS an S7
    Von the_elk im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 15.10.2015, 16:53
  2. V: Wago 750 Controller & Klemmen / Netzteil
    Von danhw im Forum Suche - Biete
    Antworten: 2
    Letzter Beitrag: 10.07.2013, 13:35
  3. Antworten: 1
    Letzter Beitrag: 19.11.2012, 11:49
  4. Antworten: 10
    Letzter Beitrag: 30.10.2012, 13:06
  5. Wago 750-653 RS485 - Mehrere Teilnehmer?
    Von backflip im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 02.08.2012, 21:04

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •