Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 5 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 49

Thema: Bei 750-8202 und der OSCAT-Lib kommt der Fehler 3150

  1. #1
    Registriert seit
    10.05.2005
    Beiträge
    2.005
    Danke
    220
    Erhielt 234 Danke für 205 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Sobald ich das Target 750-8202 einbinde kommt mit der OSCAT-Lib (Network-LIB) der Fehler 3150.


    Bei allen anderen Targets funktioniert es problemlos.


    Wie erklärt sich der Fehler:
    Es werden die LEN und CONCAT moniert.

    Beim Aufruf aus eines PRG-Bausteine kommt kein Fehler.


    Ich sollte 6 Controller diesen Typs verwenden. (Echt schnelle Controller, viel Speicher . . .)

    Ich brauche die Protokolierung und den FTP-Transfer von der OSCAT.
    Die OSCAT habe ich bereits seit Jahren im Einsatz.

    Kann mir hier jemand einen Tip zu Problemlösung geben.
    Angehängte Grafiken Angehängte Grafiken
    Angehängte Dateien Angehängte Dateien
    Karl
    Zitieren Zitieren Bei 750-8202 und der OSCAT-Lib kommt der Fehler 3150  

  2. #2
    Registriert seit
    29.09.2014
    Ort
    Hessen
    Beiträge
    102
    Danke
    4
    Erhielt 22 Danke für 20 Beiträge

    Standard

    Vermutlich benutzt du das target mit der fw03.
    Da musst du die entsprechenden Funktionen der oscat anpassen, z.b. concats dürfen keine Funktionen aufrufen - diese müsstest du vorher in eine string variable speichern.

    Beispiel:
    Str1:=string_funktion_xyz();
    Concat(str1,str2);


    Oder du wechselst auf die fw02.
    If you always do what you’ve always done, you’ll always get what you’ve always got.
    „Wer immer tut, was er schon kann, bleibt immer das, was er schon ist.“

    Henry Ford

  3. Folgender Benutzer sagt Danke zu lord2k3 für den nützlichen Beitrag:

    gravieren (16.03.2015)

  4. #3
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    19
    Danke
    0
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Hallo Karl,

    lord2k3 hat recht, das ist leider mit FW03 so. Die Lösung ist da die Speicherung in Zwischenergebnisse bei complexen Ausdrücken. Die Ergebnisse der IEC-Funktionen müssen vorher an Variablen übergeben werden. Es soll aber bald seitens 3S eine Anpassung geben. Wenn FW02 ausreicht ist das natürlich auch eine Alternative.
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  5. Folgender Benutzer sagt Danke zu .:WAGO::014731:. für den nützlichen Beitrag:

    gravieren (16.03.2015)

  6. #4
    Registriert seit
    10.05.2005
    Beiträge
    2.005
    Danke
    220
    Erhielt 234 Danke für 205 Beiträge

    Standard

    Zitat Zitat von .:WAGO::014731:. Beitrag anzeigen
    Die Ergebnisse der IEC-Funktionen müssen vorher an Variablen übergeben werden.
    O.K.

    Zitat Zitat von .:WAGO::014731:. Beitrag anzeigen
    Wenn FW02 ausreicht ist das natürlich auch eine Alternative.
    Zurück möchte ich ungerne.
    Nicht das ich dann eine "andere Baustelle" aufmache.
    Denn bis auf die Protokollierung bin ich fertig.
    Anlage läuft.


    Zitat Zitat von .:WAGO::014731:. Beitrag anzeigen
    Es soll aber bald seitens 3S eine Anpassung geben.
    Kann man etwas zum Datum sagen ?
    Könnte ich hier Informiert werden, sobald die neue Firmware herauskommt ?

    Danke vorab.
    Karl

  7. #5
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    19
    Danke
    0
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Hallo Karl,

    leider kann ich keine Angaben zum Zeitpunkt machen. Über eine neue Firmware wird im Wago Newsletter informiert, den man bei Wago anfordern kann.
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  8. #6
    Registriert seit
    10.05.2005
    Beiträge
    2.005
    Danke
    220
    Erhielt 234 Danke für 205 Beiträge

    Standard

    Die CoDeSys V2.3.9.47 von 3S ist seit dem 24.03.2015 downloadbar.

    Werde mal antesten, ob das Problem noch besteht.
    Karl

  9. #7
    Registriert seit
    10.05.2005
    Beiträge
    2.005
    Danke
    220
    Erhielt 234 Danke für 205 Beiträge

    Standard





    Jetzt kommt der Fehler:3125
    Und CoDeSys friert jetzt ein.
    Angehängte Grafiken Angehängte Grafiken
    Karl

  10. #8
    Registriert seit
    29.09.2014
    Ort
    Hessen
    Beiträge
    102
    Danke
    4
    Erhielt 22 Danke für 20 Beiträge

    Standard

    Sowas macht man ja auch nicht
    Lass die von wago freigegebene aktiv
    If you always do what you’ve always done, you’ll always get what you’ve always got.
    „Wer immer tut, was er schon kann, bleibt immer das, was er schon ist.“

    Henry Ford

  11. #9
    Registriert seit
    10.05.2005
    Beiträge
    2.005
    Danke
    220
    Erhielt 234 Danke für 205 Beiträge

    Standard

    Zitat Zitat von lord2k3 Beitrag anzeigen
    Sowas macht man ja auch nicht
    Lass die von wago freigegebene aktiv
    Warum ?

    Die Wago-Codesys ist identisch mit der von 3S.

    ZUSÄTZLICH sind noch die Targets und etwas Tools drinnen.
    (Z.b. Modbus-Konfigurator)

    Wurde so auch von Wago bestätigt !
    Karl

  12. #10
    Registriert seit
    29.09.2014
    Ort
    Hessen
    Beiträge
    102
    Danke
    4
    Erhielt 22 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Oben wurde dir die Lösung für das Problem geschrieben, wenn du das nicht umsetzt brauchst du nicht erwarten, dass es mit einer anderen codesys Version besser wird.
    If you always do what you’ve always done, you’ll always get what you’ve always got.
    „Wer immer tut, was er schon kann, bleibt immer das, was er schon ist.“

    Henry Ford

Ähnliche Themen

  1. Wago 750-8202 Problem Enocean 750-642
    Von hofstetter im Forum WAGO
    Antworten: 1
    Letzter Beitrag: 20.11.2014, 11:33
  2. TIMER_1 "OSCAT.lib" fehler 4010
    Von TomCatShS im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 27.08.2012, 10:45
  3. BC9000 und OSCAT.lib
    Von TomCatShS im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 27.08.2012, 01:10
  4. Antworten: 7
    Letzter Beitrag: 02.07.2012, 14:17
  5. codesys oscat lib fehler 3803
    Von domino im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 08.04.2010, 17:48

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •