Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Verständnis Problem "ethernet_modbusmaster_tcp "

  1. #1
    Registriert seit
    10.07.2008
    Beiträge
    47
    Danke
    19
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich nutze den oben genannten Baustein für eine Modusverbindung zw. 750-881 und 750-352.
    Zunächst einmal funktioniert alles und ich kann via InData[1].0 den ersten Binäreingang einlesen,
    sowie mit OutData[1].0 auch den ersten Binärausgang beschreiben.

    Mein Problem ist nun, das ich am 750-352 als fünfte Karte eine 750-461 (2AI PT100) anhehangen habe.
    Nun zeigt InData[1].0 immer 0 an (InData selber hat den Wert 10000). An der 750-461 Karte ist kein PT100 angeschlossen.

    Wieso funktioniert InData[1].0 nicht mehr?
    Und wie lese ich den Temperaturwert (sobald ich einen Fühler angeschlossen habe) aus?
    Zitieren Zitieren Verständnis Problem "ethernet_modbusmaster_tcp "  

  2. #2
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    45
    Danke
    0
    Erhielt 14 Danke für 13 Beiträge

    Standard

    Hallo Kiter11,

    durch das Hinzufügen einer analogen Eingangsklemme am Koppler 750-352 kommt es zu einer Verschiebung der Adressen für die digitalen Eingänge. Die Adressen der digitalen Ein- und Ausgänge liegen im Prozessabbild immer oberhalb der Adressen von analogen oder sonstigen komplexen IO-Modulen (seriellen Schnittstellen etc.). In Deinem Fall verschiebt sich die Adresse für die digitalen Eingänge um zwei Worte nach oben.

    Die beiden Eingangsworte der RTD-Klemme 750-461 enthalten jeweils den Temperaturwert in 1/10 Grad Celsius eines der beiden Sensoren. Ein Wert von z.B. 234dez entspricht also einer Temperatur von 23,4°C. Im SPS Programm muss also der Wert des Eingangswortes nur durch 10.0 geteilt werden. Werte von -2000dez bzw. -200,0 °C signalisieren einen Kurzschluß am AI. Wenn kein PT100 angeschlossen ist, wird die Karte einen Fühlerbruch anzeigen. In diesem Fall gibt sie 8500dez bzw. 850,0°C aus.
    Geändert von .:WAGO::014797:. (23.06.2015 um 08:13 Uhr)
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  3. Folgende 2 Benutzer sagen Danke zu .:WAGO::014797:. für den nützlichen Beitrag:

    Kiter11 (23.06.2015),Rudi (23.06.2015)

  4. #3
    Registriert seit
    10.07.2008
    Beiträge
    47
    Danke
    19
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    vielen Dank für die ausführliche Erklärung.
    Jetzt macht das ganze Sinn....

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 07.05.2015, 11:31
  2. Antworten: 8
    Letzter Beitrag: 07.05.2015, 08:25
  3. Antworten: 6
    Letzter Beitrag: 16.03.2012, 18:20
  4. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  5. Antworten: 2
    Letzter Beitrag: 14.12.2007, 15:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •