Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 24

Thema: e!Cockpit - erstes kleines feedback

  1. #1
    Registriert seit
    21.02.2011
    Ort
    Deutschland, Baden-Würtemberg
    Beiträge
    962
    Danke
    110
    Erhielt 119 Danke für 96 Beiträge

    Cool


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich möchte hier eine kleine Disskussion starten, welche sich allgemein um das e!cockpit von WAGO handeln soll.
    Eventuell können hier gefundene Bugs eingetragen werden oder einfach nur der Frust abgebaut werden.

    Ich fange damit mal an:

    System: Keines (reine Simulation)
    PC: Win 7 64bit pro
    e!cockpit: momentan Version 0.1.0.7855


    Ich denke, dass nach einer gewissen Eingewöhnungszeit die Arbeit mit der Software zunehmend leichter fallen wird.
    Da ich bisher niemals Codesys 3.5 verwendet habe, kann ich nicht sagen, welche Fehler und welche Vorteile nur alleine von Codesys stammen, also die folgenden Statements einfach bitte als Vergleich "Codesys 2.3" zu "E!cockpit" sehen.

    1. Ein heißes Thema für mich war immer schon die Web-Visualisierung die ja nun auf HTML5 basis läuft/laufen wird. Das bringt Riesenvorteile mit sich zumal Java ohnehin fast nirgends mehr unterstützt wird und auch nie richtig unterstützt wurde.

    Hier gefallen mir die vorgefertigten Visualisierungsobjecte und die Übersichtlichkeit der Einstellungen einzelnen Objekte. Ebenso ist es recht einfach, das ganze mal eben ohne jeden Controller und ohne große Einstellerei zu testen.

    Allerdings gibt es auch ein paar Fehler: Bei einem Klick auf ein Werkzeug geschieht es öfters, dass alle Werkzeuge verschwinden bis man auf ein anderes Fenster (z.B. Eigenschaften) und wieder zurück zu den Werkzeugen springt, das nervt etwas. Ebenso ist es für mich nicht möglich, Werkzeuge zu benutzen, sobald ich die Werkzeugleiste angedockt habe um Platz zu sparen, es erscheint ein "Ausnahmefehler".

    Die Scroll-Down Menüs der Eigenschafter sollten auch direkt zugänglich sein und nicht erst über einen doppelklick. Man kennt es ja, dass diese kleinen Nervereien am Schluss einiges an Zeit kosten wenn man sie summiert.


    2. Die Programmierung im Codesys 3.5 läuft bisher ganz unproblematisch und auch recht einfach. Besonders auffällig sind die tollen programmierhilfen (Schreibe IF, bekomme das END_IF direkt eingefügt). Ähnlich wie bei einer Java Programmierung. Gab es bei 2.3 nicht, daher ganz interessant für mich.

    3. Jede Applikation (GVL, Tasks, Visu, usw. usf.) muss manuell erstellt werden, bzw. wird bei entsprechender benutzung automatisch erstellt. Das macht den Programmteil recht übersichtlich, da alles unnötige gar nicht erst von Anfang an mit im Projekt eingebunden ist.

    4. DALI: hier wurde vor einiger Zeit die Klemme 750-647 eingeführt welche die 750-641 ersetzt. Diese scheint wohl nur über die gesonderte Software DALI Configurator programmierbar zu sein, was etwas nervig ist, zumal man vorher Visualisierungsobjekte einbinden konnte und so alle Funktionen über den Browers und die Webvisu abgedeckt hat. Da die 641 wohl bald entfällt muss man hier leider umsteigen.
    Im e!cockpit ist diese klemme (und auch einige andere) leider noch gar nicht vorhanden. Ich hoffe, dass sie bald implementiert wird, da ich sonst meine Software nicht im e!cockpit testen kann (oder nur teilweise)


    Ansonsten:
    Ich bin gespannt, wie die Übertragung eines großen Programms von 2.3 auf 3.5 (bzw. e!cockpit) von Statten gehen wird. Hoffentlich fix und unproblematisch, denn dann denke ich, werde ich mich mit der neuen Software anfreunden können.

    Eventuell werde ich gegen Ende des jahres schon von mir behaupten können, ein Codesys 3.5 Mitglied zu sein und muss mich dann leider der 2.3 Welt abwenden.

    Fazit:
    Meine bishere Einstellung --> PRO TIA Por.... äääähm e!cockpit!!
    Zitieren Zitieren e!Cockpit - erstes kleines feedback  

  2. #2
    Registriert seit
    26.11.2012
    Ort
    Gummersbach
    Beiträge
    478
    Danke
    18
    Erhielt 68 Danke für 66 Beiträge

    Standard

    Hmm, also ich weiß grad nicht, ob das ein Bug ist und kann nicht testen, ob es an meinem System liegt, aber ich habe folgendes Problem:

    Installation geht soweit, nach dem akzeptieren des Lizenzvertrages kommt die Meldung, das das Wago-USB Kabel bereits installiert sei und zunächst deinstalliert werden müsse.
    Hier auf Ja geklickt macht der Rechner einen Neustart nach der Deinstallation.
    Wenn ich nun versuche die Installation des E!Cockpit wieder aufzunehmen bricht die Installation ab, da noch eine andere Installation aktiv sei....

    Hat jemand spontan ne Idee, wie ich diesen "Installation läuft Merker" zurücksetze?

    Danke

    ##Edit##

    Hat funktioniert - der Rechner wollte zwar die fragliche Software nochmal deinstallieren, aber nun macht er anstandslos weiter mit der Installation.
    Hab einfach nur abgewartet...
    Geändert von Morymmus (25.06.2015 um 16:47 Uhr)
    Ganz kurz ganz hell
    ganz lange ganz dunkel....

  3. #3
    Registriert seit
    10.05.2005
    Beiträge
    1.959
    Danke
    217
    Erhielt 217 Danke für 199 Beiträge

    Standard

    HTML5 kostet Geld ?
    (Benötigt man eine Lizenz ?)
    Karl

  4. #4
    Avatar von KingHelmer
    KingHelmer ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.02.2011
    Ort
    Deutschland, Baden-Würtemberg
    Beiträge
    962
    Danke
    110
    Erhielt 119 Danke für 96 Beiträge

    Standard

    Also, anscheinend wird die e!cockpit Software lizenzpflichtig.
    Ob man seine Controller auch ohne e!cockpit, also nur mit Codesys und Targetdateien in betrieb nehmen kann weiß ich nicht, gehe aber fast davon aus.

  5. #5
    Registriert seit
    08.04.2014
    Ort
    Ruhrgebiet
    Beiträge
    74
    Danke
    8
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Hallo,
    teste doch mal die Zeile aus der Hilfe

    Var1 := DELETE ('SUXYSI',2,3);

    Was kommt bei Dir raus?

    Termi

  6. #6
    Registriert seit
    29.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    136
    Danke
    7
    Erhielt 67 Danke für 20 Beiträge

    Standard

    Hallo Termi,

    für manche Funktionen reicht in e!Cockpit die "einfache" Bezeichnung nicht aus um den Baustein nutzen zu können, dies liegt an einer mehrfachen Verwendung des Namens.
    Der Name Delete wird z.B. in den Bibliotheken Standard und WagoTypesCommon_1.0.0.3 verwendet und kann in der Applikation nicht eindeutig zugewiesen werden.
    In diesen Fällen der doppelten Namensvergebung ist der Namensraum-Präfix zu verwenden.
    Beispiel: Standard.Delete

    In der Eingabehilfe [F2] kann die Option Namensraum-Präfix einfügen aktiviert werden um mit der Eingabehilfe eingefügte Funktionen automatisch mit dem Namensraum-Präfix zu versehen.
    Geändert von .:WAGOsupport:. (02.07.2015 um 17:30 Uhr)
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com

    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  7. Folgender Benutzer sagt Danke zu .:WAGOsupport:. für den nützlichen Beitrag:

    Termi (02.07.2015)

  8. #7
    Registriert seit
    07.07.2011
    Ort
    Schrobenhausen/Schiefling
    Beiträge
    210
    Danke
    33
    Erhielt 26 Danke für 20 Beiträge

    Standard

    Hi all,
    höre das erste Mal vom e-cockpit.
    Als Nutzer von Codesys 2.3 auf 750-881 habe ich in Erinnerung, daß Codesys 3.0 nicht unterstützt wird => e-cockpit auch nicht.
    Stimmt das?
    Andererseits habe ich mich seinerzeit für eine IEC...Steuerung mit Codesys entschieden um unabhängig von einem bestimmten Hersteller zu sein und ggf. in der Zukunft meine SW einfach auf eine andere HW portieren zu können. Mache ich mir diesen Vorteil durch ein (proprietäres?) e-cockpit zunichte?
    Natürlich wäre es schöner bei der Visu flexibler bzw. entkoppelter zu werden aber um welchen Preis?
    Gruß

  9. #8
    Registriert seit
    29.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    136
    Danke
    7
    Erhielt 67 Danke für 20 Beiträge

    Standard

    Hallo tomrey,

    Steuerungen wie die 750-88X werden wie gewohnt mit CODESYS 2.3 programmiert, diese können nicht mit e!Cockpit programmiert werden.
    Die Serie PFC200 (750-820X) sind "hybriden" und sofern diese ab Werk mit der FW03 ausgeliefert werden, mit CODESYS 2.3 oder unserer neuen Engineering-Software e!Cockpit programmierbar.
    Bei e!Cockit handelt es sich derzeit um eine Pre-Release Version. Weitere Informationen zu e!Cockpit findest du auf unserer Webseite: http://www.wago.de/produkte/neuheite...g-software.jsp
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com

    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  10. #9
    Registriert seit
    05.05.2012
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen,

    ich mache gerade erste Erfahrungen mit e!Cockpit.
    Abgesehen von einigen kleinen Fehlern, welche vorrangig die Bedienung betreffen, macht das e!Cockpit einen sehr guten Eindruck.
    Die Objektorientierung in Codesys öffnet natürlich neue Möglichkeiten bei der Umsetzung.
    Nun ist mir bei den ersten Tests folgendes aufgefallen:
    Beim Load eines Programmes mit Visu in die Simulation erhalte ich eine Fehlermeldeung: "Fehler bem Übertragen der Datei".
    Diese Fehlermeldung beziet sich auf die Visu. (Steht zwar nicht drin, sollte aber so sein, da beim Load eines Programmes ohne Visu diese Fehlermeldung nicht erscheint.)
    Nach Bestätigen mit OK und erneutem Start der Simulation kann getestet werden.
    Hat jemand eine Idee mit was das zusammen hängen könnte ?

    Viele Grüße
    Thomas
    Geändert von p2492 (05.07.2015 um 14:14 Uhr)

  11. #10
    Registriert seit
    29.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    136
    Danke
    7
    Erhielt 67 Danke für 20 Beiträge

    Daumen hoch


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen,

    wir freuen uns, dass Ihr Euch bereits so zahlreich mit unserer neuen Engineeringsoftware e!COCKPIT auseinandersetzt und uns Euer Feedback dazu gebt. Dieses ist für die weitere Entwicklung immens wichtig - und daher gibt es dafür auch ein
    RIESIGES D A N K E S C H Ö N ! ! !

    Hier kommen nun ein paar aufklärende Worte zu den o.g. Anmerkungen:

    @KingHelmer
    Zitat Zitat von KingHelmer Beitrag anzeigen
    [...]Allerdings gibt es auch ein paar Fehler: Bei einem Klick auf ein Werkzeug geschieht es öfters, dass alle Werkzeuge verschwinden bis man auf ein anderes Fenster (z.B. Eigenschaften) und wieder zurück zu den Werkzeugen springt, das nervt etwas. Ebenso ist es für mich nicht möglich, Werkzeuge zu benutzen, sobald ich die Werkzeugleiste angedockt habe um Platz zu sparen, es erscheint ein "Ausnahmefehler".
    Die Scroll-Down Menüs der Eigenschafter sollten auch direkt zugänglich sein und nicht erst über einen doppelklick. Man kennt es ja, dass diese kleinen Nervereien am Schluss einiges an Zeit kosten wenn man sie summiert.[...]
    • Den Fehler der verschwindenden Werkzeugleiste haben wir behoben und wird Euch in Kürze zur Verfügung gestellt.
    • Den Ausnahmefehler konnten wir auf mehreren Testinstallationen leider nicht nachvollziehen.
    • Der (unnötige) Doppelklick ist bei unserer Entwicklung eingelastet. Hier gehen wir von einer zeitnahen Verbesserung des Verhaltens aus.


    Zitat Zitat von KingHelmer Beitrag anzeigen
    [...]DALI: hier wurde vor einiger Zeit die Klemme 750-647 eingeführt welche die 750-641 ersetzt. [...]
    Im e!cockpit ist diese klemme (und auch einige andere) leider noch gar nicht vorhanden. Ich hoffe, dass sie bald implementiert wird, da ich sonst meine Software nicht im e!cockpit testen kann (oder nur teilweise)[...]
    • Im ersten Release, dass wir in Kürze erwarten, wird die Unterstützung von Gebäudeautomations-typsichen Anwendungen nicht gegeben sein.
    • Die für die Gebäudeautomation typischen Module und Bibliotheken auf Basis des PFC200 werden es voraussichtlich erst zum Ende des Jahres 2015 ins e!COCKPIT schaffen.


    Zitat Zitat von KingHelmer Beitrag anzeigen
    Also, anscheinend wird die e!cockpit Software lizenzpflichtig.
    Ob man seine Controller auch ohne e!cockpit, also nur mit Codesys und Targetdateien in betrieb nehmen kann weiß ich nicht, gehe aber fast davon aus.
    • Wie auch die CODESYS V2.3 basierende WAGO-IO-Pro (=CODESYS V2.3 + Targets) wird auch e!COCKPIT lizenzpflichtig werden.
    • Leider werden wir nach derzeitiger Planung keine Unterstützung eines nativen CODESYS V3 anbieten (können). Die vielen Komfortfunktionen in e!COCKPIT bedingen eine entsprechende Runtime auf den Geräten. Der Spagat, mit e!COCKPIT erweiterte und von unseren Kunden gewünschte Funktionalitäten anzubieten und dennoch eine native CODESYS V3-Unterstützung zu implementieren, war nicht zu schaffen.


    @tomrey
    Zitat Zitat von tomrey Beitrag anzeigen
    [...]Andererseits habe ich mich seinerzeit für eine IEC...Steuerung mit Codesys entschieden um unabhängig von einem bestimmten Hersteller zu sein und ggf. in der Zukunft meine SW einfach auf eine andere HW portieren zu können. Mache ich mir diesen Vorteil durch ein (proprietäres?) e-cockpit zunichte?[...]
    • Der Programmcode und auch die Visualisierung wird mit den Editoren der CODEYS V3 erstellt, da e!COCKPIT auf dem CODESYS V3 Framework aufsetzt. Hinsichtlich Know-How und Investitionsschutz bleibst Du also unabhängig, da wir hier keine "proprietären Erweiterungen" vorsehen. Bei den WAGO relevanten Ansichten (Stationsansicht, wie aus WAGO-IO-Check gewohnt, oder der Netzwerkansicht) wollen wir die Handhabung mit unseren Produkten verbessern. Solltest Du das Steuerungssystem wechseln wollen/müssen, musst Du die Steuerungskonfiguration also neu durchführen. Das wäre aber sowieso notwendig gewesen, daher ist der Einsatz von e!COCKPIT kein Nachteil und steht Dir bei einer Portierung Deiner Software nicht im Wege.



    Das soll's für's Erste gewesen sein. Bei weiteren Fragen könnt Ihr uns auch gerne unter den unten genannten Adressdaten direkt kontaktieren.
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com

    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

Ähnliche Themen

  1. Das neue e!COCKPIT...
    Von Termi im Forum WAGO
    Antworten: 19
    Letzter Beitrag: 06.04.2016, 18:16
  2. Zylinderpositionsschalter als Feedback
    Von weißnix_ im Forum PILZ
    Antworten: 4
    Letzter Beitrag: 13.04.2015, 08:34
  3. Bitte um Feedback
    Von xvitali im Forum Programmierstrategien
    Antworten: 21
    Letzter Beitrag: 19.09.2008, 15:50
  4. Feedback CommentSearch
    Von sps-concept im Forum Werbung und Produktneuheiten
    Antworten: 3
    Letzter Beitrag: 27.08.2005, 16:19

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •