Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Serielle Kommunikation mit Wago 750-650

  1. #1
    Registriert seit
    29.07.2015
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich bin Neuling, was die SPS-Programmierung angeht. Das Auslesen von digitalen oder analogen Klemmen hab ich mittlerweile hinbekommen, jetzt versuche ich eine serielle Kommunikation mit der Klemme 750-650/000 003 zu implementieren.
    Dazu habe ich mir einige Beispielprogramme angesehen, aber so ganz schlau werde ich da nicht draus. Konkret habe ich mir das "SerialInterface_Sample01" von http://www.wago.com/wagoweb/document...a110901d_f.htm angesehen. Da kann ich aber wegen eines Fehlers die Hardware Konfiguration nicht ändern und das deshalb nicht wirklich nutzen. Daraufhin habe ich alle Programmteile in ein neues Programm kopiert, da entsprechende Hardware-Einstellungen gemacht und es wieder probiert. Aber ich messe garnichts an der Klemme, also scheint das auch nicht zu funktionieren.
    Jetzt die überraschende Frage: Warum? Hat jemand ein gutes Tutorial zur Hand oder Tipps was ich probieren könnte, um irgendeinen Output zu produzieren? So, dass ich merke, dass ich wenigstens auf dem richtigen Weg bin? Oder gibt es noch weitere Initialisierungseinstellungen, die ich noch an irgendeiner Stelle machen muss?

    Danke im Voraus!
    Zitieren Zitieren Serielle Kommunikation mit Wago 750-650  

  2. #2
    Olle ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.07.2015
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo nochmal!
    Nach weiterem stumpfen rumprobieren bin ich jetzt soweit, dass die Klemme tatsächlich sendet. Anscheinend habe ich da wieder irgendetwas in einer falschen Umgebung zugewiesen...
    Jetzt habe ich aber ein anderes Problem:
    Ich möchte unter anderem Steuerzeichen über die serielle Schnittstelle senden, unter anderem ein [ENT] bzw [ENQ] was hexadezimal einer 04 bzw 05 entspricht (BISYNCH-Protokoll). Die hexadezimalen Werte rahmen dann eine ASCII-Nachricht ein, ungefähr so: hex(04)ascii(0022PV)hex(05) mit den ensprechenden Konvertierungen. Hat jemand eine Idee, wie ich das umsetzen kann? Oder wie es ggf besser zu machen ist?

  3. #3
    Olle ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.07.2015
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hab das jetzt auch hinbekommen. Einfach mit $04 bzw $05. Weiß denn jemand, wie ich ein $00 in einen String adden kann? Mit CONCAT geht das nicht, der lässt das einfach unter den Tisch fallen...

Ähnliche Themen

  1. Suche wago 750-650/003-000
    Von Controllfreak im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 16.06.2013, 13:06
  2. WAGO RS232 750-650 an Profibus
    Von berty im Forum Feldbusse
    Antworten: 0
    Letzter Beitrag: 15.11.2007, 10:55
  3. WAGO 750-650 RS232 mit S7
    Von S.Scholl im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 15.09.2006, 20:34
  4. Wago 750-650 mit Delphi und MBT.dll
    Von Anonymous im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 22.10.2004, 21:22

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •