Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Modbus Problem mit über 120 Teilnehmer

  1. #1
    Registriert seit
    06.10.2015
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich setze einen Controller 750-880 ein.
    Dahinter habe ich diverse DI | DO | AI | AO | 5 MP-Bus klemmen | und weitere 7 Serielle Klemmen | Endklemme

    Serielle Klemme Nr. 1 (Com Port2) MBUS - funktioniert komplett
    Serielle Klemme Nr. 2 (Com Port3) MODBUS - funktioniert komplett
    Serielle Klemme Nr. 3 (Com Port3) MODBUS - funktioniert nicht, Fehler Dez. 15, Hex. 0C, bInterfaceErrorMaster
    Serielle Klemme Nr. 4 (Com Port3) MODBUS - funktioniert nicht, Fehler Dez. 15, Hex. 0C, bInterfaceErrorMaster
    Serielle Klemme Nr. 5 (Com Port3) MODBUS - funktioniert teilweise
    Serielle Klemme Nr. 6 (Com Port3) MODBUS - funktioniert teilweise
    Serielle Klemme Nr. 7 (Com Port3) MODBUS - funktioniert teilweise

    Bei den wo es Teilweise funktionier geht zwar die Abfrage der Teilnehmer
    FunctionCode :=16#04;
    Read_StartAddress := 0;
    Read_Quantity:= 34;

    Jedoch geht nicht das vorgeben von Werten:FunctionCode :=16#10;
    Write_StartAddress := 11;
    Write_Quantity:= 23;



    Das interessante daran ist das ein TIME OUT Dez. 153 Hex. 16#99 kommt, nicht das die Daten falsch sind Dez. 144 .
    Das gleiche Programm und der selbe FB (Vorlange Modbus-teilnehmer) wird auch für die Serielle Klemme 2 - Port 3 benutzt und funktioniert einwandfrei.

    Task Zyklisch: 10ms im Avg. durchlaufzeit 8ms
    Baud 19200
    8 Datenbits
    1 Stop Bit
    Even
    Maximale anzahl Teilnehemer pro Serielle Karte: 23 Stk.


    Ich gehe davon aus das die beiden Karten mit dem Fehler defekt sind, dort sind nun bereits neue bestellt.
    Vielleicht hat jemand ein ähnliches Problem bereits gehabt und kann mir dabei auf die Sprünge helfen.

    LG
    PvH
    Zitieren Zitieren Modbus Problem mit über 120 Teilnehmer  

  2. #2
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    127
    Danke
    6
    Erhielt 35 Danke für 25 Beiträge

    Standard

    Hallo PvH,

    ist die Angabe richtig, dass du für alle Module ab Klemme 2 den Com Port 3 benutzt?
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  3. #3
    PvH ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    06.10.2015
    Beiträge
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    natürlich nicht, ist ein Copy+Paste Fehler.....


    Serielle Klemme Nr. 1 (Com Port2) MBUS - funktioniert komplett
    Serielle Klemme Nr. 2 (Com Port3) MODBUS - funktioniert komplett
    Serielle Klemme Nr. 3 (Com Port4) MODBUS - funktioniert nicht, Fehler Dez. 15, Hex. 0C, bInterfaceErrorMaster
    Serielle Klemme Nr. 4 (Com Port5) MODBUS - funktioniert nicht, Fehler Dez. 15, Hex. 0C, bInterfaceErrorMaster
    Serielle Klemme Nr. 5 (Com Port6) MODBUS - funktioniert teilweise
    Serielle Klemme Nr. 6 (Com Port7) MODBUS - funktioniert teilweise
    Serielle Klemme Nr. 7 (Com Port MODBUS - funktioniert teilweise


    Die Steuerungskonfiguration via I/O Check zur Steuerungskonfiguration zur Wago sprich die Datenbreiten der Karten sind bereits öfter geprüft.

Ähnliche Themen

  1. Step 7 Problem mit erreichbare Teilnehmer
    Von spirit im Forum Simatic
    Antworten: 42
    Letzter Beitrag: 17.01.2015, 12:52
  2. Modbus über ET200s Modbus Master Modul
    Von vollmi im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 19.11.2012, 14:37
  3. Problem mit Modbus bei Write Coil
    Von Mobi im Forum Sonstige Steuerungen
    Antworten: 8
    Letzter Beitrag: 06.10.2011, 23:52
  4. Problem CP-341-> Modbus Slave mit Zxx_21_04
    Von Wagginator im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 27.06.2011, 10:09
  5. Antworten: 0
    Letzter Beitrag: 05.08.2010, 08:14

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •