Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: WAGO PWM-Signal mit 750-670

  1. #1
    Registriert seit
    06.06.2015
    Beiträge
    35
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Liebe Leut,

    ich möchte mit einer WAGO 750-670 ein PWM-Signal erzeugen und damit einen Modellbau-Servo ansteuern.
    Meine Fragen hierzu:
    1. Das Modul hat 2 Ausgänge. Kann ich damit 2 PWM unabhängig erzeugen? Abgriff an Klemme A1 sowie an Klemme B1?
    2. Mit welcher Logik geht das? In der Stepper_02.lib ist zwar ein Baustein vorhanden MC1_PWM_Mode, dieser ist aber offensichtlich für kompliziertere Aufgaben vorgesehen. D.h. dessen Beschaltung ist mir völlig unkla.
    3. Wie teile ich der Baugruppe überhapt mit, dass sie als PWM arbeiten soll?
    4. Ich benötige nur Voragaben: Ein/Aus - Frequenz (i.A. 50 Hz) - Pulsweite (i.A. 1,0 ms ... 2,0 ms)
    5. Oder kann man auf einen anderen Baustein (z.B. aus der Regelungswelt) zurückgreifen? Aber wie geht das mit der Adressierung?

    Oh, wenn jemand dazu ne Anhnung hätte...
    Bitte um Hilfe.
    Zitieren Zitieren WAGO PWM-Signal mit 750-670  

  2. #2
    Registriert seit
    06.06.2015
    Beiträge
    35
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Noch einen Dateianhang hinzugefügt ...

    PWM mit WAGO 750-670.pdf
    Zitieren Zitieren Noch einen Dateianhang hinzugefügt ...  

  3. Folgender Benutzer sagt Danke zu Inerax für den nützlichen Beitrag:


  4. #3
    Registriert seit
    04.09.2012
    Beiträge
    54
    Danke
    4
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Die erste Frage kann ich Dir beantworten:
    Die Klemme hat nur einen Kanal. Nur das Signal von A und B ist um 90° Versetzt (für Schrittmotoren).

  5. #4
    Registriert seit
    06.06.2015
    Beiträge
    35
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Zitat Zitat von Caroli Beitrag anzeigen
    Die erste Frage kann ich Dir beantworten:
    Die Klemme hat nur einen Kanal. Nur das Signal von A und B ist um 90° Versetzt (für Schrittmotoren).
    Ach so. Danke.
    Geändert von Inerax (12.11.2015 um 13:14 Uhr) Grund: Unvollständig abgesendet.

  6. #5
    Registriert seit
    13.10.2013
    Ort
    shertogenbosch niederlande
    Beiträge
    120
    Danke
    0
    Erhielt 8 Danke für 6 Beiträge

    Standard

    modelbau ist meistens nur 5 volt, und PWM ist kein SERVO.
    ein 5 volt signal mit 2 ms laufzeit ist nicht im program, aber mit umwegen ist es moglich mit den stepper, die aber viel zu schwer ist fur ein modelbau.

    ich wurde arduino benutzen, das ist billger und kleiner.
    ich benutze die arduino ofter als umsetzer zwischen die PLC und die machine.
    ich mache aus anaolg signal vom PLC ein PWM fur steuerung von ventile.
    die moderne version geht uber ethernet mit wago PLC und raspberry pie
    paul deelen
    shooter@home.nl
    +31736139136

  7. #6
    Registriert seit
    06.06.2015
    Beiträge
    35
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Zitat Zitat von computershooter Beitrag anzeigen
    modelbau ist meistens nur 5 volt, und PWM ist kein SERVO.
    ein 5 volt signal mit 2 ms laufzeit ist nicht im program, aber mit umwegen ist es moglich mit den stepper, die aber viel zu schwer ist fur ein modelbau.

    ich wurde arduino benutzen, das ist billger und kleiner.
    ich benutze die arduino ofter als umsetzer zwischen die PLC und die machine.
    ich mache aus anaolg signal vom PLC ein PWM fur steuerung von ventile.
    die moderne version geht uber ethernet mit wago PLC und raspberry pie
    Hallo Computershooter,

    vielen Dank für deine Nachricht.
    Mit Arduino ist mir bekannt. Hier geht es zwar um einen Modellbaumotor aber um eine Industrieapplikation.
    Diese soll komplett mit SPS realisiert werden.
    Dafür verwende ich nun die 750-670. Diese bringt auch (laut Herstellerangabe) die geforderte Frequenz und Pulsweite. Und die habe ich nun auch gekauft.
    Eine Alternative wäre die 750-511. Diese eignet sich zur Ansteuerung von Ventilen. Verwendest du diese?
    Kannst du mir bitte vielleicht eine Miniapplikation zur Verdeutlichung deren Verwendung zukommen lassen?

    Viele Grüße
    Inerax
    Zitieren Zitieren WAGO PWM-Signal mit 750-670  

  8. #7
    Registriert seit
    13.10.2013
    Ort
    shertogenbosch niederlande
    Beiträge
    120
    Danke
    0
    Erhielt 8 Danke für 6 Beiträge

    Standard

    bedenke das die wago alles 24 volt ist (nur die encoder sind 5 volt.
    und eine model servo ist nur 5 volt, also du brauchst ein paar widerstande um die richtige voltage zu geben.

    ja es geht mit die klemme die du angebst.
    schreibe dieses bericht in wago forum, dan bekommst du noch besser antwort.

    fur den servo treiber bedenke timing,resolution. geschwindigkeit also eine art ramp function damit einen motor nicht ruckt und zuckt.
    was passiert wenn die plc nicht schnell genug oder noch nicht pulse gibt.
    paul deelen
    shooter@home.nl
    +31736139136

  9. #8
    Registriert seit
    06.06.2015
    Beiträge
    35
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Es war irgendwie nicht leicht, die Handbücher nicht verständlich.
    Aber mit WAGO Support und viel rumgemache funktioniert es nun.
    Falls jemand noch mal das gleiche Problem hat - im Dateianhang ist die Lösung.
    Die Hardwarebeschaltung ist unbedingt zu beachten.

    Grüße
    Inerax
    Angehängte Dateien Angehängte Dateien
    Zitieren Zitieren Endlich funktioniert es!  

Ähnliche Themen

  1. Biete: Wago 750-511 PWM Klemme
    Von Sancho im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 10.11.2014, 11:21
  2. Step 7 PWM Signal?
    Von ronnie.b im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 23.05.2013, 10:44
  3. PWM Signal mit digitaler Ausgangskarte
    Von Werner1 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 28.02.2012, 10:41
  4. PWM Signal >= 100Hz. Keine C-CPU !
    Von noeppkes im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 21.06.2010, 15:51
  5. PWM Signal erzeugen mit S7-312c und SFB 49
    Von Anonymous im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 24.06.2005, 16:44

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •