Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Wago-S7 Datentausch Error TCP Client 32771

  1. #1
    Registriert seit
    02.02.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Lächeln


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo alle

    Ich bin anfänger und versuche durch die Funktion DB_ReadWrite2 von der WagoLibDB.lib Bibliothek Daten von einem 750-880 aus einem S7-1200 zu lesen und zu schreiben, dazu habe ich ein FUP programm gestaltet und hat schon geklappt.

    Aber es passiert folgendes, wenn man aus irgend einem Grund erst das Ausführen (Execute) vor dem Verbindiungsaufbau (xOpen) ausführt und dann es wieder auf der richtigen Reihenfolge versucht (Wie ihr wisst das richtige ist Verbindung aufbauen und dann ausführen ja klar) kann die Verbindung zwischen die zwei PLCs nicht mehr aufgebaut werden und absolut NUR nach einem RESET der S7 Steuerung wiederhergestellt werden. Es passiert auch wenn man unzulässige Parameter eingibt.

    Egal was man in CodeSys macht: RESET, Alles Bereinigen, Wago aus- und einschalten es kommt immer wieder ein Error TCP Client 32771, der wie gesagt nach einem RESET der S7 "aufgehoben" wird.

    Ich würde gerne wissen ob mann von der Wago seite, etwas machen könnte um dieser Error 32771 aufzuheben, ich würde nicht immer Zugriff auf der S7 haben deshalb meine Verzweifelung.

    Ich habe schon im google gesucht was dieser Fehler heißt und habe nichts gefunden, und auch nicht hier im Forum.

    Ich hoffe jemand kann mir helfen.

    Vielen Dank

    jmonts
    Zitieren Zitieren Wago-S7 Datentausch Error TCP Client 32771  

  2. #2
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    125
    Danke
    6
    Erhielt 34 Danke für 25 Beiträge

    Standard

    Hallo jmonts,

    Fehler 32771 wäre 'Socket was 'gracefully closed'' aus der SysLibSockets.
    Ich versuche deinen Workflow mal nachzustellen.
    Kannst du mir die Firmware deines 750-880 noch schreiben?
    Geändert von .:WAGO::015844:. (04.02.2016 um 14:45 Uhr)
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  3. #3
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    125
    Danke
    6
    Erhielt 34 Danke für 25 Beiträge

    Standard

    Hallo jmonts,

    ich kann das Verhalten so nicht bestätigen.
    Für eine weitere Diagnose bräuchte ich den Firmwarestand des 880, sowie deine Programme.
    Unter Umständen kann das Verhalten auch durch die Siemens Steuerung ausgelöst werden.
    Hast du dort mal ein Firmwareupdate versucht?
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  4. #4
    jmonts ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Wago Team

    Danke für die Unterstützung.

    Ich hatte inzwischen realisiert dass der Fehler "Socket was 'gracefully closed'' heißt, kriege ich den aber noch nicht abgehoben.

    Mein 750-880 hat FW 01.05.32(08 ) und der S7-1200 hat die FW 1.0.1 . Ich habe aber nicht die Möglichkeit das FW von der S7 zu aktualisieren.

    Ich verbrauche ganz einfach das DB_ReadWrite2 block in FUP ohne weiteres.

    Kann man trotzdem irgendwie dieser Socket offen halten??

    Vielen Dank Wago Support Team

    jmonts

  5. #5
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    125
    Danke
    6
    Erhielt 34 Danke für 25 Beiträge

    Standard

    Hallo jmonts,

    um deinem Problem näher auf den Grund zu gehen, würde ich dich bitten dich direkt bei uns zu melden.
    Unter Umständen müsste man sich deine Programme mal anschauen und ggf. eine Aufzeichnung des Datenverkehrs ansehen.
    Ich denke um das im Forum zu lösen ist das Problem zu spezifisch.
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  6. #6
    jmonts ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Per Mail oder Telefonisch?

  7. #7
    jmonts ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wie kann man der Datenverkehr ansehen?

  8. #8
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    125
    Danke
    6
    Erhielt 34 Danke für 25 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo jmonts,

    mail oder telefonisch wäre erstmal egal.
    Der Datenverkehr lässt sich mit dem Tool Wireshark betrachten. Dazu lässt sich die Portspiegelung an deinem 750-880 nutzen.
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

Ähnliche Themen

  1. Beckhoff TCP/IP Client Baustein
    Von BorisDieKlinge80 im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 27.11.2012, 12:34
  2. Wago WAC error
    Von vollmi im Forum WAGO
    Antworten: 9
    Letzter Beitrag: 24.08.2012, 15:58
  3. wago 750-841 KBus Error
    Von Bruno05 im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 25.02.2011, 05:56
  4. Unterschied Server-Client (Modbus-TCP)
    Von Drain im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 09.07.2007, 07:41
  5. Antworten: 1
    Letzter Beitrag: 28.09.2006, 07:15

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •