Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 30

Thema: Wago 750-841 mit SPS 314C-2 PN/DP verbinden, Visualisierung mit Laptop

  1. #1
    Registriert seit
    07.03.2012
    Beiträge
    27
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    stehe vor einem für mich unlösbarem Problem, für das ich noch nicht mal annähernd an einen Lösungsansatz komme.. Aufgabenstellung ist leider so vorgegeben wie beschrieben, ob das jetzt sinnvoll ist oder nicht, sei mal dahingestellt.

    Es geht um folgendes:

    Ich habe auf eine Wago 750-841 mit zahlreichen Busklemmen sämtliche Ein- und Ausgänge meiner Anlage (Pick-and-Place-Station) angeklemmt. Die Wago selber soll keine Programmierung aufweisen. Ich soll eine SPS (CPU 314C-2 PN/DP) mit Ethernet mit der Wago verbinden. Die eigentliche Programmsteuerung übernimmt die SPS. Visualisiert werden soll das ganze noch mit einem Laptop, der ebenfalls über Ethernet an die SPS angeschlossen wird.

    Ich hoffe man versteht einigermaßen mein Problem..

    Ist dieses Problem überhaupt zu lösen, oder ist die Aufgabe, so wie angedacht, gar nicht realisierbar? Wie realisiere ich das Ganze am Besten? Bin dankbar für jede Hilfe.

    Freundliche Grüße

    Fabian
    Zitieren Zitieren Wago 750-841 mit SPS 314C-2 PN/DP verbinden, Visualisierung mit Laptop  

  2. #2
    Registriert seit
    25.02.2010
    Beiträge
    618
    Danke
    35
    Erhielt 121 Danke für 110 Beiträge

    Standard

    Hallo Fabian
    Ist dieses Problem überhaupt zu lösen, oder ist die Aufgabe, so wie angedacht, gar nicht realisierbar? Wie realisiere ich das Ganze am Besten? Bin dankbar für jede Hilfe.
    Ich verstehe dein Problem nicht. Hier hast du alle Antworten auf deine Fragen und sogar ein Beispiel. Wo klemmt es denn jetzt?

    Wago 750-841 parametrieren

  3. #3
    solosi ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.03.2012
    Beiträge
    27
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das Problem besteht eher grundsätzlich.. Mir fehlt das Verständnis, wie ich überhaupt rangehen soll..

  4. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Die mit weitem Abstand beste Lösung:
    Ersetze die 750-841 gegen 750-370 (Profinet Koppler)


    Ansonsten musst du mit Modbus TCP arbeiten: https://support.industry.siemens.com.../view/22660304

    Die Registerbelegung findest du wiederum im Wago Handbuch.

    Mfg
    Manuel
    Geändert von MSB (10.02.2016 um 06:09 Uhr)
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. #5
    Registriert seit
    25.02.2010
    Beiträge
    618
    Danke
    35
    Erhielt 121 Danke für 110 Beiträge

    Standard

    Du nimmst den FB823 aus dem Wago Beispiel.
    Wago nutzt Funktionscode 23
    881-Seite223.pdf

    In der Übersicht siehst du, dass deine Eingänge bei Adresse 0 beginnen. Wenn du also an dem FB "zu lesende Adresse" 0 einstellst und eine Länge von 1 dann hast du die ersten 16 digitalen Engänge in deinem gelesenem Word.
    Holger

    Manuel hat allerdings recht. Der 841 ist sicherlich die schlechteste Wahl für die Aufgabe.

  6. #6
    Registriert seit
    30.11.2008
    Ort
    Baesweiler
    Beiträge
    830
    Danke
    255
    Erhielt 120 Danke für 87 Beiträge

    Standard

    Zitat Zitat von solosi Beitrag anzeigen
    Hallo Leute,

    stehe vor einem für mich unlösbarem Problem, für das ich noch nicht mal annähernd an einen Lösungsansatz komme.. Aufgabenstellung ist leider so vorgegeben wie beschrieben, ob das jetzt sinnvoll ist oder nicht, sei mal dahingestellt.

    Es geht um folgendes:

    Ich habe auf eine Wago 750-841 mit zahlreichen Busklemmen sämtliche Ein- und Ausgänge meiner Anlage (Pick-and-Place-Station) angeklemmt. Die Wago selber soll keine Programmierung aufweisen. Ich soll eine SPS (CPU 314C-2 PN/DP) mit Ethernet mit der Wago verbinden. Die eigentliche Programmsteuerung übernimmt die SPS. Visualisiert werden soll das ganze noch mit einem Laptop, der ebenfalls über Ethernet an die SPS angeschlossen wird.

    Ich hoffe man versteht einigermaßen mein Problem..

    Ist dieses Problem überhaupt zu lösen, oder ist die Aufgabe, so wie angedacht, gar nicht realisierbar? Wie realisiere ich das Ganze am Besten? Bin dankbar für jede Hilfe.

    Freundliche Grüße

    Fabian
    Ich gehe mal davon aus, dass du auch nicht über die Wago Software verfügst zur Programmierung der Steuerung?

    gruss Markus
    gruss Markus

  7. #7
    solosi ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.03.2012
    Beiträge
    27
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen,

    nein ich verfüge nicht über die Wago Software zur Programmierung.. Wie gesagt, das Hauptproblem ist eben, das die Aufgabenstellung mit exakt diesem Controller fest vorgegeben ist und ich damit arbeiten soll.. Das das die schlechteste Wahl für meine Aufgabe ist, war mir bis dato nicht bewusst, ist aber wie gesagt vorgegeben.

  8. #8
    solosi ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.03.2012
    Beiträge
    27
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    http://www.wago.com/wagoweb/document...4/a101400d.pdf

    Kann ich nach dieser Anleitung vorgehen oder funktioniert das für meinen Controller nicht?
    Kann man den Modbus eigentlich frei benutzen oder muss da vorher noch was freigeschaltet werden?

  9. #9
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Zumindest bezogen auf Siemens ist alles was du darin lesen kannst relativ nutzlos, weil sich das Programmhandling des CP343-1 seeehr vom Handling der integrierten PN-Schnittstelle unterscheidet.
    Das was du zu Wago lesen kannst, könnte prinzipiell schon passen.

    P.S. Nur um das abschließen zu klären: Schulaufgabe ?
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  10. #10
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    125
    Danke
    6
    Erhielt 34 Danke für 25 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Solosi,

    bitte schau dir folgende Anwendungshinweise an. Das sollte für dich die beste Lösung darstellen.
    Voraussetzung ist, dass deine CPU nicht zu alt ist und die Verbindung unterstützt.

    S7 Modbus Baustein für Kommunikation mit PN CPU 300 & 400
    http://www.wago.de/suche/index.jsp?a...36393290723199

    S7 Modbus Baustein für Kommunikation mit PN CPU 1200 & 1500
    http://www.wago.de/suche/index.jsp?a...28957930584154
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

Ähnliche Themen

  1. Antworten: 7
    Letzter Beitrag: 24.01.2014, 06:35
  2. Antworten: 1
    Letzter Beitrag: 27.06.2013, 15:02
  3. Wago 750-304 mit 750-841 betreiben!
    Von Lekta im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 06.02.2012, 20:42
  4. s7-300 verbinden mit wago 841
    Von commander99 im Forum CODESYS und IEC61131
    Antworten: 13
    Letzter Beitrag: 12.12.2007, 16:56
  5. 750-841 mit 750-341 verbinden
    Von cassini im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 15.10.2007, 22:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •