Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Modbus PLC 750-8202

  1. #1
    Registriert seit
    28.10.2015
    Beiträge
    30
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo
    Ich will mit Modbus experimentieren aber habe einige probleme.
    Ich bekomme beim deployment in codesys folgende fehlermeldung :

    Folgende Funktion konnte nicht eingebungen werden:
    ETHERNET_CLIENT_CLOSE
    ETHERNET_CLIENT_CLOSEinit
    .....

    Folgende Bibs habe ich im Projekt hinzugefügt:
    Ethernet.lib
    ModbusEthernet04
    mod_com.lib


    Der Code:

    TON1(IN:= KOMMU_E2.xREADY, PT:= T#0.1s);
    KOMMU_E2(
    strIP_ADDRESS:='192.12.3.2',
    wPORT:= 502,
    bUNIT_ID:= 3,
    bFUNCTION_CODE:= 16#03,
    wREAD_ADDRESS:= 30053,(*Modbus-Adr. der Slave-Eingänge(%IW0...%IW5)*)
    wREAD_QUANTITY:= 2,
    ptREAD_DATA:= ADR(Receive_Data),
    wWRITE_ADDRESS:= 16#0200,(*Modbus-Adr. der Slave-Ausgänge(%QW0...%QW2)*)
    wWRITE_QUANTITY:= 3,
    ptSEND_DATA:= ADR(Transmit_Data),
    xSTART:= TON1.Q,
    xRESET:= ,
    tTIME_OUT:= ,
    wERROR=> ,
    xREADY=> ,
    bRESPONSE_UNIT_ID=> );
    (*2. Etage: Büro 1, Beleuchtung*)
    (*Slave-Eingänge (Receive_Data) lesen*)
    DI_WORD_0:= Receive_Data[0];(*Slave %IX0.0...%IX0.15*)
    Zitieren Zitieren Modbus PLC 750-8202  

  2. #2
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    125
    Danke
    6
    Erhielt 34 Danke für 25 Beiträge

    Standard

    Hallo sadik,

    die ModbusEthernet04.lib ist auf dem PFC (8202) nicht lauffähig.
    Für dieses Gerät müsstest du die WagoLibModbus_IP_01.lib nutzen.
    Alternativ kannst du auch einfach den neuen Modbus-Konfigurator (ab CoDeSys 2.3.9.47) verwenden.
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  3. #3
    sadik ist offline Benutzer
    Themenstarter
    Registriert seit
    28.10.2015
    Beiträge
    30
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo

    Gibt es dazu auch ein Bespiel mit ModbusEthernet04 musste man TON1(IN:= KOMMU_E2.xREADY, PT:= T#0.1s); aufrufen um jede Sek Nachricht zu schicken ?


  4. #4
    Registriert seit
    30.01.2015
    Ort
    Hansastraße 27, 32423 Minden
    Beiträge
    125
    Danke
    6
    Erhielt 34 Danke für 25 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

Ähnliche Themen

  1. Modbus PLC 750-8202
    Von sadik im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 21.03.2016, 16:38
  2. Antworten: 7
    Letzter Beitrag: 08.02.2016, 22:51
  3. Wago 750-8202 und 750-315 mit Modbus RTU koppeln
    Von Boernie1967 im Forum WAGO
    Antworten: 1
    Letzter Beitrag: 28.12.2015, 10:55
  4. Antworten: 6
    Letzter Beitrag: 27.10.2015, 19:40
  5. Antworten: 3
    Letzter Beitrag: 18.06.2015, 16:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •