Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 21 bis 30 von 32

Thema: Modbus konfigurieren.. ich verzweifele

  1. #21
    Registriert seit
    13.01.2013
    Beiträge
    627
    Danke
    26
    Erhielt 64 Danke für 59 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Was steht denn unter der ModBus Configuration ?

  2. #22
    Registriert seit
    12.06.2016
    Beiträge
    14
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Die Screenshots hatte ich doch schon gepostet, oder wo meinst Du genau?
    Das

    Screenshot_Modbus8.jpg

  3. #23
    Registriert seit
    13.01.2013
    Beiträge
    627
    Danke
    26
    Erhielt 64 Danke für 59 Beiträge

    Standard

    Wenn du bei dem plus klickst kommt doch noch ein PRG... MBCFG... Ruf das mal im PLC Prg auf statt dem anderen.

  4. #24
    Registriert seit
    12.06.2016
    Beiträge
    14
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Unglücklich

    Screenshot_Modbus9.jpg

    kriege es einfach nicht hin

    MODBUS_CONFIGURATION();
    MBCFG_ModbuSlave(...);

  5. #25
    Registriert seit
    12.06.2016
    Beiträge
    14
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    oder muss ich beim Aufruf MBCFG_ModbuSlave(...) noch Parametereintragen? Aber IP, Port, etc. wurden doch im Konfigurator schon festgelegt.

  6. #26
    Registriert seit
    13.01.2013
    Beiträge
    627
    Danke
    26
    Erhielt 64 Danke für 59 Beiträge

    Standard

    Ruf den Slave einfach auf. Also ohne alles.
    MBCFG_ModbuSlave;
    Und wirf das andere mal raus.

  7. #27
    Registriert seit
    12.06.2016
    Beiträge
    14
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    irgendwas mache ich falsch.
    Ich komme nicht weiter.

  8. #28
    Registriert seit
    13.01.2013
    Beiträge
    627
    Danke
    26
    Erhielt 64 Danke für 59 Beiträge

    Standard

    Wir gucken morgen nochmal. Ich schicke dir mal ne Mail mit meiner Email. Dann schickst du einfach mal dein PRG...
    Blöde Frage. Du bist aber online und hast Start gedrückt oder ?

  9. #29
    Registriert seit
    11.10.2015
    Beiträge
    117
    Danke
    0
    Erhielt 19 Danke für 18 Beiträge

    Standard

    Ohne jetzt alles gelesen zu haben, aber ist das PRG für den Slave im Taskkonfigurator angelegt oder rufst Du es selbst einmal auf? Der Konfigurator kann das auch automatisch - siehe Konfigurator > MODBUS-Master > Einstellungen.
    Anm.: Erst seit CODESYS .49 ist die Checkbox per Default gesetzt.

  10. #30
    Registriert seit
    10.03.2014
    Ort
    Rhein-Neckar-Kreis
    Beiträge
    66
    Danke
    4
    Erhielt 10 Danke für 10 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich kann nur dringend empfehlen, auf die Codesysversion 2.3.9.49 zu wechseln, die 44 Version hat noch ein paar Mängel.


Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 07.01.2016, 18:04
  2. Antworten: 1
    Letzter Beitrag: 12.12.2014, 09:19
  3. Antworten: 16
    Letzter Beitrag: 11.08.2013, 10:34
  4. Modbus über ET200s Modbus Master Modul
    Von vollmi im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 19.11.2012, 14:37
  5. Antworten: 0
    Letzter Beitrag: 05.08.2010, 08:14

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •