Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 7 of 7

Thread: Elsner Wetterstation an interner COM-Schnittstelle von PFC200

  1. #1
    Join Date
    26.11.2012
    Posts
    208
    Danke
    19
    Erhielt 23 Danke für 22 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vorher hatte ich einen Controller (750-881) und eine serielle Karte (750-652).
    An Dieser hatte ich eine Elsner Wetterstation (Modbus P03 mit GPS), ohne Probleme in Betrieb.

    Jetzt habe ich ein PFC200 (750-8212) gekauft. Programmiert wird nach wie vor mit Codesys 2.3.

    Der PFC200 hat ja einen RS232/485-Anschluss neben den Ethernetanschlüssen. Dort sollte man doch die Elsner Wetterstation auch betreiben können?
    Dass ich nicht einfach die zwei Drähte aus der seriellen Klemme auf den gekauften COM-Stecker anschliessen kann (Pin 3 und 8 ), war mir klar. Aber ich dachte, ich bring das Ding zum laufen…
    War leider nicht der Fall.

    Was ich bereits gemacht habe:

    • Von WAGO eine Bibliotheke erhalten, die eine passende Target-Lizenz hat (die normale Elsner-lib funktioniert mit dem 750-8212 nicht!).
    • Im WBM die serielle Schnittstelle NICHT für Linux-Console eingestellt.
    • Im Codesys bei den Modbus-Variablen die Schnittstelle auf RS485 umgestellt.
    • Beim Baustein den COM-Port von 2, auf 1 gewechselt (2= erste gesteckte Karte, 1= interne Schnittstelle).
    • Hoffentlich alle Bibliotheken von 32bit auf PFC200 gewechselt.


    Wie bekomme ich die Wetterstation zum laufen (am besten von Null an, Schritt für Schritt)?
    Last edited by egro; 13.04.2019 at 20:50.
    Reply With Quote Reply With Quote Elsner Wetterstation an interner COM-Schnittstelle von PFC200  

  2. #2
    Join Date
    10.10.2015
    Posts
    162
    Danke
    0
    Erhielt 26 Danke für 25 Beiträge

    Default

    Du willst doch sicher die serielle onboard Schnittstelle verwenden (COM-Port=0), anstelle der seriellen Service-Schnittstelle (COM=1)?! Von der seriellen Schnittstelle rate ich ab, da der FB die Schnittstelle umkonfiguriert und ein Servicekabel anschließend nicht mehr gehen wird und diese Schnittstelle nicht galvanisch getrennt ist und somit entsprechend empfindlich gegenüber Try and Error hinsichtlich der Verdrahtung.

  3. #3
    egro is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    26.11.2012
    Posts
    208
    Danke
    19
    Erhielt 23 Danke für 22 Beiträge

    Default

    Ich möchte den 9-poligen COM-Port verwenden.
    Der Baustein funktioniert auch mit einer Null nicht...

  4. #4
    Join Date
    10.10.2015
    Posts
    162
    Danke
    0
    Erhielt 26 Danke für 25 Beiträge

    Default

    Die Schnittstelle mit Sub-9-D-Buchse am Controller ist definitiv COM 0.
    Die Modbus Einstellungen in der Steuerungskonfiguration sind irrelevant, da Du für die Wetterstation Master bist und die Einstellungen in der Steuerungskonfig. nur den Slave betreffen.
    Um die Einstellungen für die serielle Schnittstelle muss Du Dich nicht kümmern, das macht der FB für die Wetterstation mittels internem serial_interface_01.lib FB.
    Funktioniert nicht, ist für eine Fehlerdiagnose zu wenig.
    - Hast Du eine Fehlermeldung am FB?
    - Was machen die LEDs an der Wetterstation? Wie sind die DIP-Schalter gesetzt?
    - Wie lang ist die Verkabelung? Abschlusswiderstände? Schirmung? Mögliche Verpolung getestet? Was für einen Sub-D-Stecker setzt Du ein, bzw. was hat der für eine Wdst.-Schaltung?

  5. Folgender Benutzer sagt Danke zu KLM für den nützlichen Beitrag:

    egro (15.04.2019)

  6. #5
    Join Date
    30.01.2015
    Location
    Hansastraße 27, 32423 Minden
    Posts
    12
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Default

    Hallo egro,

    Die meisten Punkte hast du schon richtig berücksichtigt und KLM hat auch den COM0 richtig ergänzt, somit wird dir vermutlich nur das Biasing-Netzwerk fehlen. Auf Wetterstation müssen keine Dip-Schalter verändert werden.


    Die Erfahrungen zeigen das eine Verbindung zwischen den PFC200 und der Wetterstation funktionieren kann, aber in den meisten Fällen für ein fehlerfreien Betrieb ein Biasing-Netzwerk zusätzlich zum Abschlusswiederstand notwendig ist. Es werden Widerstände gegen +5V und Gnd geschaltet um die Pegel auf der RS485 Leitung stabil zu halten. Im Handbuch des PFC200 in Kapitel 3.3.6.2 als Pull-Up und Pull-Down Widerstand bezeichnet.

    Aber der Reihe nach (...du wolltest ja eine Schritt für Schritt Anleitung).



    1a. Für den Anschluss empfehlen wir den WAGO-PROFIBUS Stecker 750-960. Hier lässt sich die Leitung mit Schirm vernünftig anschließen und das eingebaute Biasing-Netzwerk kann einfach über den Schalter aktiviert werden. Wobei die Adern A/B von der Wetterstation auf dem Stecker gedreht also B/A angeschlossen werden müssen.

    1b.Wenn der Stecker nicht zur Verfügung steht, kann auch ein handelsüblicher Sub-D Stecker verwendet werden. Hier muss dann aber das Biasing-Netzwerk nachträglich eingelötet oder auf Reihenklemmen nachgebaut werden.

    - WS:A auf Pin 3
    - WS:B auf Pin 8
    - Abschlusswiderstand 120-180Ohm zwischen Pin 3 und 8
    - Pull-Up Widerstand 450-650Ohm zwischen Pin 3 und 6 (+5V)
    - Pull-Down Widerstand 450-650Ohm zwischen Pin 8 und 5 (Gnd)


    2. Im WBM unter Administration -> Serial Interface (nicht Service Interface! ) prüfen ob die Einstellung „unassigned“ aktiv ist.

    3. In der Codesys alle Bibliotheken löschen, Zielsystem umstellen und die Applikationsbibliotheken wieder einfügen. Dabei werden die Systembibliotheken (aus dem PFC200 Ordner) automatisch angezogen.

    4. Im Programm am Baustein FbModbusWeatherStation am Eingang bCom_Port eine 0 eintragen. Weitere Kommunikationseinstellungen sind nicht notwendig. Die sind Baustein intern schon gesetzt und werden bei Programm Download die Schnittstelle übergeben.

    5. Und dann Einloggen, Laden, …läuft.

    Wenn sich am Ausgang MB_Error die Anzeigen MB_No_Error und MB_CRC_Error /MB_Overrun/ MB_Timeout abwechseln, also es mal geht und mal nicht dann konnte in dem meisten Fällen der Einbau des WAGO Steckers 750-960 oder eines Biasing Netzwerks dieses Verhalten beseitigen.

    Im Anhang ein funktionierendes Programmbeispiel mit aktualisierter Bibliothek (für die neuen Zielsysteme).
    Attached Files Attached Files
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    http://www.wago.com
    mailto:support@wago.com
    phone: +49 (0) 571 887 - 44 555

  7. Folgender Benutzer sagt Danke zu .:WAGO::011726:. für den nützlichen Beitrag:

    egro (15.04.2019)

  8. #6
    Join Date
    10.10.2015
    Posts
    162
    Danke
    0
    Erhielt 26 Danke für 25 Beiträge

    Default

    Na das nenne ich doch mal eine ausführliche und alle Eventualitäten berücksichtigende Antwort. Bravo! Scheint nicht die erste Frage danach gewesen zu sein

  9. #7
    egro is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    26.11.2012
    Posts
    208
    Danke
    19
    Erhielt 23 Danke für 22 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vielen Dank für die ausführliche Antwort (mit Beispiel).
    Mein Testaufbau besteht aus dem PFC200, 1m Kabel und der Wetterstation.
    Der Baustein geht auf MB_TIME_OUT.
    Die DIP-Switches sind im Auslieferzustand.
    Widerstände habe ich keine verbaut, da es bis anhin ohne funktioniert hat (Im D-SUB-Stecker sind auch keine.).
    Wie gesagt, ich habe die Leitung 1:1 von der seriellen Klemme (750-652) auf den D-SUB-Stecker umgehängt, mit der kleinen Hoffnung, dass es so klappt.

    Ich habe jetzt den WAGO-Stecker bestellt...

    Jetzt bleibt mir nur Abwarten...
    Den das ist der einzige Nachteil der Firma WAGO.
    Die Lieferzeiten in der Schweiz sind grauenvoll!
    Im Normalfall dauert es drei Tage.
    Das ist zwar nicht besonders lange, aber wenn ein Betrieb oder eine Maschine stillsteht, sind drei Stunden zu lange.
    Ich habe fast alles, was ich beim Kunden verbaue, bei mir am Lager.

    Sobald ich den Stecker habe und es testen kann, melde ich mich...

Similar Threads

  1. Replies: 1
    Last Post: 27.10.2018, 21:59
  2. Elsner Wetterstation mit e!Cockpit
    By eloee in forum WAGO
    Replies: 15
    Last Post: 18.05.2018, 17:13
  3. Sonstiges Elsner RS485 Wetterstation an S7 315 PN
    By emilio20 in forum Simatic
    Replies: 1
    Last Post: 30.06.2017, 15:54
  4. Wetterstation Elsner RS485 einbinden?
    By babylon05 in forum Simatic
    Replies: 0
    Last Post: 14.11.2011, 10:00
  5. Elsner Wetterstation an KL 6021
    By master in forum CODESYS und IEC61131
    Replies: 2
    Last Post: 24.11.2008, 08:50

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •