Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 2 of 2

Thread: Fehler bei SysRtcGetTime und PFC 100 ECO

  1. #1
    Join Date
    05.05.2019
    Posts
    6
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen

    Arbeit mit e!cockpit 1.5.0.3 und dem PFC 100 ECO

    Beim Auslesen der Systemzeit mit der Funktion SysRtcGetTime aus der SysliRtc bekomme ich eine Fehlermeldung.

    Das Programm lässt sich Fehlerfrei übersetzten und auch der Code wird problemlos erzeugt. Erst wenn ich auf "Verbinden" gehe, kommt die Fehlermeldung "Unaufgelöste Referenz: SYSRTCGETTIME"

    Funktionsaufruf und Zuweisung: #TimesDates.UTC := SyslibRtc.SysRtcGetTime(dummy:=TRUE);
    Wobei UTC ald DT deklariert ist.

    Ich komme mit diesem Problem nicht weiter und bin für Vorschläge Dankbar!

    Danke für eure Hilfe

    Gruss
    Chucky
    Reply With Quote Reply With Quote Fehler bei SysRtcGetTime und PFC 100 ECO  

  2. #2
    Join Date
    02.05.2015
    Location
    France
    Posts
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hello

    You can use the lib WagoAppTime
    WagoAppTime.FuGetLocalDateAndTime() for Local Time
    WagoAppTime.FuGetDateAndTime() for UTC Time.

    Pierre

Similar Threads

  1. Replies: 2
    Last Post: 21.09.2017, 08:31
  2. Replies: 4
    Last Post: 23.10.2015, 12:22
  3. Replies: 0
    Last Post: 20.02.2013, 09:40
  4. Replies: 7
    Last Post: 02.07.2012, 14:17
  5. Replies: 2
    Last Post: 05.04.2012, 17:51

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •