Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 3 of 3

Thread: Bezeichner nicht erkannt

  1. #1
    Join Date
    24.01.2015
    Location
    94562 Oberpöring
    Posts
    27
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    vielleicht kann mir jemand weiterhelfen.

    Versuche den OSCAT_NETWORK.DLOG_STORE_FILE_CSV Baustein der Oscat Network Bibliothek in e!Cockpit einzubinden. Das hinzufügen der Bibliothek hat einwandfrei funktioniert, allerdings erscheint beim einfügen des Bausteins folgende Fehlermeldung:

    Bezeichner DLOG_DATA nicht definiert. Dies ist eine Struktur in der Oscat Network Bibliothek.

    Hat jemand eine Idee was schief gelaufen sein könnte?

    Vielen Dank im Voraus.
    Reply With Quote Reply With Quote Bezeichner nicht erkannt  

  2. #2
    Join Date
    21.10.2015
    Location
    Hansastrasse 27, 32423 Minden
    Posts
    37
    Danke
    0
    Erhielt 9 Danke für 8 Beiträge

    Default

    Hallo fstoiber,


    das liegt an der vordefinierten Eigenschaften der Bibliothek. Die Bibliothek besitzt die Eigenschaft LanguageModelAttribute (Auszug aus der Online Hilfe : Wenn die Bibliothek die Eigenschaft LanguageModelAttribute "qualified-access-only" hat, müssen Sie im Applikationscode über den Namensraum auf den Bibliotheksbaustein zugreifen. Es wird ein qualifizierter (eindeutiger) Zugriff erzwungen.)


    Zur Lösung: Du musst nur den Namensraum der Bibliothek für den Datentyp mit einem nachfolgenden Punkt vor dem Datentyp einfügen.
    Beispiel: meine_variable:OSCAT_NETWORK.DLOG_DATA;
    Ihr/Euer

    WAGO Support Team
    WAGO Kontakttechnik GmbH & Co. KG
    hhtp://www.wago.com

    mailto:support@wago.com
    phone: +49 (0) 571 887 - 555

  3. #3
    Join Date
    24.01.2015
    Location
    94562 Oberpöring
    Posts
    27
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vielen Dank für den Tipp. Hat funktioniert.

Similar Threads

  1. CODESYS V3.5: "Bezeichner RS nicht definiert"
    By Tale in forum CODESYS und IEC61131
    Replies: 4
    Last Post: 16.07.2016, 21:59
  2. Replies: 2
    Last Post: 08.06.2014, 19:20
  3. im151-3 pn wird nicht erkannt
    By volker in forum Feldbusse
    Replies: 9
    Last Post: 02.01.2014, 20:51
  4. TON wird nicht erkannt
    By tahren in forum CODESYS und IEC61131
    Replies: 2
    Last Post: 05.08.2010, 14:43
  5. KL3228 nicht erkannt
    By cas in forum CODESYS und IEC61131
    Replies: 3
    Last Post: 08.03.2010, 19:21

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •