Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 3 of 3

Thread: 750-8204 als Modbus TCP Slave

  1. #1
    Join Date
    12.08.2019
    Posts
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo leute.
    Ich versuche eine 750-8204 als Modbus TCP Slave zu betreiben. Ich kann sie anpingen sie läuft und ich nutze e!cockpit. Zum Test nutze ich QModMaster.
    In der Wago habe ich 4 Array of Word mit je einer länge von 12 als Datenpunkte Verknüpft. In der Spalte Richtung habe ich 2 als Eingang und 2 als Ausgang eingestellt. Die Ausgänge haben in der Spalte MODBUS ADRESSE 0 bzw.12 und die Eingänge 32000 bzw.32012 als Adresse darin stehen. In der Netzwerkübersicht ist ein Generic Modbus Master eingefügt. Ich hätte gedacht, dass das alles ist und es so funktionieren müsste. Wenn ich jetzt bei QModMaster die IP und die Slaveaddresse eingebe und ihm sage 0x04 Read Input Register, Start Address 0, Number of Register 24 hätte ich jetzt zumindest erwartet dass ich entsprechend meines Mappings in WORD 2 einen counter sehe der von 0-255 immer zählt. Will ich später nutzen um die Funktion der Kommunikation zu prüfen. Ich bekomme in QModMaster aber nur ein Read data failed... Bei der Nutzung z.B. CanOpen muss ich zyclisch den "WAGO_CANopen_Manager();" aufrufen. Muss ich bei einem Modbus Slave etwas ähnliches machen? sowas in der art wie "WAGO_MODBUSSLAVE_MANAGER();" ?
    Reply With Quote Reply With Quote 750-8204 als Modbus TCP Slave  

  2. #2
    Join Date
    22.06.2009
    Location
    Sassnitz
    Posts
    15,159
    Danke
    1,241
    Erhielt 4,461 Danke für 3,595 Beiträge

    Default

    Ich kenne mich mit Wago nicht aus. doch ich vermute stark, daß Du da einen Modbus-Server- oder Modbus-Slave-Programmteil zyklisch immer aufrufen mußt. So ist das jedenfalls bei den mir bekannten SPS.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Join Date
    20.01.2012
    Posts
    273
    Danke
    0
    Erhielt 80 Danke für 76 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    der Modbus Server läuft bei der Wago selbstständig. Der muß nict explizit aufgerufen werden.

    Habe es gerade bei meiner 8204 noch einmal ausprobiert, lesen und schreiben funktioniert mit qModMaster.

    Hast du den Modbus TCP Port im WBM freigegeben (Ports and Services->Modbus)?


    Kannst Du die Diagnoseadressen abfragen, z.B. Adresse 64161 -> 0xAAAA

    2020-04-01 22_32_21-Window.jpg

    Gruß

  4. Folgender Benutzer sagt Danke zu Thruser für den nützlichen Beitrag:

    PN/DP (01.04.2020)

Similar Threads

  1. Replies: 17
    Last Post: 21.02.2019, 21:56
  2. PLC 750-8202 als Modbus Slave
    By smart_grid in forum WAGO
    Replies: 1
    Last Post: 12.06.2018, 19:06
  3. Replies: 21
    Last Post: 09.02.2018, 15:05
  4. Replies: 18
    Last Post: 01.09.2015, 22:36
  5. S7 1200 als slave mit PC als master (modbus poll)
    By Sternius in forum Feldbusse
    Replies: 0
    Last Post: 24.09.2012, 07:59

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •