Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 11 von 48 ErsteErste ... 91011121321 ... LetzteLetzte
Ergebnis 101 bis 110 von 473

Thema: PLCSim Netzwerkerweiterung "NetToPLCSim"

  1. #101
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von sps_fighter Beitrag anzeigen
    Ja leider, Deinen Ablauf habe ich so schon mehrere male probiert, leider ohne Erfolg.
    Gibts ev. unter Windows, Netzwerkverbindungen irgend welche Einstellungen die man noch beachten sollte??
    Hast du deiner Netzwerkkarte denn auch eine zweite IP-Adresse zugewiesen?
    Zeig doch mal die Ausgabe von ipconfig /all
    Sieht bei mir z.B. so aus:
    Code:
    Ethernetadapter "LAN-Verbindung":
    
            Verbindungsspezifisches DNS-Suffix:
            Beschreibung. . . . . . . . . . . : Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller
            Physikalische Adresse . . . . . . : XX-XX-XX-XX-XX-XX
            DHCP-aktiviert. . . . . . . . . . : Nein
            IP-Adresse. . . . . . . . . . . . : 192.168.1.120
            Subnetzmaske. . . . . . . . . . . : 255.255.255.0
            IP-Adresse. . . . . . . . . . . . : 192.168.1.12
            Subnetzmaske. . . . . . . . . . . : 255.255.255.0
            Standardgateway . . . . . . . . . : 192.168.1.1
            DNS-Server. . . . . . . . . . . . : 192.168.1.1
                                                194.25.2.129
    Und ich kann dann eine Instanz auf 192.168.1.12 und die andere auf 192.168.1.120 starten.

  2. #102
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Für alle die sich die Unterstützung von mehreren PLCSIM-Instanzen gewünscht haben, im Anhang eine entsprechende Version.

    Systemvorraussetzungen:
    S7 PLCSIM V5.4 mit mindestens SP3

    - Was muss dazu gemacht werden?
    Um mehrere Verbindungen einer Simulation - und somit auch nettoplcsim - zuzuweisen sind mehrere IP-Adressen auf der Netzwerkkarte notwendig.

    1.) IP-Adresse der Netzwerkkarte hinzufügen

    Entweder man hat mehrere Netzwerkkarten in seinem Rechner, oder es muss der bestehenden Netzwerkkarte eine (oder mehrere) weitere IP-Adressen vergeben werden.

    Die weitere IP-Adresse wird über das Windows-Menü:

    Netzwerkverbindungen -> LAN-Verbindung -> Eigenschaften -> Internetprotokoll (TCP/IP) -> Eigenschaften -> Erweitert -> IP-Adressen -> Hinzufügen

    angelegt.

    2.) Einstellungen in Nettoplcsim
    In nettoplcsim gibt es jetzt einen Menüpunkt "Settings".
    Wenn der Haken bei "Listen on all network devices" entfernt wird, muss eine IP-Adresse festgelegt werden an der nettoplcsim laufen soll. Dies muss eine der IP-Adressen sein die man vorher eingestellt hat.

    Im unteren Auswahlfeld wird dann die Instanznummer von PLCSIM eingestellt.
    Diese Instanznummer wird von PLCSim vergeben. Die erstgestartete Instanz hat Nr. 1, die zweite 2 usw.

    Die nettoplcsim.exe wird dann ein zweites mal gestartet, und dort die Einstellungen für die weitere IP-Adresse und Instanz-Nummer getätigt.

    Nach Drücken des "Start" Button in beiden Programmen sollten dann beide Server auf der eingestellten IP-Adresse laufen.
    Angehängte Dateien Angehängte Dateien
    Geändert von Thomas_v2.1 (03.09.2010 um 15:54 Uhr) Grund: Versionsvorraussetzungen

  3. Folgende 2 Benutzer sagen Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    goodillla (12.10.2010),J.DanielNuevo (19.01.2011)

  4. #103
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Im Anhang mal ein Screenshot einer Beispielkonfiguration:

    Rechner hat zwei IP-Adressen, 192.168.1.160 und 192.168.1.161

    Nettoplcsim 1 ist an PLCSIM-Instanz 1 und IP 192.168.1.160 gekoppelt.
    Nettoplcsim 2 ist an PLCSIM-Instanz 2 und IP 192.168.1.162 gekoppelt.

    Als Client ist ein Intouch Leitsystem verbunden, bei dem zwei SPS angelegt wurden.
    SPS1 hat IP 192.168.1.160
    SPS2 hat IP 192.168.1.161

    Beide Visualisierungen lesen Merkerwort 0 aus der jeweiligen SPS.
    nettoplcsim_multi.png

  5. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    goodillla (12.10.2010)

  6. #104
    Registriert seit
    06.10.2010
    Beiträge
    29
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    ich versuche gerade eine ganz simple Verbindung zwischen 2 virtuellen Maschinen(VMware) von WinCC flex 2008 zu PLCSIM über nettoplcsim aufzubauen. Auf der WinCC-VM läuft die Runtime und auf der PLCSIM-VM läuft nettoplcsim und das PLCSIM.

    WinCC-VM
    192.168.47.128
    Firewall aus
    telnet-Verbindung zu nettoplcsim funktioniert

    PLCSIM-VM
    192.168.47.129
    Firewall aus
    nettoplcsim sagt das es zu PLCSIM connected ist

    Verbindungseinstellungen in WCC
    Schnittstelle Ethernet
    Bediengerät 192.168.47.128
    Steuerung 192.168.47.129 Steckplatz 0, Baugruppe 0
    Zugangspunkt hab ich mir einen neuen gebaut in Sytemsteuergung>PG/PC-Schnittstelle, die Parametrierung lautet TCP/IP -> VMware Accelerated AMD...

    Ich bekommen einfach keine Verbindung zu nettoplcsim (Client:disconected). Ichhab schon ein bisschen rumprobiert, aber da das WinCC für mich neu ist frag ich mal lieber.

    Woran muß ich drehen damit das hinhaut?

    Gruß
    Zitieren Zitieren WinCC fexible + nettoplcsim + VMware  

  7. #105
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Zitat Zitat von Maikäferbenzin Beitrag anzeigen
    Ich bekommen einfach keine Verbindung zu nettoplcsim (Client:disconected). Ichhab schon ein bisschen rumprobiert, aber da das WinCC für mich neu ist frag ich mal lieber.

    Woran muß ich drehen damit das hinhaut?
    Hallo,
    damit WinCC mit nettoplcsim zusammen läuft, musst du bei den Systemparametern für TCP/IP in WinCC die Haken für:
    -Zyklusbildung
    - Lebenszeichenüberwachung
    - CPU-Stopüberwachung
    entfernen.
    Dann sollte es eigentlich funktionieren.

    Einen kurzen Verbindungsaufbau müsste man aber auch ohne diese Änderungen in nettoplcsim zu sehen bekommen. Aber wenn die Einstellungen nicht gemacht wurden, trennt WinCC die Verbindung gleich wieder.

    Probiere auch mal eine realistische Rack/Slot Konfiguration von 0/2. Nettoplcsim interessiert sich im Gegensatz zu einer realen SPS zwar nicht für diese Werte, aber vielleicht fragt WinCC das irgendwie ab.

    Welche WinCC Version hast du denn im Einsatz?

  8. #106
    Registriert seit
    06.10.2010
    Beiträge
    29
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Hallo,
    damit WinCC mit nettoplcsim zusammen läuft, musst du bei den Systemparametern für TCP/IP in WinCC die Haken für:
    -Zyklusbildung
    - Lebenszeichenüberwachung
    - CPU-Stopüberwachung
    entfernen.
    Dann sollte es eigentlich funktionieren.
    Ich hab sowas irgendwo schonmal gelesen und im WinCC danach gesucht, aber ich weiß nicht wo ich die TCP/IP Einstellungen finde.

    Einen kurzen Verbindungsaufbau müsste man aber auch ohne diese Änderungen in nettoplcsim zu sehen bekommen. Aber wenn die Einstellungen nicht gemacht wurden, trennt WinCC die Verbindung gleich wieder.

    Welche WinCC Version hast du denn im Einsatz?
    Ich hab das nettoplcsim beim Start der Runtime jetzt noch nicht beobachtet, aber könnte sein das es so ist. Wenn ich die Runtime starte kommen ein paar Statusmeldungen, die aber so schnell wieder weg sind, das ich das nicht entziffern kann. Es sieht zuerst aus als würde es gehen aber nach 1-2 Sekunden kommt dann wieder einen Meldung und ich hab nur noch ##### in meinerm E/A-Feld stehen.

    Ich nutze WinCC 2008 flexible.

    Gruß Jan

  9. #107
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Zitat Zitat von Maikäferbenzin Beitrag anzeigen
    Ich nutze WinCC 2008 flexible.
    Ah, "WinCC flexible" ist etwas ganz anderes als "WinCC". Außer dem WinCC im Namen haben diese beiden absolut garnichts miteinander zu tun.

    Bei WinCC flexible gibt es leider manchmal Probleme mit nettoplcsim. "Manchmal" darum, weil sich WinCC flexible bei jeder Variablenkonfiguration anders verhält. Wie viele Variablen hast du denn in deinem Projekt? Bereichszeiger oder Störmeldungen angelegt?

  10. #108
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Ergänzend sei noch zu sagen, dass WinCC flexible auch wunderbar direkt mit PLCsim zusammenläuft. Dazu muss aber Step7 mit PLCsim und WinCC flexible auf dem gleichen Rechner laufen.

  11. #109
    Registriert seit
    11.10.2010
    Beiträge
    4
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Im Anhang mal ein Screenshot einer Beispielkonfiguration:

    Rechner hat zwei IP-Adressen, 192.168.1.160 und 192.168.1.161

    Nettoplcsim 1 ist an PLCSIM-Instanz 1 und IP 192.168.1.160 gekoppelt.
    Nettoplcsim 2 ist an PLCSIM-Instanz 2 und IP 192.168.1.162 gekoppelt.

    Als Client ist ein Intouch Leitsystem verbunden, bei dem zwei SPS angelegt wurden.
    SPS1 hat IP 192.168.1.160
    SPS2 hat IP 192.168.1.161

    Beide Visualisierungen lesen Merkerwort 0 aus der jeweiligen SPS.
    nettoplcsim_multi.png
    More than this! It's possible to connect 2 copies of NetToPLCSim_multiinstance from 2 IP to one PLCSIM. It means that we can simulate any hardware devices (like Local Pulpits for example) simultaneously with WinCC connection to this PLCSIM. I've tried this and it works well. Very nice feature, many thanks.

    Sorry for English, don't know German at all.

  12. #110
    Registriert seit
    06.10.2010
    Beiträge
    29
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Ergänzend sei noch zu sagen, dass WinCC flexible auch wunderbar direkt mit PLCsim zusammenläuft. Dazu muss aber Step7 mit PLCsim und WinCC flexible auf dem gleichen Rechner laufen.
    Ja, lokal hab ich das mit WinCC Felxible hinbekommen, hat auf Anhieb funktioniert, nur übers Netz will es nicht.

    So, ich habs jetzt mal mit WinCC 7.0 versucht aber immer noch keinen Erfolg.
    Ich hab mir in WinCC ein ganz frisches Projekt geöffnet und im Variablenhaushalt die S7-Protokoll-Suite hinzugefügt, dann bei TCP/IP die 3 Häckchen weggemacht und unter "Unit" TCP/IP --> VMware Accelerated AMD ... eingestellt. Dann hab ich unter TCP/IP einen neue Verbindung eingefügt und in den Eigenschaften die IP der PLCSIM-VM eingetragen. Zum Schluß noch eine Variable (MB3) angelegt dessen Wert ich mir dann in der Runtime anzeigen lassen will.
    Im Graphics Designer fix ein E/A-Feld eingefügt, als Ausgabe eingestellt und die Variable (MB3) ausgewählt.

    Wenn ich nun die Runtime starte hab in dem E/A-Feld ein gelbes Achtungszeichen stehen und im nettoplcsim steht immernoch Client:disconnected. Telnet und ping funktioniert auf beiden Seiten.

    Ha ich irgendwo was verkehrt gemacht?

    Gruß Jan

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 16.03.2012, 18:20
  2. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  3. "CONT_C" SFB41 läuft nicht in PLCSIM, aber FB41
    Von TagebauCoder im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.08.2010, 21:00
  4. Antworten: 2
    Letzter Beitrag: 14.12.2007, 15:09
  5. SFB41 "CONT_C" funktioniert mit PLCSIM nicht
    Von hubert im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 01.05.2007, 14:50

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •