Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 13 von 48 ErsteErste ... 3111213141523 ... LetzteLetzte
Ergebnis 121 bis 130 von 473

Thema: PLCSim Netzwerkerweiterung "NetToPLCSim"

  1. #121
    Registriert seit
    18.01.2011
    Beiträge
    2
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo.
    Ich bin neu an diesem Forum und auch mein Deutsch ist nicht so gut wie ich möchte. (Spanisch wäre besser )

    Wir wollen ein S7-400 mit zwei CPU mit nettoplcsim simulieren. Haben wir eine S7-400 mit einer CPU gegen Intouch geprüft und es funktioniert OK. Habe ich auch nettoplcsim multinstance downloaden, damit wir zwei verschiedene PLCs benutzen können.

    Aber wir haben nur eine IP Addresse in dem SPS mit zwei CPUs (nur ein ethernet Netzwerkkarte für die beiden CPUs) und ich bin nicht sicher, was sollte ich machen, damit alles funktioniert. (Ausserdem ob es möglich ist....) Die Idee wäre ein Intouch gegen ein S7-400 mit zwei CPUs, zu verbinden. (Für jede CPU muss man in Intouch ein verschiedenes Slot wählen) Ist es möglich? Wenn jeder CPU eine Ip Addresse hätte, gäbe es kein Problem, aber das ist ein weitere Fall.

    Vielen Dank in Voraus aus Spanien.

  2. #122
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Zitat Zitat von J.DanielNuevo Beitrag anzeigen
    Aber wir haben nur eine IP Addresse in dem SPS mit zwei CPUs (nur ein ethernet Netzwerkkarte für die beiden CPUs) und ich bin nicht sicher, was sollte ich machen, damit alles funktioniert. (Ausserdem ob es möglich ist....) Die Idee wäre ein Intouch gegen ein S7-400 mit zwei CPUs, zu verbinden. (Für jede CPU muss man in Intouch ein verschiedenes Slot wählen) Ist es möglich? Wenn jeder CPU eine Ip Addresse hätte, gäbe es kein Problem, aber das ist ein weitere Fall.
    Hallo nach Spanien,
    mit der Multiinstanz-Version funktioniert das indem du deiner Netzwerkschnittstelle weitere IP-Adressen zuweist.

    Eine Schritt für Schritt Anleitung habe ich hier:
    http://www.sps-forum.de/showpost.php...&postcount=102
    verfasst.
    Spanisch kann ich leider nicht, ich könnte dir höchstens auf englisch weiterhelfen.

    Ich habe das schon mit Intouch und 6 Plcsim / Nettoplcsim Instanzen auf einem Rechner getestet, das ist kein Problem.

  3. #123
    Registriert seit
    31.08.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von J.DanielNuevo Beitrag anzeigen
    Hallo.
    Ich bin neu an diesem Forum und auch mein Deutsch ist nicht so gut wie ich möchte. (Spanisch wäre besser )

    Wir wollen ein S7-400 mit zwei CPU mit nettoplcsim simulieren. Haben wir eine S7-400 mit einer CPU gegen Intouch geprüft und es funktioniert OK. Habe ich auch nettoplcsim multinstance downloaden, damit wir zwei verschiedene PLCs benutzen können.

    Aber wir haben nur eine IP Addresse in dem SPS mit zwei CPUs (nur ein ethernet Netzwerkkarte für die beiden CPUs) und ich bin nicht sicher, was sollte ich machen, damit alles funktioniert. (Ausserdem ob es möglich ist....) Die Idee wäre ein Intouch gegen ein S7-400 mit zwei CPUs, zu verbinden. (Für jede CPU muss man in Intouch ein verschiedenes Slot wählen) Ist es möglich? Wenn jeder CPU eine Ip Addresse hätte, gäbe es kein Problem, aber das ist ein weitere Fall.

    Vielen Dank in Voraus aus Spanien.
    Hallo nach Spanien!

    Ich kann Dir ebenfalls nur auf Deutsch oder Englisch weiterhelfen.
    Wenn Du aber die Schritte wie von Thomas_v2.1 vorgeschlagen befolgst, dann müsste es sicher funktionieren.
    siehe: http://www.sps-forum.de/showpost.php...&postcount=102
    Auch ich simuliere im Schnitt mit 4 bis 6 CPU's!

    Greetings
    from Austria

  4. #124
    Registriert seit
    18.01.2011
    Beiträge
    2
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vielen dank für die Antworten. Und vielen Thomas für Deine Software. LibnoDave benutzen wir auch.
    Ich habe kein problem wenn Ihr auf Deutsch schreibt, nur dass ich vielleicht Fähler machen könnte, wenn ich schreibe .

    Dieses Beitrag hatte ich schon mal gelessen. Das ist wovon ich NetToPLCSim_Multiinstance downloaden habe. Tatsächlich haben wir (unter anderen) zwei SPSs getestet, zu dem gleichzeitig eine Verbindung mit einem HMI (Scada) haben.

    Aber bis noch bin ich leider nicht fähig mit zwei CPUs von dem gleichen SPS, zu verbinden. Im gleichen Rack habe ich zwei S7-400 und nur eine Netzwerkkarte, die von beiden CPUs benutzt wird. Ich kann nicht die beiden CPUs gleichzeitig simulieren mit PLCSim. Muss ich wählen nur einen. Das ist im wirklichkeit mein Problem.
    Kann ich zwei, drei.. CPUs von verschiedenen SPSs ohne Probleme simulieren (und natürlich NetToPLCSim benutzen) aber nicht zwei CPUs von dem gleichen SPS.

    20.1.2011: Gestern habe ich mal nach Information versuchen... und endlich habe ich was gefunden. PLCSim kann leider nicht Multiprocessing (wie sagt man das auf Deutsch?) Unterstützen. (Vielleicht im Zukunft...)
    Geändert von J.DanielNuevo (20.01.2011 um 08:33 Uhr)

  5. #125
    Registriert seit
    11.10.2010
    Beiträge
    4
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Hallo nach Spanien,
    mit der Multiinstanz-Version funktioniert das indem du deiner Netzwerkschnittstelle weitere IP-Adressen zuweist.

    Eine Schritt für Schritt Anleitung habe ich hier:
    http://www.sps-forum.de/showpost.php...&postcount=102
    verfasst.
    Spanisch kann ich leider nicht, ich könnte dir höchstens auf englisch weiterhelfen.

    Ich habe das schon mit Intouch und 6 Plcsim / Nettoplcsim Instanzen auf einem Rechner getestet, das ist kein Problem.
    I also use my WinCC with multiple instances of PLCSIM (even up to and sometimes (approx. 1 time per 1 hour) i have "S7 block administrator error" - after this WinCC don't want to connect to any PLCSIM at all. And become to work only after Windows restart.
    I tried to test different versions of Step7 and PLCSIM but no matter.

    Maybe someone knows how to solve this?

  6. #126
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Zitat Zitat von goodillla Beitrag anzeigen
    I also use my WinCC with multiple instances of PLCSIM (even up to and sometimes (approx. 1 time per 1 hour) i have "S7 block administrator error" - after this WinCC don't want to connect to any PLCSIM at all. And become to work only after Windows restart.
    I tried to test different versions of Step7 and PLCSIM but no matter.

    Maybe someone knows how to solve this?
    Could you briefly explain how your test-system is set up?
    Are WinCC and Step7/Plcsim running on different machines, and on which machine does the error occur?

  7. #127
    Registriert seit
    11.10.2010
    Beiträge
    4
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    I run all 8 PLCSIM and WinCC on one PC using PLCSIM(TCP/IP) interface.
    Each PLCSIM has its own IP.
    Every PLCSIM is not just a "simple program". Some of them not finally checked and sometime have SystemFaults. Some of them even use TCP connections to other PLCSIMs and it works.
    And from time to time I can get a problem described before when WinCC loose connections to PLCSIM untill reboot.
    Beside this I use NetToPLSSim_Multi to connect to PLCSIM from the 3rd side, but I suggest that the problem is not in NetToPLCSim but in Siemens Software.

  8. #128
    Registriert seit
    03.02.2011
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Moin moin zusammen!

    Ich habe mir auch dieses Tool runtergeladen und bekomme schon den reinen Verbindungsaufbau hin.

    In meiner Bachelorthesis stehe ich vor dem Problem, dass ich mit LabVIEW einen Prozess simulieren soll. Die SPS soll zu Simulationszwecken in PLCSim laufen und LabVIEW soll hierauf zugreifen und sich die Daten der Ausgänge abholen und entsprechend des Prozesses die Eingangsdaten zurückliefern.
    Mein Problem ist nun, dass ich nicht weiß, wie ich überhaupt Daten aus PLCSim bzw. hier NetToPLCSim auslesen oder schreiben kann.
    Den Verbindungsaufbau habe ich hinbekommen.. Beides ist verbunden.

    Was muss ich nun an NetToPLCSim senden, damit es mir bestimmte Daten zurückliefert bzw. wie kann ich Variablen schreiben? Ich kenne mich auf dem Gebiet leider überhaupt nicht aus.

    Beste Grüße
    Matthias
    Zitieren Zitieren LabVIEW soll verbunden werden!  

  9. #129
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Zitat Zitat von goodillla Beitrag anzeigen
    I run all 8 PLCSIM and WinCC on one PC using PLCSIM(TCP/IP) interface.
    Each PLCSIM has its own IP.
    Every PLCSIM is not just a "simple program". Some of them not finally checked and sometime have SystemFaults. Some of them even use TCP connections to other PLCSIMs and it works.
    And from time to time I can get a problem described before when WinCC loose connections to PLCSIM untill reboot.
    Beside this I use NetToPLSSim_Multi to connect to PLCSIM from the 3rd side, but I suggest that the problem is not in NetToPLCSim but in Siemens Software.
    As far as I know, the "S7 block administrator error" is generated by process "s7otbxsx.exe", or if this process is not running.
    I don't know why this process hangs up, and I hope it has nothing to do with nettoplcsim. Do you see any irregularities in windows task manager, e.g high memory usage?

    You could try a quick fix: start s7otbxsx.exe manually (you find it in windows system32 folder). Maybe then you don't need to reboot windows to continue your simulation.

  10. #130
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @Matthias (mathel):
    Hab dir schon per Email geantwortet bevor ich hier gelesen habe. Wenn du zu deiner Labview Anbindung noch Fragen hast, kannst du evtl. auch einen eigenen Thread dazu aufmachen. Das Thema könnte auch noch andere interessieren.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 16.03.2012, 18:20
  2. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  3. "CONT_C" SFB41 läuft nicht in PLCSIM, aber FB41
    Von TagebauCoder im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.08.2010, 21:00
  4. Antworten: 2
    Letzter Beitrag: 14.12.2007, 15:09
  5. SFB41 "CONT_C" funktioniert mit PLCSIM nicht
    Von hubert im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 01.05.2007, 14:50

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •