Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 15 von 48 ErsteErste ... 5131415161725 ... LetzteLetzte
Ergebnis 141 bis 150 von 473

Thema: PLCSim Netzwerkerweiterung "NetToPLCSim"

  1. #141
    Registriert seit
    19.06.2003
    Beiträge
    2.197
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Ich weiß leider nicht was sich Zottel bei den einzelnen Stellen gedacht hat.
    Vermutlich nix...
    Ich vermute, ich habe halt in irgendeinem Projekt zum 1. Mal TCP/IP verwendet, dabei alles Mögliche probiert und das was funktionierte immer wieder verwendet (z.B. die ganze Datei openSocket.c).

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Und da schlagen dann die neuen Sicherheitsfunktionen zu.
    Gut zu wissen! Vor 3 ca Wochen hatte ich eine Anfrage, wo unter XP alles lief und unter Vista oder 7 nix...

  2. #142
    Registriert seit
    19.06.2003
    Beiträge
    2.197
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Ich habe die Version 0.8.4.6 veröffentlicht. Änderungen sind:
    - Die Korrekturen von Thomas_v2.1 an openSocketw
    - Fehler mit dem Jahrzehnt in get/setPLCtime() behoben
    - Fehler in toPLCfloat() behoben

  3. Folgende 2 Benutzer sagen Danke zu Zottel für den nützlichen Beitrag:

    Cliff (28.02.2011),Thomas_v2.1 (28.02.2011)

  4. #143
    Registriert seit
    28.02.2011
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Thomas,

    erst mal: wunderbare Idee so ein Programm zu machen. Richte eine "donate" - Möglichkeit ein, ich finde, diese Arbeit soll honoriert werden. Ich bin dabei.

    Aber zu meiner Frage: versuche das Tool gerade einzurichten (habe gerade die noch-Version 0.7.2 geladen). Ich habe PLCSIM mit einer simulierten SPS laufen. Wenn ich nettoplcsim starte müßte doch zumindest im Status unten links sstehen, dass das Tool mit PLCSIM connected ist, oder?

    Btw: welche Schnittstelle stelle ich denn in PLCSIM ein? PLCSIM (TCP/IP)?

    Gruß und Dank,
    Thomas.
    (Der Neue)
    Zitieren Zitieren Bin zu doof ...  

  5. #144
    Registriert seit
    28.02.2011
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo nochmal,

    es liegt doch am Port 102. Wenn ich aber s7oiehsx beenden will, dann wird der Zugriff verweigert. Auch in der Windows-Diensteübersicht geht das nicht (bin Admin). - Ich mag Windows nicht.

    Gruß,
    Thomas G.
    Zitieren Zitieren SIMATIC Dienst beenden ...  

  6. #145
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Zitat Zitat von Noch'n Thomas. Beitrag anzeigen
    Aber zu meiner Frage: versuche das Tool gerade einzurichten (habe gerade die noch-Version 0.7.2 geladen). Ich habe PLCSIM mit einer simulierten SPS laufen. Wenn ich nettoplcsim starte müßte doch zumindest im Status unten links sstehen, dass das Tool mit PLCSIM connected ist, oder?
    Eigentlich schon. Wenn das Verbinden nicht klappt sollte in dem Ausgabefenster zusätzlich eine entsprechende Fehlermeldung auftauchen.
    Zitat Zitat von Noch'n Thomas. Beitrag anzeigen
    Btw: welche Schnittstelle stelle ich denn in PLCSIM ein? PLCSIM (TCP/IP)?
    Das ist für nettoplcsim egal. Die Einstellung wird erst interessant wenn du z.B. WinCCflexible (ohne nettoplcsim) mit PLCSIM testen möchtest.

    Zitat Zitat von Noch'n Thomas. Beitrag anzeigen
    es liegt doch am Port 102. Wenn ich aber s7oiehsx beenden will, dann wird der Zugriff verweigert. Auch in der Windows-Diensteübersicht geht das nicht (bin Admin).
    Welches Betriebssystem hast du denn?

    Versuche mal den Dienst zu beenden wenn PLCSIM beendet ist.
    Also:
    1) Step7 starten
    2) Dienst beenden
    3) PLCSIM starten
    4) nettoplcsim starten, Verbinden

  7. #146
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard

    Zitat Zitat von Zottel Beitrag anzeigen
    Ich habe die Version 0.8.4.6 veröffentlicht. Änderungen sind:
    - Die Korrekturen von Thomas_v2.1 an openSocketw
    Hallo,
    ich hoffe du hast meine Änderungen nochmal gegengecheckt. Mit "ich weiß nicht was du dir dabei gedacht hast" meinte ich nämlich, dass ich so auf den ersten Blick z.B. keinen Grund für das bind() gesehen habe, aber es kann ja sein dass es einen triftigen Grund hierfür gab. Nicht dass es dann später Probleme an anderer Stelle gibt.

  8. #147
    Registriert seit
    28.02.2011
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Daumen hoch

    Hallo,

    jetzt klappt's - mußte nur richtig lesen (sorry). - Nochmal: how to donate ?

    Gruß,
    noch so'n Thomas.
    Zitieren Zitieren Danke - danke - danke!  

  9. #148
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.645
    Danke
    208
    Erhielt 409 Danke für 328 Beiträge

    Standard

    Hallo Thomas,

    Läuft den NetToPLCSim auch mit libnodave unter .NET? Ich bekomm da nämlich keine Daten von dem Simulator gelesen. Auch wenn Ich es mit dem Delphi Beispiel von libnodave Probiere, kann Ich keine Daten lesen.

    Wenn Ichs aber mit TestIsoTCP probiere funzts!

    Fehler ist immer -126 (Result contains no data)

    irgend ne Idee?
    ---------------------------------------------
    Jochen Kühner
    http://jfk-solutions.de/ - Softwareentwicklung, Programmierung, ...
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    IPhoneS7 - Inbetriebnahme Tool fürs IPhone (VarTab, Baustein-, PLC-Status)

  10. #149
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.645
    Danke
    208
    Erhielt 409 Danke für 328 Beiträge

    Standard

    Ich habs gerade nochmal versucht. Eine Anfrage mit mehreren TAGs, funktioniert an der CPU anstandlos! Dann IP auf 127.0.0.1 geändert und mit NetoToPLCSIM probiert und Ich bekomme Fehler -126.
    ---------------------------------------------
    Jochen Kühner
    http://jfk-solutions.de/ - Softwareentwicklung, Programmierung, ...
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    IPhoneS7 - Inbetriebnahme Tool fürs IPhone (VarTab, Baustein-, PLC-Status)
    Zitieren Zitieren Mhmm....  

  11. #150
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.086
    Danke
    128
    Erhielt 1.481 Danke für 1.090 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Jochen Kühner Beitrag anzeigen
    Läuft den NetToPLCSim auch mit libnodave unter .NET? Ich bekomm da nämlich keine Daten von dem Simulator gelesen. Auch wenn Ich es mit dem Delphi Beispiel von libnodave Probiere, kann Ich keine Daten lesen.

    Wenn Ichs aber mit TestIsoTCP probiere funzts!

    Fehler ist immer -126 (Result contains no data)

    irgend ne Idee?
    Also ich habe es gerade mit der aktuellen libnodave 0.8.4.6 und der simpleISO_TCP.exe aus dem Dot.Net\CS Verzeichnis getestet. Bei mir funktioniert es auf 127.0.0.1.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 16.03.2012, 18:20
  2. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  3. "CONT_C" SFB41 läuft nicht in PLCSIM, aber FB41
    Von TagebauCoder im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.08.2010, 21:00
  4. Antworten: 2
    Letzter Beitrag: 14.12.2007, 15:09
  5. SFB41 "CONT_C" funktioniert mit PLCSIM nicht
    Von hubert im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 01.05.2007, 14:50

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •