Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 16 of 53 FirstFirst ... 6141516171826 ... LastLast
Results 151 to 160 of 521

Thread: PLCSim Netzwerkerweiterung "NetToPLCSim"

  1. #151
    Join Date
    17.06.2004
    Location
    Offenau
    Posts
    4,078
    Danke
    210
    Erhielt 466 Danke für 366 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Damit fuzts bei mir auch, hast du auch mal das Delphi prog probiert?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  2. #152
    Thomas_v2.1's Avatar
    Thomas_v2.1 is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    29.03.2004
    Posts
    7,257
    Danke
    165
    Erhielt 2,178 Danke für 1,559 Beiträge

    Default

    Quote Originally Posted by Jochen Kühner View Post
    Damit fuzts bei mir auch, hast du auch mal das Delphi prog probiert?
    Funktioniert bei mir auch (Windows 7). Hast die vielleicht irgendwo noch eine alte libnodave.dll liegen, also vor 0.8.4.6?

  3. #153
    Join Date
    17.06.2004
    Location
    Offenau
    Posts
    4,078
    Danke
    210
    Erhielt 466 Danke für 366 Beiträge

    Default

    Ich hab noch 0.8.4.5! Gehts damit nich? Muss mal 8.4.5 und 8.4.6 vergleichen, ich hab In meiner ja einiges angepasst!
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  4. #154
    Thomas_v2.1's Avatar
    Thomas_v2.1 is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    29.03.2004
    Posts
    7,257
    Danke
    165
    Erhielt 2,178 Danke für 1,559 Beiträge

    Default

    Quote Originally Posted by Jochen Kühner View Post
    Ich hab noch 0.8.4.5! Gehts damit nich? Muss mal 8.4.5 und 8.4.6 vergleichen, ich hab In meiner ja einiges angepasst!
    Ab Eintrag 136 steht alles dazu, auch was Zottel geändert hat:

    http://www.sps-forum.de/showpost.php...&postcount=136

  5. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Jochen Kühner (18.03.2011)

  6. #155
    Join Date
    17.06.2004
    Location
    Offenau
    Posts
    4,078
    Danke
    210
    Erhielt 466 Danke für 366 Beiträge

    Default

    Wer die Änderungen mal in meine Version übernhemen und dann nochmals testen. Danke schon mal.

    P.S.
    Was mich trotzdem wundert, das es mit TestIsoTCP auch mit der alten Version funktioniert hat!
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Reply With Quote Reply With Quote Danke...  

  7. #156
    Join Date
    17.06.2004
    Location
    Offenau
    Posts
    4,078
    Danke
    210
    Erhielt 466 Danke für 366 Beiträge

    Default

    Ok, habs grad probiert, jetzt gehts. Hab die Änderungen auch in meine geänderte Version von libnodave übernommen.

    Vielleicht hat ja dieses Bind auch den Fehler bei der 64 Bit Version der DLL verursacht. Werd Ich morgen mal testen.

    Danke nochmals.

    Mfg.
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  8. #157
    Join Date
    02.05.2011
    Posts
    3
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Hallo zusammen!

    Ich besuche die zweijährige Fachakademie für Automatisierungstechnik. Als Abschlussprojekt möchten wir eine Vollautomatische Kerzenfertigungsanlage Realisieren.

    Bei der Visuallisierung haben wir uns für Zenon 6.51 (Copadata) entschieden.
    Jetzt möchten wir natürlich im Vorfeld unser Programm mittels nettoplcsim testen.

    Leider erhalten wir beim start des Tools folgende meldung: Listerning for clients....

    Anscheinend stimmt unsere Netzwerkeinstellung noch nicht.
    Wir verwenden Siemens Step 7 V5.4 + SP5 + HF1 in einer VM-Ware

    Wir möchten also eine Verbindung von Step7 V5.4 < ----> PLCsim <----> nettoplcsim <---> Zenon

    Kann uns irgendjemand eine kurze "Anleitung" geben wie wir die Einstellungen in Step7, usw machen müssen??

    Wir sind leider noch ziemliche Anfänger auf dem Gebiet.

    Danke vorab für die Hilfe!
    Best Grüße!
    Reply With Quote Reply With Quote NettoPLCSim mit Zenon Visualisierung  

  9. #158
    Thomas_v2.1's Avatar
    Thomas_v2.1 is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    29.03.2004
    Posts
    7,257
    Danke
    165
    Erhielt 2,178 Danke für 1,559 Beiträge

    Default

    Quote Originally Posted by FAAT2011 View Post
    Wir möchten also eine Verbindung von Step7 V5.4 < ----> PLCsim <----> nettoplcsim <---> Zenon

    Kann uns irgendjemand eine kurze "Anleitung" geben wie wir die Einstellungen in Step7, usw machen müssen??
    1. IP-Adresse des Step7-Plcsim-Rechners auf Adresse einstellen welche die SPS nachher erhalten soll. Gleiche IP-Adresse in Zenon einstellen.
    2. Plcsim starten und Programm in Plcsim laden
    3. Nettoplcsim starten, auf Start klicken. Wenn Fehlermeldung wegen "Port 102" in Benutzung kommt, den Dienst "IEPGHelper" beenden (oder über C:\>net stop s7oiehsx)
    4. Erreichbarkeit des Step7-Rechners aus der VM mittels Ping prüfen
    5. Visualisierung starten und beobachten ob sich mit Nettoplcsim jemand verbindet. Ausgaben im Fenster auf Fehler prüfen.


    Wenn keine Verbindung zustande kommt: Firewall prüfen, ggf. Port 102 auf dem Step7-Rechner für eingehende Verbindungen öffnen.
    Weiterhin die Beschränkungen der Datenbereiche beachten (siehe Dokumentation).

  10. #159
    Join Date
    07.06.2011
    Posts
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Hallo,

    vielen Dank für die bisher geposteten Beiträge. Ich möchte in meinem Fall mit NetToPLCSim PLCSIM mit dem mitgelieferten Siemens-OPC-Server (Komponenten-Konfigurator) verbinden, allerdings habe ich dabei Probleme, welche vermutlich mit der IP-Adressvergabe zusammenhängen. Die Situation derzeit sieht wie folgt aus:

    Der SPS-habe ich im NetPro die IP-Adresse meines Rechners zugeordnet (169.254.11.157). Wenn ich PLCSIM und NetToPLCSim starte, wird der korrekte Status PLCSim: Connected angezeigt.

    Ich bekomme allerdings keine Verbindung mit dem OPC-Server hin.
    Ich habe im NetPro versucht, dem "Microbox-PC" (PC auf dem der OPC-Server laufen soll) die gleiche Adresse wie der SPS zu geben, die doppelte Vergabe der IP-Adresse wird aber (sinnvollerweise) von Netpro abgelehnt. Ich habe dann dem Microbox-PC die Adresse meiner zweiten Netzwerkkarte zugewiesen und über den Komponenten-Konfigurator die Einstellungen importiert. Der OPC-Server lies sich dann auch starten.

    Im NetToPLCSim wird jedoch Client: Disconnected angezeigt. Möglicherweise wird eine Verbindung erst dann aufgebaut, wenn eine konkrete Anfrage vom OPC-Server an die NetToPLCSim weitergeleitet wird.

    Ich habe daher in unserer HMI-Entwicklungsumgebung (VisualStudio/VisiWinNetPro) das Programm einmal ausgeführt, um so eine Anfrage zu generieren, es fand aber keine Kommunikation statt. In der HMI-Entwicklungsumgebung ist als Zieladresse 127.0.0.1 (localhost) hinterlegt.

    Vermutlich habe ich den OPC-Server nicht korrekt aufgesetzt - hatte jemand schon ähnliche Probleme?

    Vielen Dank und Grüsse
    Matze
    Reply With Quote Reply With Quote NetToPLCSim und Siemens OPC (Komponenten-Konfigurator)  

  11. #160
    Thomas_v2.1's Avatar
    Thomas_v2.1 is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    29.03.2004
    Posts
    7,257
    Danke
    165
    Erhielt 2,178 Danke für 1,559 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Quote Originally Posted by Matze333 View Post
    Im NetToPLCSim wird jedoch Client: Disconnected angezeigt. Möglicherweise wird eine Verbindung erst dann aufgebaut, wenn eine konkrete Anfrage vom OPC-Server an die NetToPLCSim weitergeleitet wird.
    Genau so ist es. So lange kein OPC-Client ein Item aus der entsprechenden Steuerung anfragt, baut der OPC-Server auch keine Verbindung zur SPS (bzw. hier nettoplcsim) auf.
    Quote Originally Posted by Matze333 View Post
    Ich habe daher in unserer HMI-Entwicklungsumgebung (VisualStudio/VisiWinNetPro) das Programm einmal ausgeführt, um so eine Anfrage zu generieren, es fand aber keine Kommunikation statt. In der HMI-Entwicklungsumgebung ist als Zieladresse 127.0.0.1 (localhost) hinterlegt.
    Ich hatte letztens schon eine Anfrage, ob es funktioniert wenn der OPC-Server und die SPS auf dem gleichen Rechner laufen. Konnte es aber bisher noch nicht beispielhaft nachprüfen.
    Das Problem ist aber auch nur beim Simatic.Net OPC-Server vorhanden, weil dieser etwas pingelig ist wenn er der Meinung ist dass die konfigurierten IP-Adressen nicht passen.

    Um das Problem zu umgehen würde ich zum Testen der Netzwerkkarte eine zweite IP-Adresse zuweisen.
    Wenn deine erste IP-Adresse 169.254.11.157 lautet, dann z.B. 169.254.11.158 oder eine weitere freie IP im gleichen Subnetz.

    Warum du bei deiner Visualisierung eine IP-Adresse (127.0.0.1?) einstellen musst wenn du über den Simatic.Net OPC-Server gehst verstehe ich nicht ganz. Normalerweise legst du im Simatic.Net die Verbindung zur SPS an (z.B. auf die 2. IP deiner Karte 169.254.11.158). Der Zugriff über Items auf diese Verbindung erfolgt dann gemäß Simatic.Net OPC Syntax über den konfigurierten Verbindungsnamen folgend von Symbol- oder Absolutadressen.

Similar Threads

  1. TIA Remanenzspeicher "echte" 1515F und PLCSIM
    By MFreiberger in forum Simatic
    Replies: 1
    Last Post: 20.07.2019, 07:19
  2. Replies: 13
    Last Post: 08.10.2018, 12:36
  3. Replies: 5
    Last Post: 29.09.2016, 17:35
  4. "CONT_C" SFB41 läuft nicht in PLCSIM, aber FB41
    By TagebauCoder in forum Simatic
    Replies: 6
    Last Post: 22.08.2010, 21:00
  5. Replies: 7
    Last Post: 01.05.2007, 14:50

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •