Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 18 of 53 FirstFirst ... 8161718192028 ... LastLast
Results 171 to 180 of 521

Thread: PLCSim Netzwerkerweiterung "NetToPLCSim"

  1. #171
    Join Date
    10.09.2007
    Posts
    103
    Danke
    4
    Erhielt 7 Danke für 6 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also leider hat das nicht funktioniert.

    Ist die Frage, da ich mich hier in einer PCS7 Umgebung befinde........ob das so überhaupt funktioniert?

    Grüße

  2. #172
    Thomas_v2.1's Avatar
    Thomas_v2.1 is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    29.03.2004
    Posts
    7,257
    Danke
    165
    Erhielt 2,178 Danke für 1,559 Beiträge

    Default

    Quote Originally Posted by joflow View Post
    Also leider hat das nicht funktioniert.

    Ist die Frage, da ich mich hier in einer PCS7 Umgebung befinde........ob das so überhaupt funktioniert?
    Nein, mit PCS7 wird das nicht funktionieren. Dort läuft die Kommunikation vollständig anders ab als bei WinCC oder anderen Visualisierungen.

  3. #173
    Join Date
    10.09.2007
    Posts
    103
    Danke
    4
    Erhielt 7 Danke für 6 Beiträge

    Default

    Hi,

    nun die Kommunikation läuft nicht unbedingt anderster ab. Ich habe auch bei PCS7 meine DB's auf der AS Seite und den Kanal Treiber in WinCC.

    Ist halt nur die Frage ob die Kommunikation mit den automatisch erstellten Instanz DB's funktioniert.

    Wie könnte ich denn die generelle Funktion testen?

    Kann ich mir einen DB erstellen mit werten, den ich in WinCC einfach mal in einem Bild darstelle?

    Dann müsste ich doch sehen ob das funktioniert, oder?

    Grüße

  4. #174
    Thomas_v2.1's Avatar
    Thomas_v2.1 is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    29.03.2004
    Posts
    7,257
    Danke
    165
    Erhielt 2,178 Danke für 1,559 Beiträge

    Default

    Ich habe keine Ahnung wie das im Detail abläuft, aber soweit ich das sehe werden da viele Sachen von der SPS aus getriggert. Darum funktioniert der ganze PCS7-Käse auch nur mit einer 400er, weil eine 300er dafür gar nicht genug Ressourcen hat.
    Diese Alarm_x FBs funktionieren in Plcsim nicht, und auch in anderen Soft-SPSen diverser Hersteller (z.B. Deltalogic) werden diese Dinge imho nicht unterstützt.

    Wir haben zwar PCS7 in der Firma, aber keine 400er SPS damit ich mir das im Detail angucken könnte. Wenn du sowas hast kannst du ja mal mit Wireshark einen Mitschnitt der Kommunikation machen.

  5. #175
    Join Date
    18.04.2005
    Location
    Fast an der Schweiz
    Posts
    928
    Danke
    234
    Erhielt 114 Danke für 79 Beiträge

    Default

    Seit neustem habe ich folgenden Effekt :

    Das Panel (echtes Panel) baut eimalig eine Verbindung auf, ich kann die einmalig gelesenen Variabeln auf Nettoplcs. erkennen, dann ist feierabend nix geht mehr. Stoppe ich Nettoplcs.fängt es erneut an immer nur 1x Daten einlesen. Das kann ich zig mal wiederholen. Immer das selbe.

    Was kann das sein ?


    Versionen :
    S7-PLCSIM; V5.4 + SP3; K05.04.03.00_01.19.00.01; V5.4.3.0
    STEP 7; V5.5; V5.5.0.0_25.6.0.1; V5.5.0.0
    Nettoplcsim 0.7.2
    WIn XP SP3
    port 102 ist ok
    Code:
    IF Suppe = fad THEN
        Salz = true
    End IF
    
    `Salz isch Cool
    Arbeitet mit : Step7 V5.6 / WinCC Flex 2008 SP5 / Intouch / Winmod /TIA V15

    ║▌║█║║▌║█║ Warnung! Falscher oder fehlender Kaffee - Benutzer angehalten --(◔̯◔)--
    1334566890111
    Reply With Quote Reply With Quote Probleme mit MP377 ?  

  6. #176
    Thomas_v2.1's Avatar
    Thomas_v2.1 is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    29.03.2004
    Posts
    7,257
    Danke
    165
    Erhielt 2,178 Danke für 1,559 Beiträge

    Default

    Quote Originally Posted by Waelder View Post
    Seit neustem habe ich folgenden Effekt :

    Das Panel (echtes Panel) baut eimalig eine Verbindung auf, ich kann die einmalig gelesenen Variabeln auf Nettoplcs. erkennen, dann ist feierabend nix geht mehr. Stoppe ich Nettoplcs.fängt es erneut an immer nur 1x Daten einlesen. Das kann ich zig mal wiederholen. Immer das selbe.
    Hm, die letzte Version (0.7.2) scheinst du laut deiner Signatur zu haben, oder?

    Problematisch sind meistens zyklische Daten die ein WinCCflexible Panel anfragt, und die nettoplcsim so nicht bedienen kann. In der letzten nettoplcsim-Version habe ich eine Anfrage bezüglich solcher Daten abgelehnt, denn dann sollte WinCCflexible die Daten eigentlich in herkömmlicher Weise anfragen.

    Ist in den Projekt sonst irgendetwas spezielles?
    Um herauszufinden was das ist, bräuchte ich z.B. ein Wireshark-Mitschnitt der Kommunikation zwischen Panel und nettoplcsim.

  7. #177
    Join Date
    18.04.2005
    Location
    Fast an der Schweiz
    Posts
    928
    Danke
    234
    Erhielt 114 Danke für 79 Beiträge

    Default

    Nein es ist gar nichts spezielles drin, ich hab alle variabeln rausgeschossen und nur 1 Bild gelassen lediglich die koordinierungsworte und das Fehlermanagement laufen mit. die Fehler werden abgefragt alle 1 s.
    ich hab auch noch eine vorgängerversion von netto. die streikt leider auch.
    In das Wireshark muss ich mich einarbeiten dann kann ich dir das protokoll liefern.
    Übrigends haben wir es an 2 rechnern getestet mit erfolg = 0
    Code:
    IF Suppe = fad THEN
        Salz = true
    End IF
    
    `Salz isch Cool
    Arbeitet mit : Step7 V5.6 / WinCC Flex 2008 SP5 / Intouch / Winmod /TIA V15

    ║▌║█║║▌║█║ Warnung! Falscher oder fehlender Kaffee - Benutzer angehalten --(◔̯◔)--
    1334566890111

  8. #178
    Thomas_v2.1's Avatar
    Thomas_v2.1 is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    29.03.2004
    Posts
    7,257
    Danke
    165
    Erhielt 2,178 Danke für 1,559 Beiträge

    Default

    Quote Originally Posted by Waelder View Post
    Nein es ist gar nichts spezielles drin, ich hab alle variabeln rausgeschossen und nur 1 Bild gelassen lediglich die koordinierungsworte und das Fehlermanagement laufen mit. die Fehler werden abgefragt alle 1 s.
    "Koordinierungsworte" wird das Problem sein. Ich nutze das eigentlich nie, darum habe ich das noch nicht getestet bzw. nicht angesehen wie das überhaupt mit der SPS ausgetauscht wird. Ist aber sicher wieder so ein Siemens-Spezialkrams.

  9. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Waelder (19.08.2011)

  10. #179
    Join Date
    18.04.2005
    Location
    Fast an der Schweiz
    Posts
    928
    Danke
    234
    Erhielt 114 Danke für 79 Beiträge

    Default

    OK Thomas,
    dann werde ich mal das Koordinierungsdingens Abschalten und Berichten.
    Da ich das Netto bis jetzt hauptsächlich für Intouch benutzt hab (supiii) ist mir das wohl nicht aufgefallen. Magst recht haben im Fenster werden die Koord. Werte gezeigt. Siemens Zieht wohl auf einmal die ganzen längen rein unnd max ein paar werte dann ist ebbe.
    Wir werden sehen am Montag.

    Danke noch
    Code:
    IF Suppe = fad THEN
        Salz = true
    End IF
    
    `Salz isch Cool
    Arbeitet mit : Step7 V5.6 / WinCC Flex 2008 SP5 / Intouch / Winmod /TIA V15

    ║▌║█║║▌║█║ Warnung! Falscher oder fehlender Kaffee - Benutzer angehalten --(◔̯◔)--
    1334566890111

  11. #180
    Join Date
    19.09.2011
    Posts
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi, I'm trying to establish comm. like this:
    Host: Win XP + SP3 ip=192.168.10.1
    HMI: Cimplicity (GE family)
    OPC Server: INAT TCPIP-S
    VMware player: Win XP + SP2 ip=192.168.10.128
    STEP 7: V5.4 + SP3 + HF1
    S7 PLCSIM: V5.4 + SP1
    nettoplcsim

    When I start nettoplcsim I get the attached result. I tried to change the parameters in the OPC but I get the same all the time. What can be the problem?

    Dovi
    Attached Images Attached Images
    Reply With Quote Reply With Quote ENGLISH - Problem with INAT OPC Server  

Similar Threads

  1. TIA Remanenzspeicher "echte" 1515F und PLCSIM
    By MFreiberger in forum Simatic
    Replies: 1
    Last Post: 20.07.2019, 07:19
  2. Replies: 13
    Last Post: 08.10.2018, 12:36
  3. Replies: 5
    Last Post: 29.09.2016, 17:35
  4. "CONT_C" SFB41 läuft nicht in PLCSIM, aber FB41
    By TagebauCoder in forum Simatic
    Replies: 6
    Last Post: 22.08.2010, 21:00
  5. Replies: 7
    Last Post: 01.05.2007, 14:50

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •