Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 48 ErsteErste 123412 ... LetzteLetzte
Ergebnis 11 bis 20 von 473

Thema: PLCSim Netzwerkerweiterung "NetToPLCSim"

  1. #11
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.077
    Danke
    128
    Erhielt 1.477 Danke für 1.088 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von herbert1 Beitrag anzeigen
    Hallo Thomas,
    bei mir kommt die Meldung:
    Client: No connected
    Server 1: PlcSim V5.4 SP2
    Server 2: WinCCflex 2007 Runtime

    Hast Du evt. ein kleines Beispielprojekt für mich?

    Würde mich sehr interessieren.
    Also ein Beispielprojekt würde dir nicht viel bringen.

    Das einizige worauf du achten musst ist dass deine Netzwerkeinstellungen passen. So wie ich es oben auch schon erklärt habe:

    Angenommen du hast bei deinem WinCC flexible Projekt für die SPS-Station die IP-Adresse 192.168.1.100 eingetragen, dann musst dein PLCSim-Rechner (bei dir "Server 1") genau diese IP-Adresse bekommen.
    Subnetzmaske und Gateway natürlich auch, sodass beide überhaupt miteinander kommunizieren können.

    Du muss dir vorstellen dass der PLCSim-Rechner deine spätere SPS mit Netzwerkschnittstelle darstellt.

  2. #12
    Registriert seit
    20.12.2006
    Beiträge
    275
    Danke
    20
    Erhielt 28 Danke für 26 Beiträge

    Standard

    Hallo Thomas v2.1
    herzlichen Glückwunsch zu diesem tollen Tool.
    Wir bereiten zur Zeit einen Umbau von einer AEG Steuerung auf S7 vor, einschließlich WinCC 6.2 Dieses Programm ermöglicht es uns die gesamte Anlage nacheinander durchzutesten.
    1000 "Danke Button"
    MFG
    Bitverbieger

    Gelingt Dir etwas auf Anhieb, so lass Dir Deine Verblüffung nicht anmerken.

  3. #13
    Registriert seit
    03.02.2009
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Servus zusammen,

    ich habe das Programm mit der Visualisierung Zenon erfolgreich getestet und bisher keine Probleme festgestellt.

    (Bezug zu meinen Beiträgen im Thread: http://sps-forum.de/showthread.php?t=24315)

    Thomas

  4. #14
    Registriert seit
    30.03.2005
    Beiträge
    43
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen,
    ich bekomme leider keine Verbindung.
    Wenn alles auf einem Rechner läuft, dann funktioniert es.
    Auf Recher 1 (IP:192.168.2.100) läuft Step4V.5.4 mit PlcSimV.5.4SP2 und nettoplcsim, aur Rechner 2 (IP:192.168.2.106) WinCCflex 2007 Runtime.
    Starte ich dann die Runtime kommt als Meldung:
    (Verbindung abgebaut:
    Verbindung_1, Station 192.168.2.100, Baugruppenträger 0, Platz 2).
    Hat evt. jemand ein Tipp?

  5. #15
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.077
    Danke
    128
    Erhielt 1.477 Danke für 1.088 Beiträge

    Standard

    Zitat Zitat von herbert1 Beitrag anzeigen
    Auf Recher 1 (IP:192.168.2.100) läuft Step4V.5.4 mit PlcSimV.5.4SP2 und nettoplcsim, aur Rechner 2 (IP:192.168.2.106) WinCCflex 2007 Runtime.
    Starte ich dann die Runtime kommt als Meldung:
    (Verbindung abgebaut:
    Verbindung_1, Station 192.168.2.100, Baugruppenträger 0, Platz 2).
    Hat evt. jemand ein Tipp?
    Hast du vielleicht eine Firewall (die von Windows oder von einem anderen "Security"-Programm) aktiv?
    Wenn ja, dann diese entweder beim Testen ausschalten oder den Port 102 in der Firewall freigeben.

    Wenn du das überprüft hast, mal eine Eingabeaufforderung öffnen und dort:
    Code:
    C:\>telnet 192.168.2.100 102
    eingeben und prüfen ob Telnet sich mit nettoplcsim verbinden kann.

  6. #16
    Registriert seit
    30.03.2005
    Beiträge
    43
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Thomas,
    bei einem Rechner klappt die Verbindung mit
    C:\>telnet 192.168.2.106 102 bei dem anderen nicht
    C:\>telnet 192.168.2.100 102
    Es konnte keine Verbindung mit dem Host hergestellt werden, auf Port 102
    Ich weiß aber nicht, wer Port 102 schon belegt.
    (Simatic IEPG Help Service ist es nicht)
    Habe mir das Programm TCPView besorgt, kann darin aber nicht erkennen wer den Port blockiert.
    Firewall ist keine aktiv.

  7. #17
    Registriert seit
    03.02.2009
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Servus Herbert1,

    du kannst auch mit Betriebssystembefehlen herausfinden, welches Programm welchen Port belegt. Durch Eingabe von netstat -ano erhältst du die PID-Nummer des Prozesses, welcher einen bestimmten Port belegt (siehe Bildschirmkopie, 1. Zeile in der Eingabeaufforderung -> PID 760 für Port 102). Im Task Manager musst du die Spalte für die PIDs einblenden und dann sollte das zugehörige Programm auszumachen sein.


    Mit Zenon habe ich inzwischen auch die Verbindung mit zwei Unterschiedlichen Rechnern erfolgreich getestet.

    An dieser Stelle noch einmal ein Lob für den Ersteller des Programms (Thomas_v2.1), für die gute Arbeit und die Wahl der Lizensierung (Open Source).

    Thomas
    Angehängte Grafiken Angehängte Grafiken

  8. #18
    Registriert seit
    18.03.2009
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von th69xx Beitrag anzeigen
    Servus Herbert1,

    du kannst auch mit Betriebssystembefehlen herausfinden, welches Programm welchen Port belegt. Durch Eingabe von netstat -ano erhältst du die PID-Nummer des Prozesses, welcher einen bestimmten Port belegt (siehe Bildschirmkopie, 1. Zeile in der Eingabeaufforderung -> PID 760 für Port 102). Im Task Manager musst du die Spalte für die PIDs einblenden und dann sollte das zugehörige Programm auszumachen sein.


    Mit Zenon habe ich inzwischen auch die Verbindung mit zwei Unterschiedlichen Rechnern erfolgreich getestet.

    An dieser Stelle noch einmal ein Lob für den Ersteller des Programms (Thomas_v2.1), für die gute Arbeit und die Wahl der Lizensierung (Open Source).

    Thomas

    I need to know how to connect the client, I am using the opc server KepServerEx

  9. #19
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.077
    Danke
    128
    Erhielt 1.477 Danke für 1.088 Beiträge

    Standard

    Zitat Zitat von mar001 Beitrag anzeigen
    I need to know how to connect the client, I am using the opc server KepServerEx
    Remind that NetToPLCSim works only if your Kepserver uses S7-communication over TCP/IP.

    You have to set the IP-address of your PC (on which PLCSim is running)
    to the IP-address your real PLC will have (and the IP you have configured in your Kepware OPC server).

    Then start NetToPLCSim on your PLCSim-PC and hit the Start-Button.
    If all is OK you will see:
    "Starte Server...
    ...gestartet"
    in the textbox.
    The statusbar will show "PLCSIM: Verbunden".

    If you have a firewall on your pc, make sure you open port 102 for incoming connections.

    Then your OPC-server will be able to connect to PLCSim.

    Thomas

  10. #20
    Registriert seit
    18.03.2009
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Remind that NetToPLCSim works only if your Kepserver uses S7-communication over TCP/IP.

    You have to set the IP-address of your PC (on which PLCSim is running)
    to the IP-address your real PLC will have (and the IP you have configured in your Kepware OPC server).

    Then start NetToPLCSim on your PLCSim-PC and hit the Start-Button.
    If all is OK you will see:
    "Starte Server...
    ...gestartet"
    in the textbox.
    The statusbar will show "PLCSIM: Verbunden".

    If you have a firewall on your pc, make sure you open port 102 for incoming connections.

    Then your OPC-server will be able to connect to PLCSim.

    Thomas
    It works very nice, Thanks.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 16.03.2012, 18:20
  2. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  3. "CONT_C" SFB41 läuft nicht in PLCSIM, aber FB41
    Von TagebauCoder im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.08.2010, 21:00
  4. Antworten: 2
    Letzter Beitrag: 14.12.2007, 15:09
  5. SFB41 "CONT_C" funktioniert mit PLCSIM nicht
    Von hubert im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 01.05.2007, 14:50

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •