Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 4 von 8 ErsteErste ... 23456 ... LetzteLetzte
Ergebnis 31 bis 40 von 73

Thema: S7Droid - Android APP für S7 Bedienung

  1. #31
    Registriert seit
    05.05.2007
    Beiträge
    280
    Danke
    14
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich hätte mal ne Frage zu S7Droid full.

    Wenn ich in der App einen Multitaster projektiere der mit 5 Tastern ausgestattet ist, wie muss ich die Einstellungen machen.
    Meine Bits die ich setzen will liegen als Beispiel im DB100DBW80. Welches Bit wir nun mit dem ersten, zweiten, dritten... Taster gesetzt.
    Ich kann ja in der App kein Bit auswählen sondern muss ein Word oder Int auswählen oder?

    Danke

    Gruß Markus

  2. #32
    AutomationSE ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.03.2011
    Beiträge
    25
    Danke
    0
    Erhielt 5 Danke für 3 Beiträge

    Standard

    Hallo,

    erst mal Entschuldigung für die späte Antwort! Der Multitaster setzt letztendlich keine Bits sondern Zahlen im gewählten Word. So daß die Bits eigentlich wie folgt aussehen:

    Byte 1 Byte 0
    0: 0000 0000 0000 0000
    1: 0000 0000 0000 0001
    2: 0000 0000 0000 0010
    3: 0000 0000 0000 0011
    4: 0000 0000 0000 0100
    5: 0000 0000 0000 0101

    Du müsstest jetzt in der SPS einen Integer Vergleich machen um die Stufen deines 5 er Tasters zu nutzen. Momentan ist das noch nicht anders möglich, Ich denke aber wir werden in einer der nöchsten Versionen so etwas einbauen können.

    Für weitere Fragen stehen wir gerne zur Verfügung.

    Mit freundlichen Grüssen

    AutomationSE
    Geändert von AutomationSE (30.12.2011 um 13:30 Uhr)

  3. #33
    Registriert seit
    13.08.2011
    Beiträge
    341
    Danke
    21
    Erhielt 47 Danke für 42 Beiträge

    Standard

    Hallo,

    flolgendes Zitat aus der "Konfigurations-Anleitung S7Droid Full V1.2":

    4 Hinweise zur Tab-Konfiguration
    Momentan ist das System so aufgebaut, daß die Reihenfolge der Bedienelemente innerhalb eines Tabs in
    Abhängigkeit der Datenbank ID erfolgt, d.h. die Datenpunkte erscheinen in der Reiheinfolge Ihrer Eingabe.
    Um dennoch recht schnell und komfortabel die Werte in der richtigen Reihenfolge zu erhalten wird folgende
    Vorgehensweise vorgeschlagen:
    1. Export der aktuellen Datenbank in eine CSV Datei
    2. Editierung und Sortierung der Datenpunkte in der CSV Datei
    3. Spalte „_id“ der Datenpunkte und SPS Sektion leeren
    4. SPSen aus der Datenbank löschen
    5. Speicherung der CSV-Datei unter „S7DroidImport.csv“ im Root Verzeichnis des externen
    Speichers
    6. Import der CSV-Datei.
    7. Nach Import zweimal die Taste zurück betätigen und danach den Button auf der escheinenden
    Seite betätigen.
    was ist mit Punkt 4 (SPSsen aus der Datenbank löschen) gemeint
    Gruss der Fuss!!!

    +|----,,----:
    ------R----| Widerstand ist zwecklos!!!
    -|----''----:

  4. #34
    Registriert seit
    13.08.2011
    Beiträge
    341
    Danke
    21
    Erhielt 47 Danke für 42 Beiträge

    Standard

    Hat sich schon erledigt, gemeint ist die SPS in S7Droid zu löschen, nicht in der .csv Datei!
    Gruss der Fuss!!!

    +|----,,----:
    ------R----| Widerstand ist zwecklos!!!
    -|----''----:

  5. #35
    AutomationSE ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.03.2011
    Beiträge
    25
    Danke
    0
    Erhielt 5 Danke für 3 Beiträge

    Standard

    Hallo zusammen,

    stimmt genau, ist vielleicht ein bischen missverständlich beschrieben.

    mfg.

    AutomationSE

  6. #36
    Registriert seit
    22.10.2010
    Beiträge
    188
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,

    habe mir auch S7droid Full gekauft zusammen mit einem Internet Tablet Archos 70b.

    Gibt es schon eine Möglichkeit, mehrere Analoganzeigen in einer Zeile anzuordnen? Da ich ein 16:9-Format habe, wäre das für mich natürlich viel besser.

    So kann ich mir pro Seite vielleicht 5 Anzeigen einrichten, danach muss ich schon scrollen.

    Ideal wären 4 Anzeigen pro Zeile, dann könnte ich schon einiges mehr auf den Bildschirm zaubern.
    Hab sehr viele Temperaturen zum Anzeigen (ca. 10 Stück, Heizungssteuerung) und noch viele andere Sachen.

  7. #37
    AutomationSE ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.03.2011
    Beiträge
    25
    Danke
    0
    Erhielt 5 Danke für 3 Beiträge

    Standard

    Hallo,

    momentan ist diese Möglichkeit noch nicht implementiert. Dieses wird erst möglich sein, wenn eine Tab Konfiguration eingebaut ist. Geplant ist dieses schon, dauert aber wahrscheinlich noch eine gewisse Zeit. Dann wird es auch möglich sein, z.B. den gleichen Datenpunkt auf mehrere Tabs darzustellen.

    mfg.

    AutomationSE

  8. #38
    Registriert seit
    22.10.2010
    Beiträge
    188
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hat schon jemand die Siemens Logo 0ba7 am Laufen? Bekomme leider keine Verbindung zustande, weder mit Lite noch mit Full-Version.
    Vom PC aus ist die Logo erreichbar und kann mittels Logo-SoftComfort7.0 auch den Netzwerkeingang schalten.

    Wenn ich allerdings mit dem Archos 70b versuche eine Verbindung zu bekommen passiert folgendes:

    Neben der IP-Adresse geh ich auf das Pfeilsymbol --> Dann kommt Host Online , soweit ok
    Wenn ich einen Datenpunkt aktiviere sagt er S7-Adresse OK
    Wenn ich dann auf das Häckchen gehe um eine Abfrage der Adresse zu starten und evtl. zu schalten geht das ganze Bild kurz aus und danach muss ich wieder beim ersten Schritt anfangen, Ip-Adresse aktivieren, DB usw.

    Geb ich eine falsche Racknummer oder Slot oder sonstwas ein und drücke dann auf den Haken zum Abrufen, erscheint nebendran ein animierter Kreis und es passiert nichts, eigentlich logisch.
    Aber sobald ich die richtige Adresse eingebe baut sich das Bild immer wieder neu auf und ich kann von vorne beginnen.

    Woran kann das liegen?

  9. #39
    AutomationSE ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.03.2011
    Beiträge
    25
    Danke
    0
    Erhielt 5 Danke für 3 Beiträge

    Standard

    Hallo,

    zunächst die Frage ob Du die Verbindung in der Logo gem. Beschreibung unter http://www.automation-se.de/index.php/contlogohowto eingerichtet hast?

    Wenn ja müßtest Du mir mal die Datenpunkt-Adresse schicken, damit ich das nachvollziehen kann. An den Rack und Slot Einstellungen solltest Du nichts ändern müssen, da diese durch die Anwahl des SPS Systems automatisch gesetzt werden. Hier ist es sehr wichtig, daß die Einstellungen gemäß how'to gemacht worden sind.

    Falls sonst Fragen da sind einfach melden.

    Gruß

    AutomationSE

  10. #40
    Registriert seit
    22.10.2010
    Beiträge
    188
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe die Verbindung exakt laut Beschreibung eingerichtet. Meine IP-Adresse der Logo lautet 192.168.1.118 und befindet sich im Router-Netzwerk mit der Adresse 192.168.1.1

    Vom PC aus, der mit Kabel über einen Switch mit dem Router verbunden ist, kann ich die Logo ansprechen.
    Als Testprogramm habe ich folgendes genommen:

    -Netzwerkeingang VB0.0 schaltet Ausgang Q1.

    Mit dem Logo-Programm kann ich dann über die Eingabe von VB0 den Zustand von 0 auf 1 ändern und die Logo schaltet den Ausgang.

    Laut Beschreibung müsste dann die Adresse beim S7droid DB1.DBX0.0 sein oder?
    Aber selbst wenn ich Ausgänge lesen möchte wie z.b. A0.0 funktioniert es nicht bzw. das Bild baut sich ständig neu auf.


    Wenn ich beim Full-App alles so lasse, wie es original ist und nur bei der 0ba7 die IP-Adresse auf meine ändere fängt der Bildschirm wieder an sich neu aufzubauen. Dann aktiviert sich automatisch die S7-1200, sobald ich die 0ba7 anklicke baut sich der Bildschirm wieder neu auf und ich bin wieder bei der S7-1200.
    Ist schon etwas seltsam


    Bei S7droid Lite kann man ja direkt auf S7 Adresseingabe gehen, ohne Datenpunkte zu erstellen, da klappt es aber auch nicht.

    Datenpunktkonfiguration:

    DP-Name: Test
    DP-Beschreibung Test2
    DP-Adresse DB1.DBX0.0
    DP-Type: Bool
    Poll-Intervall 1000ms
    DP-Gruppe: Test3
    HMI-Type: Schalter Schaltfläche
    Zustands-Texte: Test5
    Untere Grenze: 0
    Obere Grenze 1
    Datenpunkt Read and Write

    Speichern...fertig.
    Geändert von Xplosion (03.02.2012 um 20:55 Uhr)

Ähnliche Themen

  1. Phoenix Webvisit +ILC130 +Android 2.2
    Von ibanez007 im Forum PHOENIX CONTACT
    Antworten: 11
    Letzter Beitrag: 27.03.2013, 07:22
  2. Android software für SPS
    Von ralfi_ir im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 15.03.2011, 06:45
  3. Google android 2.1
    Von emilio20 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 30.08.2010, 19:25
  4. OP 73 Bedienung
    Von rene im Forum HMI
    Antworten: 2
    Letzter Beitrag: 12.07.2007, 10:04
  5. Allgemeine Bedienung
    Von McMeta im Forum HMI
    Antworten: 2
    Letzter Beitrag: 17.04.2006, 20:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •