Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 10 of 10

Thread: Beckhoff TwinCAT3 Fehler "Check for autostart..." beim Aktivieren der Konfiguration

  1. #1
    Join Date
    17.03.2017
    Posts
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    beim aktivieren der Konfiguration meines Beckhoff-Projekts bekomme ich leider immer wieder die beiden Fehler, wie in den Screenshots zu sehen. Das passiert meistens dann, wenn ich Klemmen auf dem Bus austausche oder die Zuordnung der Variablen ändere. Ich habe schon mit dem Beckhoff-Support telefoniert, aber die konnten mir auch nicht wirklich helfen. Hat jemand eine Idee?

    beckhoff_fehler_2.pngbeckhoff_fehler_1.png

    Danke

    Viele Grüße

    Mebus
    Reply With Quote Reply With Quote Beckhoff TwinCAT3 Fehler "Check for autostart..." beim Aktivieren der Konfiguration  

  2. #2
    Join Date
    16.12.2015
    Location
    Innsbruck
    Posts
    95
    Danke
    27
    Erhielt 16 Danke für 16 Beiträge

    Default

    Hallo,
    Haben sie schon mal in den Ordner reingesehen? Sind da irgendwelche Files vorhanden?
    Also konkret unter C:\TwinCAT\3.1\Boot
    Mfg M.
    Iam not a savior, i just try to think about the future not beeing sad
    (c) Elon Musk

  3. #3
    Mebus is offline Neuer Benutzer
    Themenstarter
    Join Date
    17.03.2017
    Posts
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Hallo,

    es gibt dort die folgenden Dateien, wenn der Fehler auftritt:



    Code:
    PS C:\TwinCAT\3.1\Boot> dir -R
    
    
        Verzeichnis: C:\TwinCAT\3.1\Boot
    
    
    Mode                LastWriteTime         Length Name
    ----                -------------         ------ ----
    d-----       18.11.2020     22:08                Plc
    -a----       02.11.2020     17:43         428883 CurrentConfig.xml
    -a----       21.11.2020     15:18         122880 LoggedEvents.db
    -a----       02.11.2020     17:46            412 TCNC.bootdata
    
    
        Verzeichnis: C:\TwinCAT\3.1\Boot\Plc
    
    
    Mode                LastWriteTime         Length Name
    ----                -------------         ------ ----
    -a----       02.11.2020     17:43         342292 Port_851.app
    -a----       02.11.2020     17:39              0 Port_851.autostart
    -a----       18.11.2020     22:08           1824 Port_851.bootdata
    -a----       02.11.2020     17:46           1824 Port_851.bootdata-old
    -a----       02.11.2020     17:43             16 Port_851.cid
    -a----       02.11.2020     17:43             20 Port_851.crc
    -a----       02.11.2020     17:43              0 Port_851.occ
    -a----       02.11.2020     17:43              0 Port_851.oce
    -a----       02.11.2020     17:43         557108 Port_851_boot.tizip
    -a----       02.11.2020     17:43          68524 Port_852.app
    -a----       02.11.2020     17:39              0 Port_852.autostart
    -a----       18.11.2020     22:08             20 Port_852.bootdata
    -a----       02.11.2020     17:46             20 Port_852.bootdata-old
    -a----       02.11.2020     17:43             16 Port_852.cid
    -a----       02.11.2020     17:43             20 Port_852.crc
    -a----       02.11.2020     17:43              0 Port_852.occ
    -a----       02.11.2020     17:43              0 Port_852.oce
    -a----       02.11.2020     17:43              0 Port_852.ocm
    -a----       02.11.2020     17:39         178341 Port_852_act.tizip
    -a----       02.11.2020     17:43         178341 Port_852_boot.tizip
    
    
    PS C:\TwinCAT\3.1\Boot>
    Die .autostart Dateien haben eine Größe von 0 Bytes?

    Mebus

  4. #4
    Join Date
    16.12.2015
    Location
    Innsbruck
    Posts
    95
    Danke
    27
    Erhielt 16 Danke für 16 Beiträge

    Default

    Hallo,
    ja das mit der .autostart Datei ist ok -> die soll nur den Autostart für die Runtime markieren.
    Es scheint also eh alles runtergeladen zu werden.
    Ich würde mal versuchen die Dateien wegzukopieren (irgendwo in ein Temp Verzeichnis oder so) und anschließend die Solution neu aktivieren.
    Konkret gehts um alle Dateien unterhalb von Boot. Sollten keine wichtigen Files dabei sein, dann auch einfach löschen.

    Achtung: die Persistenten Daten sind dann auch weg, also vorher irgendwie sichern falls wichtig.
    Nur der Vorsicht halber gefragt: Speicherplatz is auf der Festplatte genug vorhanden? und an den Rechten dieses Boot Ordners wurde auch nicht rumgefummelt?
    Ist das Ziel wo die Solution aktiviert wird lokal auf dem Rechner oder über eine ADS-Route verbunden?
    Sg
    M.
    Iam not a savior, i just try to think about the future not beeing sad
    (c) Elon Musk

  5. #5
    Join Date
    10.08.2012
    Posts
    646
    Danke
    0
    Erhielt 182 Danke für 169 Beiträge

    Default

    4024.10 und Bootproject encrypted?

    Guga

  6. #6
    Join Date
    10.08.2012
    Posts
    646
    Danke
    0
    Erhielt 182 Danke für 169 Beiträge

    Default

    Beschreibung nun genauer nun gelesen.
    Lösch bitte einmal alle Dateien im Bootverzeichnis.

  7. #7
    Mebus is offline Neuer Benutzer
    Themenstarter
    Join Date
    17.03.2017
    Posts
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Moin,

    Quote Originally Posted by Guga View Post
    4024.10 und Bootproject encrypted?

    Guga

    Ja, diese Version aber keine Verschlüsselung des Boot-Projektes.

    Wenn ich TwinCAT schließe und wieder öffne, kann ich die Konfiguration aktivieren und starten.

    Ich greife Remote über Secure-ADS zu.

    Mebus

  8. #8
    Mebus is offline Neuer Benutzer
    Themenstarter
    Join Date
    17.03.2017
    Posts
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Die Datei "Port_851.app" ist manchmal einfach nach dem Download leer

    Mebus

  9. #9
    Join Date
    13.12.2011
    Location
    Bückeburg
    Posts
    3,253
    Danke
    419
    Erhielt 524 Danke für 442 Beiträge

    Default

    Was mich etwas irritiert ist die Port Nummer 852. Ist denn mehr als eine Laufzeit aktiv?
    Von irgendwas mit Internetzugang gesendet.

  10. #10
    Mebus is offline Neuer Benutzer
    Themenstarter
    Join Date
    17.03.2017
    Posts
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja, es sollten zwei PLCs aus zwei PLC-Projekten heruntergeladen werden.

    Wir das PLC-Projekt nicht aktiviert, wenn es bei der statischen Code-Analyse Fehlermeldungen gibt? Es funktioniert eigentlich immer, nur wenn ich die Verknüpfungen zu den Ausgängen ändere, bekomme ich diese Fehler.

    Mebus

Similar Threads

  1. ".project.~u" Datei bei Beckhoff TwinCAT3
    By Mebus in forum CODESYS und IEC61131
    Replies: 1
    Last Post: 20.05.2019, 21:25
  2. Replies: 8
    Last Post: 05.02.2019, 10:26
  3. Replies: 3
    Last Post: 13.06.2018, 09:55
  4. [TwinCat] Fehlermeldung beim aktivieren der Konfiguration
    By naheliegend in forum CODESYS und IEC61131
    Replies: 3
    Last Post: 21.03.2018, 19:47
  5. Replies: 2
    Last Post: 13.11.2016, 11:20

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •