Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 25

Thema: Busausfall (Profibus)

  1. #11
    Harry ist offline Benutzer
    Themenstarter
    Registriert seit
    18.03.2004
    Beiträge
    70
    Danke
    8
    Erhielt 5 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kamin :

    Was meinst du mit aktiven Abschlusswiderständen? Ich hab halt einfach die original Siemens PB-Stecker bei denen die Abschlusswiderstände mit Schiebeschaltern eingeschaltet werden können.

    Irgendwie könnte es schon etwas mit dem zu tun haben was Du schilderst. Denn das problematische Gerät ist ja der letzte Teilnehmer.
    Im Gegensatz zu deinem Versuch mit dem OP27 ist es bei mir aber genau umgekehrt: die Probleme auf dem Bus treten auf, sobald ich das letzte Gerät mit 24V versorge...


    Dagobert:

    Deine Schilderung stimmt 1:1 überein mit dem Problemfall den ich habe. Nur ist mein Netz wirklich SEHR klein... Gesamtbuslänge etwa 12m...

    Ein Repeater? Ist das nicht kompliziert zum konfigurieren? Gibts sowas von Siemens?
    (Wäre mir immer noch viel sympathischer als ein Panzerrohr-Installation!)


    Gruss

    Harry

  2. #12
    Registriert seit
    27.01.2004
    Ort
    Ösi-Land
    Beiträge
    302
    Danke
    0
    Erhielt 4 Danke für 2 Beiträge

    Standard

    Zitat Zitat von Harry
    - OV des NG mit Masse verbinden/nicht verbinden (Verbunden tritt der Fehler weniger häufig auf)
    Ausser beim isolierten Aubau sollten die 0V der Netzteile generell auf Masse (Erdungsschiene) liegen. (Ist IMHO Vorschrift) Am besten alle 0V auf der selben Masse und genau kontrollieren ob die Trennklemme auch zu ist.

    Liegt die Busleitung zum Stellantrieb in "ungünstiger" Umgebung?(Leitungen mit hoher Leistung, Spannung, Frequenz)

    Schon mal versucht die Baudrate zu reduzieren?
    Zitieren Zitieren Re: Busausfall (Profibus)  

  3. #13
    Harry ist offline Benutzer
    Themenstarter
    Registriert seit
    18.03.2004
    Beiträge
    70
    Danke
    8
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Die Speisungen sind jetzt alle miteinander verbunde. Wie geschildert, hat dies bewirkt, dass der Fehler seltener auftrat. Aber eben leider nur seltener!
    Die Reduktion der Baudrate hat keine feststellbaren Veränderungen im Verhalten gebracht.

    Das sind die richtig schönen Projekte: da gibt man eine Preisofferte ab was die Integration so eines Stellantriebs kostet und schlussendlich bastelt man tagelang da rum und kommt nicht weiter.

    Und selbstverständlich sagen alle Hersteller und Lieferanten, dass sie "das noch nie" irgendwo sonst hatten...

  4. #14
    Registriert seit
    06.10.2003
    Beiträge
    3.403
    Danke
    447
    Erhielt 502 Danke für 406 Beiträge

    Standard

    Hallo Harry,

    Zitat Zitat von Harry
    ...Ein Repeater? Ist das nicht kompliziert zum konfigurieren? Gibts sowas von Siemens?...
    Ja gibt es, Bestell-Nummer 6ES7 972-0AA01-0XA0. Zu konfigurieren ist da garnichts. Er trennt ganz einfach zwei Bussegmente galvanisch von einander. Nur die Busabschlusswiderstände müssen richtig geschaltet werden. Anstatt von zwei hast du dann vier Busabschlüsse. Die Stromversorgung des Repeaters würde ich vom CPU-Netzteil beziehen.

    Gruß, Onkel
    Zitieren Zitieren 6ES7 972-0AA01-0XA0  

  5. #15
    Registriert seit
    08.05.2004
    Beiträge
    121
    Danke
    0
    Erhielt 3 Danke für 2 Beiträge

    Standard

    Das ist ja dein Problem, sobald du den Stecker draufmachst, wird der Abschlusswiederstand im Stecker mit Spannung aus deinem Gerät versorgt. Ergo haben beide Abschlusswiederstände unterschiedliches Potential.

    Schleife den Teilnehmer doch ein, die paar Meter zurück zum Schrank sind doch bestimmt zu verkraften. Dann dürfte dein Problem gelöst sein.


    Aktives RS485 Abschlusselement : 6ES7972-0DA00-0AA0 67 ¤

  6. #16
    Registriert seit
    27.01.2004
    Ort
    Ösi-Land
    Beiträge
    302
    Danke
    0
    Erhielt 4 Danke für 2 Beiträge

    Standard

    Das Aktives Abschlusselement habe noch nie verwendet und ich habe immer mehrere Netzteile in den Anlagen. zb. im Hauptschrank eines für die CPU, CP, Repeater und ein eigenes für die Sensoreninseln (ET200) im Feld. Die externen Schränke mit teilweise eigener CPU machen sich die Spannungen alle selbst. Alles ist über mehrere 100 Meter mit Profibus verbunden und der Bus läuft teilweise sogar weiter wenn ich einen Abschlussteilnehmer abschalte! Es sind halt alle 0V der Netzteile geerdet und die Stromversorgungen und Erdungen laufen sternförmig zum Hauptschrank.

  7. #17
    Harry ist offline Benutzer
    Themenstarter
    Registriert seit
    18.03.2004
    Beiträge
    70
    Danke
    8
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Also.. ich werde mal als erstes die Busverdrahtung ändern, damit der Probleme machende Stellantrieb nicht am Schluss ist. Ist wohl die einfachste und günstigste Variante.

    Wenn das nicht nützt: Versuch mit dem Repeater.

    Werde dann ein Feedback schreiben.

    Danke für die Hilfe!

    Harry

  8. #18
    Registriert seit
    29.08.2003
    Beiträge
    221
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Moin

    mich würd mal intressieren ob der Bus nun läuft und was du jetzt als masnahmen gemacht hast?

    MfG Balou

  9. #19
    Registriert seit
    18.06.2003
    Beiträge
    141
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hallo zusammen,

    BEITRAG VON SIEMENS!

    Hinweise zur dauerhaften Terminierung eines Bussegmentes

    FRAGE:
    Wenn ich die Spannungsversorgung
    an einem PROFIBUS DP Slave
    abschalte oder diesen vom Netz trenne,
    dann werden andere Slaves beeinflusst.
    Was kann ich dagegen tun?

    ANTWORT:
    Der erste und der letzte Teilnehmer
    am PROFIBUS sind für die Terminierung
    des Bussegmentes verantwortlich.
    Diese Terminierung erfolgt über einen
    Abschlusswiderstand, welcher über
    die Stromversorgung des Slaves
    mitversorgt wird. Wenn Sie einen der
    beiden Slaves abschalten, dann
    heben Sie die Terminierung des
    Bussegmentes auf. Dadurch melden
    andere Teilnehmer eine Busstörung.
    Deshalb dürfen die DP-Teilnehmer
    mit eingeschaltetem Abschlusswiderstand
    nicht abgeschaltet oder vom Netz
    getrennt werden. Dadurch wird der
    Abschlusswiderstand nicht mehr versorgt
    und der Bus ist nicht mehr richtig abgeschlossen.

    Wenn Sie häufiger DP-Slaves vom
    Bus nehmen müssen, dann empfiehlt
    sich der Einsatz eines aktiven
    PROFIBUS -Terminators
    (MLFB: 6ES7 972-0DA00-0AA0).
    Dieser aktive RS485-Abschlusswiderstand
    dient zum Abschluss von PROFIBUS - Segmenten.
    Die Busterminierung ist damit unabhängig
    von den angeschlossenen Busteilnehmern.
    Der aktive Abschlusswiderstand kann
    separat zu den anderen Peripheriekomponenten
    oder mit einer vor der Peripherie
    zugeschalteten Spannung versorgt werden.
    Durch den aktiven PROFIBUS -Terminator
    können die Teilnehmer wahlfrei an- und
    abgekoppelt werden, ohne dass es zu
    Fehlfunktionen in der Kommunikation kommt.

    Hinweis:
    Ein RS485 Repeater besitzt ebenfalls
    die Funktion eines Abschlusswiderstandes.
    Es ist somit nicht notwendig, ein Bussegment,
    welches bereits durch einen Repeater
    abgeschlossen wird, zusätzlich durch
    einen Abschlusswiderstand zu terminieren.

    Tritt dieses Verhalten auf, wenn ein Slave
    abgeschaltet wird und sich nicht am Ende
    eines Bussegmentes befindet
    (d.h. Abschlusswiderstand ist abgeschaltet),
    dann ist das Bussystem nicht korrekt aufgebaut.
    Überprüfen Sie den Busaufbau anhand
    des Handbuches "SIMATIC NET PROFIBUS-Netze Anhang C".

    Hinweis:
    Das Handbuch finden Sie auf den
    Internet Seiten des Customer Support
    unter der Beitrags-ID 1971286.


    Beitrags-ID:2157453 Datum:30.07.2003

    mfG churchill

  10. #20
    Harry ist offline Benutzer
    Themenstarter
    Registriert seit
    18.03.2004
    Beiträge
    70
    Danke
    8
    Erhielt 5 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke für die Infos, Churchill.

    Ich habe nun also den Aufwand betrieben und das problematische Gerät zwischen andere Busteilnehmer eingeschlauft.
    Leider ein totaler Misserfolg. Es funktionierten nur noch die Geräte welche sich zwischen dem Stellentrieb und der CPU befinden.
    Auf den Rest (inkl. dem Stellantrieb der Probleme macht) kann über den Bus nicht mehr zugegriffen werden.
    Ziehe ich den PB-Stecker des Stellantriebs, so funktionieren alle andern Teilnehmer wieder....

    Nurn hab ich halt alles wieder rückgängig gemacht, und es funktioniert wieder so wie vorher: die Busteilnehmer fallen "nur" noch sporadisch aus.

    Bin langsam am Ende meines Lateins.....

    Gruss

    Harry

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 22.05.2009, 10:21
  2. Profibus Abhören (Profibus-Sniffer)
    Von tomi_wunder im Forum Feldbusse
    Antworten: 9
    Letzter Beitrag: 17.09.2007, 21:35
  3. Antworten: 2
    Letzter Beitrag: 12.07.2006, 12:56
  4. Profibus DP - SPS - Anlauf und Busausfall abfangen
    Von CrazyCat im Forum Feldbusse
    Antworten: 7
    Letzter Beitrag: 12.07.2006, 10:58

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •