Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Frage zu einem Sprungverteiler

  1. #1
    Registriert seit
    20.11.2007
    Beiträge
    96
    Danke
    41
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Probiere gerade eine Schrittkette zu programmieren! Habe nun folgendes Problem: Wenn der erste Schritt ok ist erhöht sich der Wert meines MW vom Sprungverteiler um 1. Jetzt soll im Schritt 1 eine Zeit mit Hilfe eines Zeitrelais Einschaltverzögert aktiv werden. Wenn die Zeit abgelaufen ist soll die Schrittkette um 1 weiterzählen. Wie schaffe ich es das die Zeit zu laufen beginnt - brauch ja eine steigende Flanke!! Wie macht ihr so etwas? Bei mir bleibt er immer im Schritt 1 stehen!
    Zitieren Zitieren Frage zu einem Sprungverteiler  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Was hast du denn bis jetzt programmiert. Zeig mal

  3. #3
    Registriert seit
    20.11.2007
    Beiträge
    96
    Danke
    41
    Erhielt 0 Danke für 0 Beiträge

    Frage

    Ich hoffe du kannst das lesen! Danke vorerst!! Mit was muß ich im sr1 beginnen das das Zeitrelais beginnt zu arbeiten.
    Angehängte Dateien Angehängte Dateien

  4. #4
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Code:
            L     MW   620
            SPL   erro                        //Unzulässiger Wert
            SPA   sr0                         //Positionierung läuft
            SPA   sr1                         //Zeit läuft nach erster Flanke der Fotozelle 
            SPA   sr2                         // 1.Zeit abgelaufen, Stop Rollbahn Start 1.Umreifung
            SPA   sr3                         // Umreifung beendet - Start Rollbahn
            SPA   sr4                         //Zeit läuft nach zweiter Flanke der Fotozelle     
            SPA   sr5                         //2.Zeit abgelaufen, Stop Rollbahn Start 2.Umreifung 
            SPA   sr6                         // Umreifung beendet - Start Rollbahn
       
       
       
      erro: SET   
            S     "Fehler_Schrittkette_2UM"
            BEA   
       
       
       
       
      sr0:  U     "Fotozelle_Schwert"
            FP    "Pos_Flanke1"
            SPBNB _001
            L     MW   620
            INC   1
            T     MW   620
      _001: NOP   0
            BEA   
       
       
       
      sr1:  L     S5T#5S                   //Da bleibt er immer stehen – wartet auf eine high Flanke aber wie???
            SS    T    607
            NOP   0
            NOP   0
            U     T    607
            SPBNB _002
            L     MW   620
            INC   1
            T     MW   620
      _002: NOP   0
            BEA
    da haben dann auch die leute ohne word was von und können mitreden
    Geändert von vierlagig (14.03.2008 um 09:45 Uhr)
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  5. #5
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Ich vermute das Du ein Bit mit VKE=1 vor L setzen musst

    Also
    U M 1.1 // Merker immer 1
    L S5T#5S //Da bleibt er immer stehen – wartet auf eine high Flanke aber wie???
    SS T 607
    Früher gab es Peitschen .... heute Terminkalender

  6. #6
    Registriert seit
    13.03.2004
    Beiträge
    135
    Danke
    10
    Erhielt 6 Danke für 6 Beiträge

    Standard

    @Lipperlanstern: Das wird wohl nicht reichen, da der Timer auch bisher nur angesprungen wird, wenn die Vorbedingung 1 ist.

    Ich denke der Timer muss stattdessen außerhalb der Sprungleiste definiert werden. Etwa so:

    L 1
    L MW620
    ==I
    L S5T#5S
    SS T607

    Aber wie gesagt, außerhalb der Sprungleiste, so das der erste Teil der Verknüpfung auch mal 0 wird.

    Gruss Hagen
    Im Zweifel, tue immer das richtige!

  7. #7
    Registriert seit
    20.11.2007
    Beiträge
    96
    Danke
    41
    Erhielt 0 Danke für 0 Beiträge

    Blinzeln

    Danke vorerst an alle, Schrittkette funkt schon bis Schritt 4 - es wird ja!!

  8. #8
    Registriert seit
    22.12.2006
    Beiträge
    43
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Stell auch sicher, dass dein Timer wieder zurückgesetzt wird, sonst "rauscht" die Schrittkette das nächste mal über diesen Schritt hinweg.

    Ich lasse deswegen Zeiten immer extern des Schrittes, bzw. der Schrittkette laufen und frage im Schritt selber den Timer dann ab.
    Zitieren Zitieren TimerSchrittkette  

  9. Folgender Benutzer sagt Danke zu tim_taylor für den nützlichen Beitrag:

    zwerg77 (14.03.2008)

Ähnliche Themen

  1. Frage zu einem WinCC Angebot
    Von würgi im Forum HMI
    Antworten: 3
    Letzter Beitrag: 07.11.2010, 15:26
  2. Eine Frage zu einem Programmauszug...
    Von petzi im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 25.12.2009, 22:11
  3. Frage zum Sprungverteiler
    Von rene im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 13.07.2007, 09:54
  4. Einfache Frage? - Schalten mit einem Taster
    Von Anonymous im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 06.03.2004, 15:29

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •