Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: Erste Inbetriebnahme einer CPU 314C-2 ptp

  1. #31
    Join Date
    12.11.2008
    Posts
    65
    Danke
    43
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jetzt klappts. Beim Ausgang anstelle von A 2.0 A 124.0 eingegeben (Systemvorgabe) und die LED leuchtet. Gut es war vielleicht offensichtlich für den Fachmann, aber den Laien freuts trotzdem

    Dann versuche ich jetzt mal das eigentliche Anwenderprogramm ans Laufen zu kriegen.

    Danke nochmals

  2. #32
    Join Date
    12.11.2008
    Posts
    65
    Danke
    43
    Erhielt 0 Danke für 0 Beiträge

    Default

    Morgen allerseits

    Gleich noch ein paar weitere Fragen:

    Wo finde ich die richtige Adressierung für meinen Analogeingang? Auf meiner CPU314c-2 nutze ich dafür mal bei AI 0 die Anschlüsse 2 und 4 (Spannungseingang). Den Wert lese ich dann mit dem Baustein FC105 ein, wie man mir es hier angeraten hat.

    Darin habe ich jetzt unter anderem auch die Zeile

    Code:
    IN :=PEW6
    stehen. Derjenige der mir die Zeile empfohlen hat, hat dann gemeint das PEW6 müsste aber möglicherweise noch geändert werden und ich sollte mir dann die Hardwarekonfig dafür anschaun. Habe ich jetzt auch getan, nur finde ich nichts was "PEW6" ähnelt. Die Eingänge der Analoganschlüsse sind weiterhin auf "Systemvorgabe" wobei da "Anfang: 752" steht. Da ich meinen Analogsensor dann gleich an den ersten Eingang anschliessen will nehme ich an dass 752 dann meiner ist. Die Frage ist nur, was schreibe ich dem FC105 dann hin? Vielleicht das hier:

    Code:
    IN :=E 752
    ?

    Weiterhin leuchtet auch die rote SF LED meiner SM338 sofort nach Einschalten auf. Die SM338 hängt in der Hardwarekonfig an 4. Stelle, und ist bislang nur mit diesem extra Datenstecker an der Rückseite mit der CPU verbunden, und sonst hängt nichts daran. Das deutet ja schon mal auf einen Fehler hin, aber da ich noch gar nichts daran gebastelt habe verwundert es mich doch etwas. Weiss vielleicht einer Rat?

    Danke im Voraus

  3. #33
    Join Date
    03.12.2008
    Posts
    929
    Danke
    213
    Erhielt 241 Danke für 150 Beiträge

    Default

    PEW steht für Peripherie Eingangs Wort
    Wenn vorher PEW 6 dasteht musst du das durch PEW 752 ersetzen.

    E 752 gibt es nicht.

    MfG
    Paul

  4. Folgender Benutzer sagt Danke zu Paul für den nützlichen Beitrag:

    DerPraktikant (15.01.2009)

  5. #34
    Join Date
    12.11.2008
    Posts
    65
    Danke
    43
    Erhielt 0 Danke für 0 Beiträge

    Default

    Verstehe, danke.
    Und wenn man Peripherie Eingangs Realzahl braucht? So wie ich gerade?

    das sollte dann PED752 sein oder?

  6. #35
    Join Date
    08.08.2007
    Location
    Dresden
    Posts
    9,882
    Danke
    1,064
    Erhielt 2,056 Danke für 1,632 Beiträge

    Default

    möööp, FC105 nimmt dein word und macht ein real daraus.
    analogin als real gibt es nicht (zumindest ist das meine bescheidene erfahrung )
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  7. #36
    Join Date
    12.11.2008
    Posts
    65
    Danke
    43
    Erhielt 0 Danke für 0 Beiträge

    Default

    Auf PEW752 geändert wird es wieder gut.

  8. #37
    Join Date
    12.11.2008
    Posts
    65
    Danke
    43
    Erhielt 0 Danke für 0 Beiträge

    Default

    Irgendwie hakt es daran dass mein OB1 den FB1 nicht so richtig aufrufen will.

    Mein OB1 enthält lediglich die Zeile
    Code:
    UC FB1
    womit er dann bedigungslos den FB1 starten sollte, in dem das Programm steht (das mittlerweile arg gekürzt wurde aus Zeitgründen). Tut er aber nicht.

    Code:
    CALL FB1,DB1
    habe ich auch versucht, da kommt dann automatisch die Liste mit den Eingaben und Ausgaben meines FB1 hin, wenn ich da dann die entsprechenden Adressen reinschreibe wie sie in der Hardwarekonfig stehen, und für den Analogeingang dann PED752 (weil er PEW752 nicht annimmt). Insgesamt kann ich das dann auch rüberladen und starten, geht aber gleich wieder in STOP und die rote LED geht an.

    So wie ich das hier deute klappt der übergang von FB1 im OB1 dann nicht, obwohl es meines Wissens aber sollte.

    Gibt es keinen Aufrufbefehl der ohne viele Fragen zu stellen gleich zu dem Baustein übergeht den er aufrufen soll?

    Nachtrag:
    Code:
    UC FB1
    scheint doch die passende Zeile zu sein. Wenn FB1 ein einfaches kleines Programmchen ist welches zwei LEDs nach 5 Sekunden anmachen soll klappt alles reibungslos.

    Dann kommt der Fehler doch wohl vom Inhalt meines FB1. Ich schau mir dannmal die Sprungleiste an als nächstes
    Last edited by DerPraktikant; 15.01.2009 at 09:50.

  9. #38
    Join Date
    03.12.2008
    Posts
    929
    Danke
    213
    Erhielt 241 Danke für 150 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    CALL FB1,DB1
    Das ist schon richtig so.



    Analogeingang dann PED752 (weil er PEW752 nicht annimmt).
    Du mußt das Wort in ein Doppelwort unmandeln.

    L PEW 752........... // Lade Peripherieeingangswort 752
    ITD .....................// wandle Integer zu Doppelinteger
    T MD 20 ..............// Transferiere das Ergebnis ins Merkerdoppelwort 20
    .........................// das MD 20 geht von M20.0 bis M23.7 dieser Bereich darf nirgendwo
    ..........................// anders verwendet sein, sont mußt du dir ein anderes freies
    .........................// Doppelwort suchen.

    Dies muß im OB1 vor dem Aufruf des FB1 stehen.
    Dort wo du PED752 hinschreiben wolltest, schreibst jetzt MD20.
    Falls der FB1 Zahlenformat "Real" erwartet mußt nach ITD noch
    DTR (Doubleinteger to Real) schreiben.
    Last edited by Paul; 15.01.2009 at 10:09.

Similar Threads

  1. Replies: 9
    Last Post: 07.02.2015, 13:36
  2. Hilfe, S7-314C-2 PtP Tot?
    By Mahon in forum Simatic
    Replies: 5
    Last Post: 04.07.2010, 22:51
  3. Analoge Sensoren an 314C-2 PTP
    By elofix in forum Simatic
    Replies: 3
    Last Post: 14.09.2009, 11:17
  4. Ram nach Rom bei der CPU 314C 2-PTP
    By S7_Mich in forum Simatic
    Replies: 3
    Last Post: 26.03.2009, 22:08
  5. IntraDrive erste Inbetriebnahme
    By Ahtam in forum Antriebstechnik
    Replies: 3
    Last Post: 14.10.2008, 12:59

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •