Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 7 of 7

Thread: S5 Simatic CPU102

  1. #1
    Anonymous Gast

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe Probleme,wenn ich den FB1 und PB1 ins AG lade und im PB1 den FB1 aufgerufen. Die CPU geht immer in Stop. Wenn ich den FB Befehl im PB1 lösche, dann geht sie wieder in RUN. Was mache ich falsch oder geht das mit der CPU garnicht??
    Reply With Quote Reply With Quote Answered: S5 Simatic CPU102  

  2. "Hallo Gast

    Vergewissere dich dass der FB1 sich wirklich im AG befindet. Ansonsten mittels USTACK den Fehler finden. Vielleicht wird im FB1 einen DB aufgerufen der sich nicht im AG befindet oder befinden sich höhere Befehle die, die CPU102 nicht auswerten kann??

    Mit der Schachtelungstiefe sollte es keine Schwierigkeit geben!

    mfG churchill"


  3. #2
    Join Date
    19.06.2003
    Posts
    193
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Default

    Hallo Gast

    Vergewissere dich dass der FB1 sich wirklich im AG befindet. Ansonsten mittels USTACK den Fehler finden. Vielleicht wird im FB1 einen DB aufgerufen der sich nicht im AG befindet oder befinden sich höhere Befehle die, die CPU102 nicht auswerten kann??

    Mit der Schachtelungstiefe sollte es keine Schwierigkeit geben!

    mfG churchill

  4. #3
    Anonymous Gast

    Default

    Hallo churchill,

    Dies habe ich in den FB geschrieben:

    NW1

    Name: test
    Bez: EIN1 E, BI
    A DB10

    NW2

    UN =EIN1
    SPB =M001

    L MW10
    L DW1
    !=F
    = A2.0
    M001 ***

    Das ganze dann noch im PB1 aufgerufen.

    Den DB und FB habe ich ins AG übertragen.
    Im OB1 habe ich nur SPA PB1 geschrieben.

    Eigentlich ganz simpel, oder???
    Was meinste dazu??

  5. #4
    Join Date
    19.06.2003
    Posts
    193
    Danke
    0
    Erhielt 4 Danke für 4 Beiträge

    Default

    Hallo Gast

    Hast du vielleicht im PB1 beim FB-Parameter einen für die SPS unbekannte Adresse angegeben? Versuchs mal als Eingangsparameter mit einem Merker.

    mfG churchill

  6. #5
    Join Date
    23.06.2003
    Posts
    81
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Hallo Leute,

    die 102er CPU kann keine Parameter an FB's !

    das geht erst ab CPU 103

    Gruß Jörg
    Reply With Quote Reply With Quote keine FB-Parameter bei CPU 102 !!  

  7. #6
    Anonymous Gast

    Default

    Danke Jogi für deine Info!!!

  8. #7
    Anonymous Gast

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Jogi

    Hab ich auch nicht gewusst..

    Danke für die Info.
    mfG churchill

Similar Threads

  1. Replies: 12
    Last Post: 07.02.2011, 22:59
  2. [Suche] S5 100U CPU102 bzw. CPU103 oder 95U
    By jojo2 in forum Suche - Biete
    Replies: 3
    Last Post: 08.12.2010, 18:29
  3. S5 CPU102; OB1 wird nicht bearbeitet
    By pfloh in forum Simatic
    Replies: 33
    Last Post: 04.05.2010, 12:21
  4. S5 100U CPU102 bleibt in stop
    By easyprivate in forum Simatic
    Replies: 9
    Last Post: 14.01.2009, 21:07
  5. Onlineverbindung S5-100 CPU102
    By Michel in forum Simatic
    Replies: 7
    Last Post: 06.09.2007, 00:06

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •