Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: Step7 BUG in der Software???

  1. #1
    Registriert seit
    01.04.2010
    Beiträge
    306
    Danke
    18
    Erhielt 38 Danke für 37 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe heute folgende Support Request anfrage an Siemens gestellt.

    Fehler beim anzeigen der Qeuerverweisliste.
    Systeme: Win 7 Ultim. 64Bit, Step7 V5.5+SP2+HF1
    Win XP Pro 32Bit, Step7 V5.5+SP3

    In der Anlage ein Screenshot und ein Testprojekt

    Folgendes Problem stellt sich dar:

    Ich öffne die Querverweise der Referenzdaten, filtere auf MB49.
    Es wir jeder Merker angezeigt (Sortiert von M49.0 -M49.7)!
    Ich maximiere und minimiere von unten beginnend jeden Merker Eintrag.
    Wenn ich bei dem Merker 49.3 angelangt bin verschwinden aufmal die Einträge für M49.5 - M49.7.

    Egal was ich in der Liste maximiere oder minimiere die Listeneinträge erscheinen nicht wieder.
    Erst wenn ich die Liste vollständig schließe und neu öffne sehe ich wieder alle Merker!

    Dann habe ich begonnen etwas rumzutesten!
    Ich öffne die Querverweisliste filtere auf MB49.
    Dann maximiere und minimiere ich M49.0 zuerst.

    Dann beginne ich wieder von unten jeden Merker zu maximieren und zu minnimieren!
    Wenn ich dann bei dem M 49.3 bin und ihn maximiere dann verschwinden die M49.5 und M49.6.

    Auch hier erscheinen die Einträge erst nach dem neu öffnen der Querverweisliste!

    Im Folgenden beschreibe ich weitere Fehler in kompakter Form die aber immer damit anfangen das ich die Querverweisliste neu öffne und nach MB49 filtere.

    1. Von unten beginnend Merker für Merker mini/maxi = bei M49.3 fehlen M49.5 - M49.7
    2. Erst M49.0 min/max dann von unten beginnend = bei M49.3 fehlen M49.5 und M49.6
    3. Erst M49.1 min/max dann von unten beginnend = bei M49.3 fehlen M49.4 und M49.5
    4. Erst M49.2 min/max dann von unten beginnend = bei M49.3 fehlen M49.4 und M49.5
    5. Erst M49.3 min/max dann von unten beginnend = bei M49.3 kein Fehler
    6. Erst M49.4 min/max dann von unten beginnend = wie beim ersten Punkt
    7. Erst M49.5 min/max dann von unten beginnend = wie beim ersten Punkt
    8. Erst M49.6 min/max dann von unten beginnend = wie beim ersten Punkt

    Vorher.jpgFehler.jpg

    Das MB 60, im Testprojekt, habe ich angelegt um die Listeneinträge zu testen.
    Der Fehler scheind dann aufzutreten wenn ein Operand mer als 8 Zeileneinträge aufweist.

    Mit dem MB 60 im Testprojekt ist es ähnlich.

    Der Fehler wird richtig heftig wenn ich die Querverweisliste ungefiltert öffne!
    Ich beginne wieder bei M60.7 maximieren dann minimieren wenn ich dann schon M60.6 maximiere verschwindet M60.7 wenn ich dann M60.6 minimiere erscheinen die letzten 5 Zeileneinträge von M60.7 wieder!

    Probiert es aus und gebt einwenig Feedback auf welchen Systemen und Software Versionen das noch so ist.

    MFG
    SKg
    Angehängte Dateien Angehängte Dateien
    Mann muß nicht alles wissen, mann sollte nur wissen wo es geschrieben steht!
    Wer lesen kann ist klar im Vorteil!
    Zitieren Zitieren Step7 BUG in der Software???  

  2. #2
    Registriert seit
    14.10.2010
    Ort
    Telgte
    Beiträge
    653
    Danke
    97
    Erhielt 129 Danke für 99 Beiträge

    Standard

    Hi SKG,

    ich habe dein Projekt mal getestet. Ich muss dabei sagen das ich zuvor noch nie so ein Problem hatte oder davon gehört hätte.
    Ich nutze Win7 Ultimate 32Bit mit Step7 V5.5 SP2 HF4.
    Nicht direkt in der von dir beschriebenen Reihenfolge aber nach einigem minimieren/maximieren ist der Effekt bei mir auch aufgetreten.

    Ich habe das dann in diversen anderen Projekten getestet und diesen Effekt nicht gehabt.
    Daraufhin habe ich den Merkerbereich MB49 in die anderen Projekte eingefügt, aber auch damit den Effekt nicht erziehlt.
    Erst als ich eine bestimmte Anzahl von Verwendungen im Projekt eingefügt hatte trat dieser Effekt ebenfalls auf.
    Dies dann aber unabhängig von dem Merkerbereich, ausschließlich durch die Menge der Verwendungen der einzelnen Variablen.

    Somit würde ich anhand der von dir getesteten Systemkombinationen und meiner Version darauf schließen das dies kein
    direktes Versionsproblem ist, sondern eine Art Anzeigefehler in den Referenzdaten, bedingt durch die Menge der Einträge zu einer
    einzelnen Variablen.
    Durch F5 Ansicht aktualisieren wurde dies aber in jedem Fall wieder korrekt dargestellt.

    Werde in der Zukunft wohl des öfteren Mal F5 drücken

    Hoffe ich konnte helfen (auch wenn ich keine Lösung dafür habe)

    Gruß, Torsten
    Programmierumgebung: Step7 V5.5, WinCCflex2008-SP3, TIA-PortalV13, MicroWinV4.0

  3. #3
    SKg ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.04.2010
    Beiträge
    306
    Danke
    18
    Erhielt 38 Danke für 37 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    also der Service Rquest hat das Problem jetzt an die Entwicklungsabteilung weiter gegeben!

    MFG
    Mann muß nicht alles wissen, mann sollte nur wissen wo es geschrieben steht!
    Wer lesen kann ist klar im Vorteil!

Ähnliche Themen

  1. Bug in CPU-Firmware oder Step7?
    Von Gebs im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 20.07.2010, 08:57
  2. Step7 von mhj software
    Von ranger484 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 04.08.2009, 13:40
  3. Step7 V5.4 Sp2 - Bug
    Von vierlagig im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 28.09.2007, 08:59
  4. step7 v5.3 software
    Von Anonymous im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 04.09.2005, 18:15
  5. Antworten: 14
    Letzter Beitrag: 15.06.2005, 17:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •