F- Ausgänge schalten sporadisch ab

JOHKU

Well-known member
Beiträge
171
Punkte Reaktionen
18
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo und alles Gute 2013!

Habe eine alte Anlage mit CPU 317-F 6 ES7 317-6FF00-0AB0 und bin dabei diese zu erweitern mit einer ET200s Station.

Funktioniert auch alles super und prima wenn nicht die Ausgänge einer F-DO vom Typ 6 ES7 138-4FB03-0AB0 so ca. alle 3-4 Minuten für etwa einen Zyklus abschalten würden.
Die Baugruppe meldet keine Störung! An der Baugruppe sind 3 Ventile a 16W angeschlossen macht also ca. 700 mA pro Kanal bzw. 2A Summenstrom über die Baugruppe.

Mögliche Ursachen ?
Überlastung der Ausgänge? Müsste jedoch eine Fehlermeldung oder Passivierung der betroffenen Kanäle verursachen.
Irgendein F-Prüfzyklus ?

Hat jemand ein ähnliches Verhalten schon beobachtet?


Gruß
Johannes
 
Zuletzt bearbeitet:

Sinix

Well-known member
Beiträge
1.588
Punkte Reaktionen
216
Mmmmmhhhh.

Woher weißt du dass es für genau einen Zyklus ist?
Hast du die Baugruppe mal getauscht?
Was hast du in der HW-Konfig parametriert, insbesondere bei Rücklesezeit und Verhalten nach Kanalfehler?

Gruß MK
 

CNC840D

Well-known member
Beiträge
120
Punkte Reaktionen
6
Das Problem hatte ich auch mal mit einer Reglerfreigabe an einem Servo....so alle paar Minuten stand er einfach da
als hätte man im die Reglerfreigabe abgeschalten obwohl das gar nicht der Fall war.

Wir haben dann einfach ein Relais an den Ausgang angeklemmt und die Freigabe über den Kontakt geschalten, danach war das Problem weg.
 
OP
J

JOHKU

Well-known member
Beiträge
171
Punkte Reaktionen
18
Danke Allen für die Antworten.

1. glaube ich dass die Baugruppe einen Sockenschuss hat. Habe sie gegen eine xxx-BF01-0AB0 getauscht und das Problem war fast weg.

2. Danach habe ich zur Entkopplung auch ein Relais verwendet und das Problem scheint gelöst zu sein.
Offensichtlich ist bei der ET200s das Verhalten stark lastabhängig.

Ich arbeite jetzt seit gut 10 Jahren mit F-Technik, meistens mit ET200M oder iSP aber man wird immer wieder überrascht!

Gruß

Johannes
 

bike

Well-known member
Beiträge
6.464
Punkte Reaktionen
794
Zuviel Werbung?
->Hier kostenlos registrieren
reagiert ein Ventil innerhalb eines PLC Zyklus?
Also das kann ich mir fast nicht vorstellen.
Daher ist mir das Problem nicht klar.


bike
 
OP
J

JOHKU

Well-known member
Beiträge
171
Punkte Reaktionen
18
@bike
Genau das konnten sich die Siemens Entwickler auch nicht vorstellen.

Als jedoch Probleme auftraten haben sie in der Dokumentation die Krücke mit den Relais empfohlen.

In meinem Fall handelt es sich um pneumatische Gas Schnellschlussventile.

Gruß

Johannes
 

Deltal

Well-known member
Beiträge
1.074
Punkte Reaktionen
140
Sind da Löschdioden in den Ventilen/Ventilsteckern? Eventuell gegen RC-Glieder tauschen, damit die Energie in der Spule langsamer abgebaut werden kann. Oder mal bei Siemens anfragen ob man auch direkt die Spule an den Ausgang hängen kann.

Ein Relais dazischenzuhängen ist natürlich keine Lösung weil du das ganze Ding dann Sicherheitstechnisch betrachten müsstest. Aber eine Relaisspule parallel zur der Ventilspule wäre mal eine Idee ;)
 
Zuletzt bearbeitet:

Larry Laffer

Supermoderator
Teammitglied
Beiträge
13.096
Punkte Reaktionen
2.721
Hallo,
ich kann das Verhalten, das Johku beschreibt, bestätigen.
Wir haben bei uns von Festo das "Sicherheits-Ventil" (so heißt es nicht, aber ich habe die richtige Bezeichnung gerade auch nicht greifbar) in Verwendung um die Gesamt-Luftzufuhr der Anlage zu schalten. Damit habe ich sporadisch (aber nicht bei jedem Testzyklus) auch das Verhalten, obwohl dieses Ventil (auch laut Festo) explizit genau für diese Anforderung gemacht ist. Festo hat uns dann empfohlen, einen anderen Anschlußstecker von denen zu verwenden (ich denke, da steckt eine Art Entkopplung drin). Das hatte aber auch keine wirkliche Abhilfe geschaffen. Am Ende haben wir dann auch die schon genannten Relais (eins für jeden Ausgang) dazwischen gebaut. Da hier ja dann schon 2 hängen bleiben müßten halte ich das nicht für bedenklich.

Das beschriebene Verhalten tritt aber tatsächlich nur mit der Siemens F-Technik auf. Davor hatten wir die Sick-Safety-Steuerungen dafür am Start und die haben das entweder nicht so gemacht (das mit dem Test-Impuls) oder es anders gelösst - jedenfalls gab es da das Problem nicht mal mit den "normalen" Anschlußsteckern.

Schön wäre es hier vielleicht, wenn man dieses Verhalten der Baugruppe ändern / abschalten könnte - das geht aber anscheinend nicht ...

Gruß
Larry
 

Deltal

Well-known member
Beiträge
1.074
Punkte Reaktionen
140
Zuviel Werbung?
->Hier kostenlos registrieren
Naja nur musst du ab einem bestimmten PL die Relais wieder rücklesen. Außerdem muss du alles nocheinmal extra in deiner Berechnung betrachten und eventuell machen dir die "schlechten" Sicherheitstechnischen Daten des Relais bzw Schützes Probleme überhaupt dein PL zu erreichen.

Die gründsätzliche Aussage "einfach mal nen Relais dazwischen" bewerte ich auch eher negativ (Siehe http://www.sps-forum.de/showthread.php/58044-Sicherheitsbewusstsein-der-Hersteller )

Im Grunde reicht es, durch einer zusätzlichen induktiven oder kapazitiven Last die kurzen Impulse zu überbrücken. Ich hatte vor x-Jahren mal Stress mit einer Pilz SPS und ein paar Hilfsschützen. Fehlermeldung war irgendwas "mit keine Last angeschlossen". Nachdem ich die Schottky Dioden an den Spulen durch Varistoren (nicht ideal, aber hatte ich gerade dabei) getauscht hatte, war dieser Fehler verschwunden.
 

Oberchefe

Well-known member
Beiträge
2.278
Punkte Reaktionen
365
Generell gibt's die Testung woanders natürlich auch (z.B. bei Rockwell), nur dass man die da abschalten kann. Hat natürlich wieder den Nachteil dass ein geschossener Transistor am Sicherheitsausgang nicht sofort erkannt wird sondern erst wenn das nächste mal abgeschaltet werden soll, ist aber beim Relais dazwischen nicht besser. Ich habe mit der Testung schon die Erfahrungung machen müssen, dass eine Zuhaltung (mit Rückmeldung ob zu) nicht dauerhaft zublieb, die paar Millisekunden reichen da offensichtlich.
 

Safety

Well-known member
Beiträge
2.005
Punkte Reaktionen
819
Hallo,
die Ausschalt, Testimpuls braucht man um den entsprechenden PL zu erreichen. Aber wenn der Ausgang der F-SPS und der Aktor im selben Gehäuse sind welches nach DIN EN 60204-1 gebaut wurde, dann kann man laut DIN EN ISO 13849-2 Anhang D Tabelle D5.2 einen Fehlerausschluss auf Kurzschlüsse zwischen zwei beliebigen Leitern machen. Es gibt F-SPSen da kann man den Testimpuls abschalten oder es gibt Bauteile zum Unterdrücken dieser, seht euch den Anhang an.
 

Anhänge

  • Filter_Klemme_Halbleiterausgang.pdf
    422,7 KB · Aufrufe: 40

CNC840D

Well-known member
Beiträge
120
Punkte Reaktionen
6
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo Oberchefe,

ich hab mich vielleicht etwas undeutlich ausgedrückt, wir haben natürlich je Ausgang ein Relais angehängt und die Kontakte in Reihe geschalten.
Ebenso haben wir die Kontakte der Relais rückgelesen.

Sorry das ich mich vieleicht ein wenig undeutlich ausgedrückt habe.
 
OP
J

JOHKU

Well-known member
Beiträge
171
Punkte Reaktionen
18
@ an Alle.
Danke nochmals für die rege Beteiligung!
Das beschriebene Verhalten habe ich nur bei ET200s Baugruppen beobachten können und zwar nur einmal in Kombination mit Norgreen Vorsteuerventilen.(Pneumatik)
Bei ET200M oder den neuen ET200iSP Baugruppen habe ich noch niemals irgendein Problem gehabt.
Ich baue Brennersteuerungen und Prozessleitsysteme mit Simatic S7 F-Technik seit 2003.
Zu den Relais.
Selbstverständlich muss man entweder Sicherheitsrelais (z.B. Siemens oder HIMA ) verwenden oder 2 Kontakte von zwei getrennten Relais in Reihe Schalten. Zwei Kontakte eines einzigen Relais sind unzureichend, da in dem Fall in dem der Anker klemmt, ein Doppelfehler auftritt.
Wenn man jetzt auch noch Relais von zwei unterschiedlichen Herstellern verwendet kommt man bei jedem TÜV dieser Welt durch.

Gruß @ Alle


Johannes
 

Safety

Well-known member
Beiträge
2.005
Punkte Reaktionen
819
Hallo,
zu einer Bewertung gehört immer erst mal ein Sollwert SIL oder PLr nur dann kann man sagen ob die Relais i.o. sind. Stichwort Diagnosedeckungsgrad nicht jedes Relais hat zwangsgeführte oder Spiegelkontakte oder wird überhaupt zurück gelesen und auch noch richtig in der SRASW Diagnostiziert?
 
OP
J

JOHKU

Well-known member
Beiträge
171
Punkte Reaktionen
18
Zuviel Werbung?
->Hier kostenlos registrieren
@ Safety

Lieber Freund,
dass Thema war: F-Baugruppe schaltet sporadisch ab.
Wollen wir jetzt wirklich die SIL Diskussion anfangen?
Möchten wir ein Hazop-Meeting zu zwei Relais organisieren? (ich bestelle dann mal die Kekse und den Kaffee)
Muss man immer mit dem Klugen…. anfangen?
Ich habe oben schon die (SIL 3) Sicherheitsrelais erwähnt aber ich empfehle Dir die EN 746-2 für Thermoprozessanlagen oder die TRD 412 für Kesselanlagen zu schmökern. Es gibt auch VDI Empfehlungen wie man prinzipiell ein sicherheitsgerichtetes Signal aufbaut.

Gruß
Johannes
 

Safety

Well-known member
Beiträge
2.005
Punkte Reaktionen
819
Hallo,
in diesem Thema sind auch solche Äußerungen gefallen:
Das Problem hatte ich auch mal mit einer Reglerfreigabe an einem Servo....so alle paar Minuten stand er einfach da
als hätte man im die Reglerfreigabe abgeschalten obwohl das gar nicht der Fall war.

Wir haben dann einfach ein Relais an den Ausgang angeklemmt und die Freigabe über den Kontakt geschalten, danach war das Problem weg.

Am Ende haben wir dann auch die schon genannten Relais (eins für jeden Ausgang) dazwischen gebaut. Da hier ja dann schon 2 hängen bleiben müßten halte ich das nicht für bedenklich.

Die letzte Antwort von Dir hatte ich nicht mehr gelesen, deshalb auch noch mal der Hinweis.
War dieser Hinweis wirklich
Muss man immer mit dem Klugen…. anfangen?
Wollte nur helfen, Entschuldigung dafür!
 

Sinix

Well-known member
Beiträge
1.588
Punkte Reaktionen
216
@ an Alle.
Danke nochmals für die rege Beteiligung!
Das beschriebene Verhalten habe ich nur bei ET200s Baugruppen beobachten können und zwar nur einmal in Kombination mit Norgreen Vorsteuerventilen.(Pneumatik)
Bei ET200M oder den neuen ET200iSP Baugruppen habe ich noch niemals irgendein Problem gehabt.
Ich baue Brennersteuerungen und Prozessleitsysteme mit Simatic S7 F-Technik seit 2003.
Zu den Relais.
Selbstverständlich muss man entweder Sicherheitsrelais (z.B. Siemens oder HIMA ) verwenden oder 2 Kontakte von zwei getrennten Relais in Reihe Schalten. Zwei Kontakte eines einzigen Relais sind unzureichend, da in dem Fall in dem der Anker klemmt, ein Doppelfehler auftritt.
Wenn man jetzt auch noch Relais von zwei unterschiedlichen Herstellern verwendet kommt man bei jedem TÜV dieser Welt durch.

Gruß @ Alle


Johannes

Hi Johannes,

offensichtlich ist damit für dich das Problem durch die Relais behoben.
Bin auch schon länger mit Siemens F-CPUs insbesondere ET200s unterwegs und
für mein Empfinden wird hier durch die Relais einfach um ein Problem drumherum gebastelt.

Bisher hatte ich nur eine eindeutig defekte 4F-DO Baugruppe, aber auch schon zweimal sporadische Ausfälle an einer F-P-pp/pm.
Als Last war hier jeweils ein Festo-Ventil. Ich sehe hier ein generelles Problem F-Ausgang vs. Ventil, an dem eigentlich Siemens Abhilfe schaffen
müsste. Das machen die aber nur wenn Sie oft genug von uns Anwendern genervt werden.
Möglicherweise könntest du ja mal von Siemens jemand kommen lassen der sich das anschaut, da es aller 3-4min passiert
ist es ja auch reproduzierbar.

MfG MK
 
Oben