FB 43 / pH Regelung

Jeremy3

Well-known member
Beiträge
116
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo zusammen,

ich benutze den FB 43 für eine Impulsbreitenmodulation, also ich möchte ein Magnetventil anszusteuern und komme mit dem FB 43 nicht zurecht. Ich möchte in Abhängigkeit von verschiedenen REALwerten ( 0.0 , 10.0, 20.0,... usw bis 100.0 ) einfach nur diesen FB 43 ansteuern. Aber er macht am Ausgang nicht das was ich benötige. Daher ein Beispiel: Ich steuere den FB 43 am INV Eingang mit 50.0 an und möchte am AUsgang bei einer Zykluszeit von z.b 4 sekunden das er zwei sekunden lang eine eins hat und 2 sekunden lang eine null und dann wieder von vorn. Wenn ich Ihn nun mit 100.0 ansteuere möchte ich das er am AUsgang dauerhaft geschaltet ist, also die kompletten 4 sekunden eine eins hat. Bei 0.0 soll er dauerhaft 0 sein usw...

Zum Programm :

siehe Bild 1 :

FB 43 :
- INV = 50.0
- PER_TM = 4s
- P_B_TM = 50 ms > vorbelegt
- RATIOFAC = 1.0 > vorbelegt
- STEP3_ON = FALSE
- ST2BI_ON = FALSE > vorbelegt
- MAN_ON = FALSE > vorbelegt
- POS_P_ON = FALSE > vorbelegt
- NEG_P_ON = FALSE > vorbelegt
- SYN_ON = TRUE > vorbelegt
- COM_RST = FALSE > vorbelegt
- Cycle = 100 ms

Betriebsart :
Soweit ich die Hilfe verstanden habe befindet sich der Baustein jetzt in der Zweipunktregelung mit unipolarem Stellbereich (0%...100%).
- MAN_ON = FALSE
- STEP3_ON = FALSE
- ST2BI_ON = FALSE

siehe Bild 2 :
DB 53 :
Datenbaustein DB 53 des FB 43, siehe unter @ aktualwert die Werte die anliegen

Ausgang QPOS_P :
Bei diesen konfigurierten Werten spinnt der AUsgang einfach nur. Er blinkt in einer sekunde einfach mehrmals, obwohl er eigentlich 2 sekunden lang eins haben sollte und 2 sekunden lang eine Null.

FRAGEN :

1. Da es sich um KEIN propotionales Magnetventil handelt benutze ich auch kein FB 41 ( CONT_C ) für meine Steuerung/Regelung. Kann ich überhaupt den FB 43 unabhängig vom FB 41 benutzen oder muss man die beiden immer in Kombination benutzen. Wie gesagt, es handelt sich nur um ein einfaches Magnetventil das mit 24 Volt über einen DO ( Digital Output ) angesteuert wird.

2. Verstehe nicht ganz was es mit der Genauigkeit zwischen PER_TM und. CYCLE vom FB 43 Pulsegen auf sich hat. Also das Verhältnis das man da wählen sollte. Ist es nicht so das umso größer das Verhältnis, umso größer auch die Genauigkeit ? Falls ja, welche Nachteile hat man dann ?

Hoffe Ihr könnt mir helfen.

Freundliche Grüße

Jeremy
 

Anhänge

  • Bild 1.png
    Bild 1.png
    22,9 KB · Aufrufe: 18
  • Bild 2.jpg
    Bild 2.jpg
    68,4 KB · Aufrufe: 11
Zuletzt bearbeitet:
OP
J

Jeremy3

Well-known member
Beiträge
116
Punkte Reaktionen
0
FB43/pH-Regelung

Hallo zusammen,

ich benutze den FB 43 für eine Impulsbreitenmodulation, also ich möchte ein Magnetventil anszusteuern und komme mit dem FB 43 nicht zurecht. Ich möchte in Abhängigkeit von verschiedenen REALwerten ( 0.0 , 10.0, 20.0,... usw bis 100.0 ) einfach nur diesen FB 43 ansteuern. Aber er macht am Ausgang nicht das was ich benötige. Daher ein Beispiel: Ich steuere den FB 43 am INV Eingang mit 50.0 an und möchte am AUsgang bei einer Zykluszeit von z.b 4 sekunden das er zwei sekunden lang eine eins hat und 2 sekunden lang eine null und dann wieder von vorn. Wenn ich Ihn nun mit 100.0 ansteuere möchte ich das er am AUsgang dauerhaft geschaltet ist, also die kompletten 4 sekunden eine eins hat. Bei 0.0 soll er dauerhaft 0 sein usw...

Zum Programm :

siehe Bild 1

FB 43 :
- INV = 50.0
- PER_TM = 4s
- P_B_TM = 50 ms > vorbelegt
- RATIOFAC = 1.0 > vorbelegt
- STEP3_ON = FALSE
- ST2BI_ON = FALSE > vorbelegt
- MAN_ON = FALSE > vorbelegt
- POS_P_ON = FALSE > vorbelegt
- NEG_P_ON = FALSE > vorbelegt
- SYN_ON = TRUE > vorbelegt
- COM_RST = FALSE > vorbelegt
- Cycle = 100 ms

Betriebsart :
Soweit ich die Hilfe verstanden habe befindet sich der Baustein jetzt in der Zweipunktregelung mit unipolarem Stellbereich (0%...100%).
- MAN_ON = FALSE
- STEP3_ON = FALSE
- ST2BI_ON = FALSE

siehe Bild 2
DB 53 :
Datenbaustein DB 53 des FB 43, siehe unter @ aktualwert die Werte die anliegen

Ausgang QPOS_P :
Bei diesen konfigurierten Werten spinnt der AUsgang einfach nur. Er blinkt in einer sekunde einfach mehrmals, obwohl er eigentlich 2 sekunden lang eins haben sollte und 2 sekunden lang eine Null.

Fragen :

1. Da es sich um KEIN propotionales Magnetventil handelt benutze ich auch kein FB 41 ( CONT_C ) für meine Steuerung/Regelung. Kann ich überhaupt den FB 43 unabhängig vom FB 41 benutzen oder muss man die beiden immer in Kombination benutzen. Wie gesagt, es handelt sich nur um ein einfaches Magnetventil das mit 24 Volt über einen DO ( Digital Output ) angesteuert wird.

2. Verstehe nicht ganz was es mit der Genauigkeit zwischen PER_TM und. CYCLE vom FB 43 Pulsegen auf sich hat. Also das Verhältnis das man da wählen sollte. Ist es nicht so das umso größer das Verhältnis, umso größer auch die Genauigkeit ? Falls ja, welche Nachteile hat man dann ?

Hoffe Ihr könnt mir helfen.

Freundliche Grüße

Jeremy
 

Anhänge

  • Bild 2.jpg
    Bild 2.jpg
    68,4 KB · Aufrufe: 14
  • Bild 1.png
    Bild 1.png
    22,9 KB · Aufrufe: 25

Thomas_v2.1

Well-known member
Beiträge
8.128
Punkte Reaktionen
2.456
Zuviel Werbung?
->Hier kostenlos registrieren
Rufst du den Baustein denn auch im 100ms Zyklus (z.B. OB35) auf? Wenn du das nicht machst wird die Zeit im Baustein falsch berechnet, und dann funktioniert dieser nicht wie gewünscht.
Ansonsten sollte das von der Beschaltung und deinen gezeigten Parametern her funktionieren.
 

Thomas_v2.1

Well-known member
Beiträge
8.128
Punkte Reaktionen
2.456
Achso, was ich auch noch sehe:
Vielleicht liegt das was du beobachtest auch an deinem auf true stehenden SYN_ON Parameter. Wenn sich INV ändert wird die laufende Impulszeit nämlich abgebrochen und anhand des Wertes von INV neu berechnet. Wenn dein vorgeschalteter Regler also auch alle 100ms eine neue Stellgröße ausgibt, bekommst du keine wirklich stabile Pulsmodulation.
Darum entweder den CONT_C seltener eine Stellgröße berechnen lassen, oder SYN_ON auf false setzen.
 

borromeus

Well-known member
Beiträge
2.270
Punkte Reaktionen
329
Ich verwende den hundertfach ohne Problem.

zu Frage 1: Ja, sicher, der FB43 ist ein Baustein, ob der einen Regler davor hat ist egal.
zu Frage 2: Cycle, ist das Zeitintervall in der Du den Baustein aufrufen solltest- das ist auch vermutlich der Fehler, da ich vermute, dass Du das nicht so machst.

Hilfe zum Baustein:
CYCLE TIME >= 1ms T#10ms SAMPLE TIME / AbtastzeitDie Zeit zwischen den Bausteinaufrufen muß konstant sein. Der Eingang „Abtastzeit“ gibt die Zeit zwischen den Bausteinaufrufen an.


Und das ergibt auch die Antwort auf Deine Frage mit der Genauigkeit. In Deinem Fall hast Du 100ms Cycle und 4s Periode. Ergibt 40 Zeitscheibchen. Dh. Du hast ein Raster von 2,5% Stelldauer. 0, 2.5, 5, 7.5, .... bis 100.0 %.
Willst Du z.B. auf 1% granular sein ändere die Cycle auf 40ms.

Also ich nehme an, dass Dein Baustein jetzt zyklisch im OB1 Zyklus aufgerufen wird und daher das von Dir beschriebene Verhalten aufweist.

Gruß
Karl
 
Zuletzt bearbeitet:
OP
J

Jeremy3

Well-known member
Beiträge
116
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
@Thomas_v2.1

herzlichen Dank, genau das war es !

@borromeus

herzlichen Dank für die Erklärung mit dem Raster. Ja ich hatte diesen im OB 1 laufen, wusste nicht das der zwingendermaßen im Weckalarm OB aufgerufen werden muss.


Hätte aber noch ein paar Fragen die mir einfallen :

1. ENtspricht die Abtastzeit CYCLE des Fb 43 immer die der OB Weckalarm Zykluszeit ? Was wenn die anders sind ?
2. Wenn man jetzt so ein Raster von 1 % wählt und Cycle auf 40 ms hat , hat man dann irgendwelche nachteile ? Da ich quasi nur 10.0 , 20.0 usw. benötige und dieses Raster schon zu genau wäre-

Freundliche Grüße

Jeremy
 
Oben