Modbuskopplung mit S7-1200

AndyD

Well-known member
Beiträge
75
Punkte Reaktionen
2
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo Gemeinde.

Habe mal wieder ein kleines Problem.
Sind meine ersten Gehversuche mit dem TIA-Portal.
Ich versuche hier gerade eine Modbuskopplung aufzubauen.
Softwarestand ist folgender:
TIA Portal V11 SP2 UD5

Hardwarekonfig:
CPU 6ES7 214-1AG31-0XB0
CM1241 6ES7 241-1CH31-0XB0

Jetzt habe ich von der Siemens Support Seite mir schon folgende Hilfestellung geholt
Beitrags-ID 47756141 (Wie realisieren Sie eine MODBUS-RTU-Kommunikation mit Step 7 (TIA Portal) V11 für die Simatic S7-1200 ? )

Die Bausteine bei diesem Beitrag habe ich geladen und im Programm eingefügt.
Allerdings, direkt beim Baustein "MB_COMM_LOAD" beim Eingang PORT stoße ich an eine Grenze.
Laut Beitrag soll hier der symbolische Name des Kommunikationsmoduls auswählbar sein.
Ist er aber nicht. Als Fehler bekomme ichhier auch "Ungültiger Wert für die Port-ID(falsche Adresse für das Kommunikationsmodul)." ausgegeben.

Habe schon in der Hardwarekonfig gesucht, aber ich finde die Port-ID dort einfach nicht.

Hat jemand von euch eine Idee wo ich diese finde?

Grüße aus der Pfalz

AndyD
 
OP
A

AndyD

Well-known member
Beiträge
75
Punkte Reaktionen
2
Hallo Gemeinde.
Die Port -ID habe ich mittlerweile gefunden.
Allerdings gestaltet sich nun das nächste Problem:

Der Hardwareaufbau zum testen besteht mittlerweile aus einem "älteren" Laptop mit RS-232 Schnittstelle. Danach habe ich einen Umsetzer von RS-232 auf RS-485. Zwischen Laptop Schnittstelle und diesem Umsetzer habe ich nun ein altes PG mit Comwatch gesetzt. Vom Umsetzer geht dann eine Profibusleitung auf das CM1241. Mit meinem normalen Laptop bin ich dann online im TIA-Portal.

Konfiguriert ist momentan eine Geschwindigkeit von 9600kB/s, keine Parität, 8 Datenbits und 1 Stopbit.
Wenn ich nun den Slave starte und in der Onlineansicht im TIA-Portal bin, sehe ich nun den Datenfluss im Comwatch auf dem PG. Hier sehe ich eindeutig die Anfrage des Masters an den Slave und auch die Antwort des Slaves. Also rein aufgrund des Datenflusses erkenne ich keinen Fehler mehr.

In der Onlineansicht sieht erst einmal auch alles soweit gut aus, außer dass die Daten des Slaves im Ziel-DB nicht ankommen.
Einen Fehler kann man an dem Siemens Baustein FB1081 "MB_MASTER" im normalen Modus auch nicht erkennen.
Wenn ich allerdings eine MOVE-Funktion nutze, wo ich am Anschluss EN das ERROR Bit des FB1081 verknüpfe und dann den STATUS des FB1081 in ein MW verschiebe, dann steht da tatsächlich weiterhin die Fehlermeldung "80C8 Slave-Timeout. Überprüfen Sie die Baudrate, Parität und die Anschlüsse des Slaves."

Natürlich habe ich Baudrate, Parität und Anschlüsse mehrfach geprüft. Ich sehe ja auch die Antwort des Slaves auf dem BUS und auch die Antwortzeit ist direkt.

Hat hier vielleicht jemand eine Idee?

Grüße aus der Pfalz

AndyD

P.S.:

Hier ein Auszug aus dem Comwatch:
MASTER: 04 03 00 00 00 02 C4 5E
SLAVE: 04 03 04 00 64 00 C8 EF 7A
 
Zuletzt bearbeitet:

Oberchefe

Well-known member
Beiträge
2.661
Punkte Reaktionen
478
Zuviel Werbung?
->Hier kostenlos registrieren
Master:
Code:
Poll Analysis
-------------
Device Address =4       =0x04
Function       =3       =0x03 =Read Holding Registers
Point Address  =40001   
Point Count    =2

Slave:
Code:
Response Analysis
-----------------
Device Address =4       =0x04
Function       =3       =0x03 =Read Holding Registers
Point Address  =40001   (Obtained from Poll)
Point Count    =2       (Obtained from Poll)
    Point Address  =40001   Value=100  =0x64
    Point Address  =40002   Value=200  =0xc8

soweit also erst mal in Ordnung
 
OP
A

AndyD

Well-known member
Beiträge
75
Punkte Reaktionen
2
Hallo,

Ja, soweit ist alles in Ordnung.
Habe den Fehler auch gefunden.
Ist schon etwas peinlich.
Der Umsetzer von RS-232 auf RS-485 hat verschiedene Dipschalter. Da keine Beschreibung mehr davon vorhanden ist, wurde an dieser Stelle von mir halt die verschiedenen Möglichkeiten ausprobiert.
Letztlich war es also nur ein DIP-Schalter, der falsch stand.
Jetzt funktioniert es...

Dennoch Danke.

Grüße aus der Pfalz

AndyD
 
Oben