Problem mit mm Anzeige bei CMMP

Jusch

Well-known member
Beiträge
56
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo,

ich hab ein kleines Problem bei drei Festo Antrieben des Typs: CMMP in Verbindung mit den Achsen EGC-120-500-TB-KF-OH-GK und EGC-120-850-TB-KF-OH-GK.

Erstmal zum Aufbau der Steuerung:

Die CMMP´s werden via Profibus über eine Siemens S7-313C-DP im Positioniermodus angesteuert. In den Festo Servoumrichtern (CMMP) habe ich eingestellt das ich die Position in mm ausgegeben haben will. Aber irgendwie hat meine Achse eine Verfahrtweg von 1500mm statt eigentlich 850mm (die Größe der Achse).

Danke schonmal für eure Antworten

Gruß
Jusch
 

Tigerente1974

Well-known member
Beiträge
1.815
Punkte Reaktionen
289
Ich kenne zwar nicht das Antriebssystem, aber da wird es mit großer Wahrscheinlichkeit einen Parameter geben, der das Verhältnis des Gebers EH/mm bestimmt. Dieser muss dann noch angepasst werden.
 
OP
J

Jusch

Well-known member
Beiträge
56
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo Tigerente1974,

ich hab diesen Parameter auch schon gefunden und alles auf mm eingestellt, zudem hab ich auch noch mit dem Festo Support dieses Problem besprochen und die konnten mir auch nicht richtig weiter helfen. In meinem System sind ja noch drei weitere Festo Servoumirchter mit einer anderen Achse verbaut, diese haben einen Verfahrweg von 300mm und den bekomm ich auch richtig über Profibus ausgegeben/angezeigt. Genau diese Prametereinstellungen habe ich dann für die anderen drei Achsen übernommen, womit ich das Problem habe, aber leider hat sich nichts verändert.

Gruß
Jusch
 

Tigerente1974

Well-known member
Beiträge
1.815
Punkte Reaktionen
289
So aus der Ferne mit fehlenden Detailkenntnissen ist das schwierig zu beurteilen. Übertragung und Auswertung des Signals auf der SPS-Seite sauber? Sitzt der Geber am Motor? Dann bleibt doch eigentlich nur noch, dass die Übersetzung Motor/Last ein anderes Verhältnis als angegeben hat. Nimm doch mal 2 weitere Punkte. Z.B. jeweils nach 1/3 der Strecke und prüfe, ob sich der mm-Wert analog dazu linear verhält. Falls ja, pass doch den Parameter so an, dass es stimmt.
 
OP
J

Jusch

Well-known member
Beiträge
56
Punkte Reaktionen
0
Hallo Tigerente 1974,

Erstmal danke für deine schnellen Antworten. Ich kann das Übersetztungsverhältnis nochmals ändern, wobei es bei Festo so ist das man die Achse mit Motor usw. alles eingibt und das Programm dann schon von allein weiß welches Übersetzungsverhältnis gewählt worden ist. Aber ich werde es nochmals ausprobieren.

Gruß
Jusch
 
Oben