Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 22

Thema: WInCC V7.0 SP3 Upd 1 Absturz Script.exe

  1. #11
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja da bin ich ja mit angefangen und Scheiter an den vorhandenen angeblich nicht vorhandenen Variablen


    Gesendet von meinem iPhone mit Tapatalk
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  2. #12
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Hab ich zwar noch nicht gesehen, aber die Meldung davor lautet ja "Tag unknown, timeout or conversion failed".

    Ich weiß nicht ob es so einen Fehler gibt, wenn versucht wird eine Word Variable per GetTagBool zu lesen, oder etwas anderes was nicht zusammenpasst. Wenn du sagst die Variablen würden existieren, Adressen passen usw.

    Quality code 4c ist imho Startwert, d.h. sie wurde noch nie gelesen.

  3. #13
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    [So ich habe nun diverse Änderungen vorgenommen und auch einige Schreibfehler und fehlende Variablen usw. gefunden.

    Ich habe nochmals eine Error TXT angehängt wo doch noch einige Fehler auftauchen. Insbesondere das " Bild nicht angewählt" macht mich stutzig. Hat jemand vielleicht noch eine Idee bzw. einen Ansatz wo ich suchen könnte???

    ATTACH]29037[/ATTACH]

    Danke für eure Hilfe
    Angehängte Dateien Angehängte Dateien
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  4. #14
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    "Bild nicht angewählt" kommt auch, wenn du z.B. per Skript via SetPropXY() eine Eigenschaft eines Objektes mit falschen Bildnamen schreiben willst, nur als Beispiel. Oder es gibt das Bild, aber es ist nicht aktiv, d.h. nicht geladen. Wenn du von einem Fenster was sich in einem Bildfenster befindet ein anderes manipulieren willst, muss der komplette Pfad stimmen.
    Schema: Bildname.Bildfenster:Unterbildname.Unterbildfenster:Unterunterbildname

    Bei deinem Eintrag um 2015-06-15 13:33:11.221 ist demnach im Bild START.pdl ein Bildfenster mit Namen MENU in welches das Bild MENUUEBERSICHT.pdl geladen wurde. In diesem gibt es ein Objekt mit Namen Gruppe 9 an dem es einen Fehler gibt. Da musst du dieses Objekt überprüfen was dort gemacht wurde. Gleiches bei den anderen Fehlermeldungen.
    Geändert von Thomas_v2.1 (15.06.2015 um 18:41 Uhr)

  5. #15
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    "Bild nicht angewählt" kommt auch, wenn du z.B. per Skript via SetPropXY() eine Eigenschaft eines Objektes mit falschen Bildnamen schreiben willst, nur als Beispiel. Oder es gibt das Bild, aber es ist nicht aktiv, d.h. nicht geladen. Wenn du von einem Fenster was sich in einem Bildfenster befindet ein anderes manipulieren willst, muss der komplette Pfad stimmen.
    Schema: Bildname.Bildfenster:Unterbildname.Unterbildfenster:Unterunterbildname

    Bei deinem Eintrag um 2015-06-15 13:33:11.221 ist demnach im Bild START.pdl ein Bildfenster mit Namen MENU in welches das Bild MENUUEBERSICHT.pdl geladen wurde. In diesem gibt es ein Objekt mit Namen Gruppe 9 an dem es einen Fehler gibt. Da musst du dieses Objekt überprüfen was dort gemacht wurde. Gleiches bei den anderen Fehlermeldungen.
    Hallo,

    also ich habe das mal überprüft. Eine Gruppe Neun gibt es. An dieser Gruppe wird per Mausklick wieder eine C-Aktion ausgeführt ( Bildwechsel via Skript). (also bei Mausklick).

    Da kann ich leider so mal keinen Fehler erkennen. In den Bildwechsel Skripten werden folgende Befehle ausgeführt:

    PictureStore("PortalDetailPortalSchalter", "MenuPortal", "MenuPortalDetailportal", "MenuPortalDetailPortal", "Schalter")

    Es passiert folgendes Es öffnet sich das Menu Portal , darin das Bild MenuPortalDetailPortal in dem Bild: MenuPortalDetailPortalDetail wird eine Schaltfläche der Hintergrund verändert. Als Großes Bild öffnet sich außerdem PortalDetaiilPortalSchalter

    Die verändernde Schaltfläche heißt Schalter.

    Allerdings würde ich von daher sagen es ist alles korrekt. Daher sind mal die Experten hier gefragt.

    Ihr seid übrigens Spitze.
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  6. #16
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Da musst du dir die Funktion PictureStore mal genauer ansehen, das ist zumindest keine WinCC Systemfunktion. Wahrscheinlich findest du diese über Global-Script als Projektfunktion wieder.

  7. #17
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Ja das ist irgendwas selbst gemachtes. Ich schau sie mir mal an


    Gesendet von meinem iPhone mit Tapatalk
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  8. #18
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    anhängend mal die Scripte die wohl Ursächlich sind.

    Wäre super wenn jemand mal eine Fehlerstelle finden könnte.

    Also das ist dann doch schon sehr komplex aus meiner Sicht.
    Angehängte Dateien Angehängte Dateien
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  9. #19
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    So aktuell hing der Rechner mal wieder. Mit Apdiag und Info First Action bekomme ich folgend Fehlermeldung:

    stack.txt

    Interpretiere ich das Richtig, das im Bild Start.pdl im Bildfenster Kopf das Bild Kop.pdl geladen ist und Probleme macht? zbd zwar am Objekt Dummy Feld ?

    Mein Prozess Skript.exe ist noch vorhanden und läuft allerdings mit 45 MB Arbeitsspeicher wobei ich nicht beurteilen kann ob das viel ist.
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  10. #20
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kannst ja mal schauen ob es dort ein Objekt "DummyFeld" gibt, und ob dort noch irgendwelche Skripte anhängen.

    Was direkt auffallend falsches an diesem PictureManagement habe ich jetzt nicht gesehen. Wobei man das erst genau bewerten kann wenn man sieht wie das ganze Menü aufgebaut ist. Aber mir sieht es nicht so aus als ob dort die Schreib- oder Lesezeiger außerhalb der Grenzen laufen können, und dann irgendwo auf anderen Speicher zugegriffen wird.

    Wann bleibt WinCC denn hängen? Wenn etwas bedient wird (z.B. eben Bildwechsel über die Navigation), oder auch ohne dass jemand etwas macht?

Ähnliche Themen

  1. WinCC Flex 2008 SP3 Script CreateObject
    Von nowayray im Forum HMI
    Antworten: 1
    Letzter Beitrag: 19.04.2013, 14:17
  2. Antworten: 0
    Letzter Beitrag: 26.11.2012, 19:36
  3. Antworten: 0
    Letzter Beitrag: 24.08.2012, 09:45
  4. Absturz von S7KAFAPX.EXE bei Texteingabe
    Von exert im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 01.11.2009, 15:46
  5. Antworten: 3
    Letzter Beitrag: 17.11.2005, 10:57

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •