Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: AGLink + Hilscher - Karte / Probleme

  1. #1
    Registriert seit
    25.06.2005
    Beiträge
    108
    Danke
    19
    Erhielt 13 Danke für 13 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    einer unserer Kunden wollte sich selbst als Programmierer versuchen und seine Scada - Applikation auf einem neuen Rechner aufsetzen.
    Zur Anwendung gehörte eine Hilscher- CiF50-PB Profibus-PCI- Karte, welche er ebenfalls in den neuen PC eingebaut hat.
    Nachdem dieser "fliegende Wechsel" der Applikation aufgrund von Treiberproblemen scheiterte,
    wurde vom Kunden die Profibuskarte wieder in den alten Rechner rückgebaut.
    Nun ist aber auch in der alten Konstellation kein Betrieb am Profibus mehr möglich, denn AGLink meldet:

    "Fehler in einer Gerätetreiberfunktion" beim SPS-Test

    Alle anderen Funktionen melden beim Testen keine Probleme, nur die Buskommunikation scheint gestört.
    Auch ein "Trockentest" mit einer CPU bei uns im Haus schafft keine Abhilfe.

    Hat unser Kunde eventuell die CIF-Karte beim Aus- und Einbauen in jenseits befördert ?

    Hat jemand von euch eine Idee ?

    Danke Uwe
    Zitieren Zitieren AGLink + Hilscher - Karte / Probleme  

  2. #2
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    642
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Welche Version von AGLink kommt zum Einsatz? Lief die Karte bereits einmal mit AGLink? Welche Version der CIF kommt zum Einsatz?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #3
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    642
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Erkennt das Gerätetreiber-Setup die Karte?
    Ist diese dort als entsprechende Karte (0-3) verfügbar?
    Was sagt der Gerätetreibertest, also die Applikation von Hilscher?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  4. #4
    Nais ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2005
    Beiträge
    108
    Danke
    19
    Erhielt 13 Danke für 13 Beiträge

    Standard

    Hallo Herr Hönle,

    Welche Version von AGLink kommt zum Einsatz? Lief die Karte bereits einmal mit AGLink? Welche Version der CIF kommt zum Einsatz?
    Der Karte lief bis zum missglückten Rechnertausch ohne Probleme mit AGLink 3.7. Nach dem Rücktausch in den alten Rechner war plötzlich auch hier kein Connect mehr möglich.
    Die Kartenversion muss ich nachsehen, gekauft ist Sie im Jahr 2005.

    Erkennt das Gerätetreiber-Setup die Karte?
    Ist diese dort als entsprechende Karte (0-3) verfügbar?
    Was sagt der Gerätetreibertest, also die Applikation von Hilscher?
    Das Treiber -Setup lief ohne Probleme, die Karte wurde sauber erkannt.
    Der Download per Hilscher Sycon war auch ohne Probleme, die Config wurde ohne Fehler eingespielt.

    Uwe

  5. #5
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    642
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Wen die Karte in einen anderen PCI-Slot gesteckt wird, kann es sein, dass sie nicht mehr als "die alte" erkannt wird. Deshalb Treiberkonfiguration laufen lassen. Was wird dort angezeigt? Bei welcher Boardnummer?
    Dann Treibertestprogramm laufen lassen. Funktioniert hier alles? Speziell interessiert mich die Ausgabe der Geräteinfo wie DevGetBoardInfo, DevGetInfo, DevInitBoard, DevOpenDriver.
    Wie ist AGLink_Config genau eingestellt?
    Wenn es dieselbe Karte ist, dann hat sich mein erster Post erübrigt. Es kam nur vor, dass eine neuere Kartengeneration mit einer neuen ID versehen wurde und ich diese dann in der älteren AGLink-Version nicht als CIF-Profibuskarte erkannt habe. Ist aber heir nicht der Fall.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  6. #6
    Nais ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2005
    Beiträge
    108
    Danke
    19
    Erhielt 13 Danke für 13 Beiträge

    Standard

    Problem gelöst:

    Ich trau mich gar nicht zu schreiben woran es lag:

    Der Kunde hat trotz mehrmaligem Hinweis darauf an dem "roten Schieber, dort wo das lila Kabel raus kommt" gespielt !

    Mehr brauch ich wohl nicht mehr schreiben...

    Trotzdem besten Dank für die Hilfe bei der "Phantomjagd" Herr Hönle !

  7. #7
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    642
    Erhielt 955 Danke für 769 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Gern geschehen.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

Ähnliche Themen

  1. Netlink Hilscher NL 50-MPI
    Von Andi2 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 14.06.2011, 15:48
  2. Codesys -> Hilscher CIF50PB
    Von röhrengertl im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 08.12.2010, 07:31
  3. Mit flex2008 über Hilscher DP-Karte auf CPU
    Von Johannes F im Forum HMI
    Antworten: 10
    Letzter Beitrag: 16.03.2009, 08:12
  4. Hilscher PKV 30-DPS
    Von Ass0384 im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 05.03.2009, 08:52
  5. cif 50pb von Hilscher
    Von bernd7 im Forum Feldbusse
    Antworten: 1
    Letzter Beitrag: 17.12.2006, 22:44

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •