Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: 2 MPI Teilnehmer an CPU 313C-2DP

  1. #1
    Registriert seit
    05.07.2008
    Beiträge
    41
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Unglücklich


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe eine CPU 313C-2DP, am X1 MPI ist ein Helmholz MPI Adapter eingesteckt (SWW7-HMI). Dieser kommuniziert mit meinem Bedienpanel VTP-C120. Der MPI Anschluss des Adapters besitzt einen Doppelstecker. Auf diesem, steckt mein Siemens MPI Adapter (S7 PC USB ADAPTER).
    Es scheint mir, dass es zu Kollisionen zwischen den beiden Teilnehmern kommt, da wenn ich Bausteine beobachte die Verbindung sporadisch zusammenbricht.

    Gibt es da eine Möglichkeit wie ich ohne diese Abbrüche arbeiten kann?
    Bzw. Mach ich vielleicht was falsch....

    Vielen Dank im Voraus.

    Gruß Tobias
    Zitieren Zitieren 2 MPI Teilnehmer an CPU 313C-2DP  

  2. #2
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Normalerweise sollten sich die beiden vertragen. Wie ist die Terminierung am HMI-Adapter eingestellt? Schon einmal geändert? Mit welcher Geschwindigkeit läuft X2? Kann ggf. der USB-Adapter darüber verwendet werden?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #3
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Hast du auch verschiedene MPI Adressen eingestellt?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Zitieren Zitieren MPI Adresse??  

  4. #4
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von Jochen Kühner Beitrag anzeigen
    Hast du auch verschiedene MPI Adressen eingestellt?
    Habe ich auch zuerst überlegt. Aber dann dürfte nur der erste Adapter an den Bus kommen. Der zweite würde gleich beim Login eine Fehlermeldung erzeugen. Er würde also gar nicht zu den sporadischen Abbrüchen kommen.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  5. #5
    Registriert seit
    05.07.2008
    Beiträge
    41
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Blinzeln

    Danke für die ersten Tips.

    Der Endwiderstand am Doppelstecker ist offen.

    Der Adapter am Panel ist so Eingestellt

    Fehlertoleranz = 0
    Schnittstelle = COM2
    Geschwindigkeit = 19.200 Baud
    MPI Adresse = 0
    letzte MPI im BUS = 31

    Die CPU Schnittstelle:

    MPI Adresse = 2
    Vernetzt = Ja
    Subnetz = MPI(1) 187.5 kBit

    Der PC Adapter

    MPI Adresse = 1
    Timeout = 30s
    Geschwindigkeit = 187.5 kBit
    letzte MPI im BUS = 31

    Pg/PC ist einziger Master am Bus = Ja

    Was mir aufgefallen ist, dass in HW Eigenschaften der CPU --> Kommunikation steht:

    Verbindungs Ressourcen Reserviert für :

    BASIS = 0
    OP = 1
    PG = 1

    Am X2 steckt der Profibus.....

    Gruß Tobias
    Geändert von Herrminator (31.01.2009 um 20:28 Uhr) Grund: Hab was vergessen
    Zitieren Zitieren Einstellungen  

  6. #6
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Mit dem Endwiderstand mal experimentieren bzw. auch mal kräftig schlaten, nicht dass die Stellung nicht zur tatsächlichen Einstellung passt.
    Der Haken bei einziger Teilnehmer am Bus kann entfallen, da sowohl der HMI-Adpater als auch die 313er Master sind und somit insgesamt 3 Master mitspielen.
    Bei den Verbindungen wird nur angezeigt, welche reserviert sind (bzw. daneben welche belegt sind). Dies kann in der Hardware-Konfiguration geändert werden. Hat aber für diesen Fall keine Bedeutung.
    Selbst wenn an X2 der Profibus steckt und mit max. 1,5 MBit/s läuft, einfach mal den dort den USB-Adapter testen. Ändert sich an grundsätzlichen verhalten was?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  7. #7
    Registriert seit
    05.07.2008
    Beiträge
    41
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also am X2 geht der MPI Adapter garnicht.

    Meldung:

    Die lokale MPI Adresse des PG/PC ist größer als die Maximale Teilnehmeradresse oder es ist eine falsche Baudrate oder Interrupt eingestellt.

  8. #8
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Den Siemens-USB-Adapter auf Profibus, die richtige Baudrate und die richtige HSA umstellen. Nicht zur umstecken.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  9. Folgender Benutzer sagt Danke zu Rainer Hönle für den nützlichen Beitrag:

    Herrminator (01.02.2009)

  10. #9
    Registriert seit
    05.07.2008
    Beiträge
    41
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Lächeln

    Ah jetzt hab ichs gesehen wie das Umstellen geht. Bis jetzt scheint es stabil zu laufen über PB. Vielen Dank für eure Tips. Hab ich heute wieder einiges gelernt. Danke nochmal. Hoffe das geht weiterhin so gut.

    Gruß

  11. #10
    Registriert seit
    05.07.2008
    Beiträge
    41
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Funktioniert ohne Probleme !!!

    Danke nochmals.

    Gruß Tobias
    Zitieren Zitieren Wunderbar  

Ähnliche Themen

  1. Can-Bus Teilnehmer tauschen
    Von Jesch im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 21.03.2010, 08:52
  2. S7-200 nur Unbekannte Teilnehmer
    Von snowXtal im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 28.04.2009, 13:04
  3. ASI-Bus Teilnehmer
    Von agn im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 26.09.2008, 13:50
  4. Antworten: 0
    Letzter Beitrag: 28.07.2006, 08:30
  5. Kommunikationsprobleme div Teilnehmer
    Von Keinweltmeister im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 14.07.2006, 08:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •