Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 5 ErsteErste 12345 LetzteLetzte
Ergebnis 21 bis 30 von 41

Thema: Flackernde Analogwerte

  1. #21
    Registriert seit
    22.08.2009
    Beiträge
    64
    Danke
    8
    Erhielt 6 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    vielleicht ist es nicht richtig das ich mich hier so dranhänge. aber ich habe auch ein ähnliches Problem bei einer Anlage. Es kommt öfters vor das mir der Analogeingang völlig ausreist. Das PEW steht so bei 8000 und reist dann plötzlich kurz auf sein maximum aus. der geber macht sicher kein problem.
    bin nächste woche wieder bei der anlage. vielleicht hat jemand schon mal so ein problem gehabt. Danke im voraus!
    Zitieren Zitieren Analogwert nicht korrekt  

  2. #22
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    4..20 oder 0..10?
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. #23
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Beitrag

    Hallo,

    Zitat Zitat von berni_rb
    vielleicht ist es nicht richtig das ich mich hier so dranhänge. aber ich habe auch ein ähnliches Problem bei einer Anlage.
    Nee, ist schon Ok, ist ja das gleiche Thema.

    Zitat Zitat von berni_rb
    Es kommt öfters vor das mir der Analogeingang völlig ausreist. Das PEW steht so bei 8000 und reist dann plötzlich kurz auf sein maximum aus. der geber macht sicher kein problem.
    Ist die SPS nun eine S5 oder eine S7 (mich macht der Wert 8000 etwas stutzig) ? Und welche AE wird da eingesetzt ?
    Mach doch bitte ein paar nähere Angaben dazu, vielleicht können wir Dir dann besser weiterhelfen.

    Gruß

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren Da brauchen wir noch ein paar Infos von Dir ...  

  4. #24
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    ich fürchte das wird wie mit mac hawk enden ... und wir bleiben weiter am rätseln ...
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  5. #25
    Registriert seit
    22.08.2009
    Beiträge
    64
    Danke
    8
    Erhielt 6 Danke für 5 Beiträge

    Standard

    Danke für die Rückantwort.

    Also CPU 315. Analogkarten: SIMATIC S7-300, ANALOGEINGABE SM331, POTENTIALGETRENNT 8AE, AUFL. 13BIT U/I/WIDERSTAND/PT100, NI100, NI1000, LG-NI1000 66MS WANDLUNGSZEIT,
    1 X 40-POLIG

  6. #26
    Registriert seit
    22.08.2009
    Beiträge
    64
    Danke
    8
    Erhielt 6 Danke für 5 Beiträge

    Standard

    und das Problem habe ich bei 4-20mA

  7. #27
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Vielleicht nicht geschirmte Leitungen und daneben ein dicker Antrieb?
    Das Problem kenn ich wenn nicht geschirmt und Störstahlung.
    Stimmt es sollte bzw darf bei Stromwandler keinen EInfluss haben, sagt die Theorie, doch die Praxis ist etwas anders.
    Daher habe ich eine Plausabiltätsprüfung über den Eingang geschrieben.
    Wenn der Wert zu schnell nach zu gross oder zu klein sich ändert, neuen Messwert wegwerfen und letzten Wert einfrieren.
    Wenn länger keine plausiblen Werte kommen, dann gibt es Störung.
    Ist nicht ganz fein, aber es funktioniert


    bike

  8. #28
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi

    Daher habe ich eine Plausabiltätsprüfung über den Eingang geschrieben.
    Wenn der Wert zu schnell nach zu gross oder zu klein sich ändert, neuen Messwert wegwerfen und letzten Wert einfrieren.
    Wenn länger keine plausiblen Werte kommen, dann gibt es Störung.
    Ist nicht ganz fein, aber es funktioniert

    Grundsätzliche Frage an alle:
    ( Hat eigentlich nichts mit Bike zu "tun" )

    Habt ihr auch Filter/"Plausibilitätsüberprüfungen" an euern Analog-Eingängen ?
    Karl

  9. #29
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    ehrlich gesagt nicht, obwohl stellenweise kann es auch die
    Baugruppe übernehmen. Die Diagnosefähigen Baugruppen liefern
    bei überlauf hex 7FFF oder bei unterlauf hex 8000 einen Diagnosealarm.

    Das erklärt auch das problemm bei berni_rb, da entspricht
    die hex 8000 - 0mA, die dürfte er aber bei der einstellung
    4-20mA garnicht haben.
    Vlt. hat doch der geber ein problemm....?
    Geändert von rostiger Nagel (17.10.2009 um 11:44 Uhr)
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  10. #30
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Helmut_von_der_Reparatur Beitrag anzeigen
    Vlt. hat doch der geber ein problemm....?
    Genau aus diesem Grund prüfe ich die Werte und unterscheide nach sinnvoll und -los.
    In den letzte 30 Jahren habe ich eben die Erfahrung gemacht, dass solche Funktionen sinnvoll sind.
    Jeder wie er will, mag und kann


    bike

Ähnliche Themen

  1. Analogwerte
    Von siqo im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 07.07.2011, 01:30
  2. Analogwerte
    Von Alexandr im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 12.08.2010, 13:59
  3. analogwerte
    Von Majus68 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 31.08.2009, 14:41
  4. Analogwerte wandeln
    Von jethon im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 06.09.2008, 11:09
  5. Analogwerte mit AS-i
    Von Johnathan im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 09.02.2006, 18:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •