Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 27

Thema: Profinet Verbindung zwischen S7 und Kuka KRC4 Compact

  1. #1
    Registriert seit
    17.03.2015
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Ich möchte eine S7 1516F-3 PN/DP Cpu mit einer Kuka KRC 4 Compact steuerung über Profinet verbinden. Das ganze mit TIA V13 SP1.
    Habe die KRC4 per GSD Datei in TIA eingebunden, IP, Profinet Name und Gerätenummer vergeben.
    Ich kann den Kuka auch anpingen aber finde ihn im TIA nicht. Auf die CPU komm ich drauf, habe auch die Hardwarekonfig natürlich geladen.

    Hat jmd eine Idee was ich noch testen könnte?

    Vielen Dank schon mal!
    Zitieren Zitieren Profinet Verbindung zwischen S7 und Kuka KRC4 Compact  

  2. #2
    Registriert seit
    09.01.2012
    Beiträge
    466
    Danke
    25
    Erhielt 38 Danke für 35 Beiträge

    Standard

    Was heisst du findest ihn im TIA nicht?

    Die SPS hat keine Kommunikation zu ihm? Was sagt die OnlineDiagnose der Steuerung?

    Sind die beiden Geräte im gleichen Netz?

    Bring mal mehr Informationen

  3. #3
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    zeigt KRC4 einen Fehler in der Kommunikation?
    Stimmen die Einstellungen bei Profinet im KRC4. (Gerätenamen, IP..usw...)
    Kuka nach Änderungen der SPS nochmal hochfahren.
    Wer ist Master?

  4. #4
    f.zaunberger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.03.2015
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Im TIA finde ich den Kuka nicht unter erreichbare Teilnhmer.
    CPU und Roboter sind beide im gleichen Profinet IO-System konfiguriert

  5. #5
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    erreichbare Teilnehmer geht soweit ich weiss über MAC-Adresse.
    Ist ein Switch oder Router oder irgendwas dazwischen, der das nicht weiterleiten kann (Broadcast) , dann gibts keinen erreichbaren Robbi.

  6. #6
    f.zaunberger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.03.2015
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    CPU ist Master.
    KRC 4 zeigt keinen Fehler an, kann auch die CPU "blinken" lassen und KRC bekommt mit wenn SPS in Stop oder Run geht. Also geht die Kommunikation ja schon...nur stimmt was im TIA nicht.
    Gerätename, IP usw alles eingestellt und gleich (im TIA und in WorkVisual).

    Ich kann ja nicht mit der KRC4 kommunizieren also E/A s senden/empfangen wenn mir TIA sagt KRC4 ist nicht erreichbar...

  7. #7
    f.zaunberger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.03.2015
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Roboter hängt direkt an X1 P1 der CPU
    In der Diagnose zeigt es mir auch keine Infos über den Robi an (Mac oder sonst was)

  8. #8
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Die E/A Länge und Adressen beidseitig richtig eingetragen?
    findet die KRC4 die SPS? da gibts doch auch Meldungen

  9. #9
    f.zaunberger ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.03.2015
    Beiträge
    18
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Die Anzahl der E/As gibt mir ja die GSD mit (64 sichere und 256 normale EAs) an den Adressen habe ich bisher noch nichts geändert aber das sollte ja nichts damit zu tun haben das mir TIA sagt der Robi ist nicht erreichbar
    Die KRC4 findet mich...wie gesagt in WorkVisual kann ich die CPU blinken lassen!

  10. #10
    Registriert seit
    11.12.2009
    Beiträge
    2.113
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also dann gehen wir mal durch:

    IP Adressen stimmen? (Kuka -> Konfiguration -> Netzwerkschnittstelle)
    Im WoV den Kuka als Slave aktiviert ?
    Gerätenamen stimmen?
    Kommunikationslänge korrekt eingestellt (Sowohl SPS als auch Kuka)?
    Safety-ID korrekt gesetzt (Bei Kuka ist sie im Standard auf 7!)
    Projekt geladen und aktiviert?
    Kaltstart mit Dateien neu einlesen durchgeführt?
    Kommen am Kuka Fehlermeldungen wie "Verbindung PNIO DEV falsch" oder "Kommunikationsausfall mit SPS 20000ms"?
    Bist du auf der richtigen Schnittstelle am KRC4 Compact (Es ist die rechte Netzwerkbuchse im Hartingstecker direkt über dem grünen Hauptschalter)?

    Grüße

    Marcel
    Stell Dir vor es geht, und keiner kriegts hin!

Ähnliche Themen

  1. Step 7 Profinet Verbindung zwischen PC-Station und CPU
    Von NeuerUser2015 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 10.03.2015, 19:03
  2. Antworten: 4
    Letzter Beitrag: 07.03.2015, 10:58
  3. Antworten: 2
    Letzter Beitrag: 10.11.2014, 13:41
  4. Step 7 Kuka KRC4 an eine 317TF-2DP über CP
    Von Krumnix im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 21.11.2013, 22:39
  5. Step 7 Profinet-Verbindung zwischen S7400H und 26Stk 3xx
    Von Mathias im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 25.10.2013, 12:59

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •