Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: Wie S7-Verbindung mit CPU 314 IFM und CP341-1 LEAN zu LOGO!8 projektieren

  1. #1
    Registriert seit
    21.01.2015
    Ort
    Mannheim
    Beiträge
    14
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich möchte über Netzwerk einen Datenaustausch zwischen einem LOGO!8-Regler 12/24RCE und der CPU314 IFM (6ES7 314-5AE03-0AB0) mit CP343-1 LEAN (6GK7 343-1CX10-0XE0) realisieren. Eine Anleitung dazu habe ich auf der Homepage von Siemens gefunden. (Allerdings mit einer anderen CPU) Die Umsetzung scheitert aber schon bei dem Anlegen der S7-Verbindung in NetPro. siehe erstes Bild
    Problem S7-Verbindung zu LOGO!.gif
    Wo liegt die Fehlerursache?

    Mit einer anderen CPU 314C-2 DP (6ES7 314-6CG03-0AB0) und CP341-1 Lean (6GK7 343-1CX00-0XE0) kommt eine andere Fehlermeldung. siehe zweites Bild
    Problem S7-Verbindung zu LOGO! CPU314C-2 DP.gif

    Was muß ich tun, um erfolgreich eine S7-Verbindung projektieren und betreiben zu können?

    Ich danke für jede Hilfe.
    Zitieren Zitieren Wie S7-Verbindung mit CPU 314 IFM und CP341-1 LEAN zu LOGO!8 projektieren  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    ... Einen CP343-1 oder "PN-CPU) kaufen ... der Lean unterstützt S7-Verbindungen nur als Server "passiv", kann also seinerseits keine S7-Verbindung aufbauen, was hier aber erforderlich wäre.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    KlausMA (03.06.2015)

  4. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.291 Danke für 2.660 Beiträge

    Standard

    Das sollte auch mit dem LEAN-CP gehen, wenn man in der LOGO eine Client-Verbindung einrichtet. Dann ist die S7 der Server.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    KlausMA (03.06.2015)

  6. #4
    Registriert seit
    21.01.2015
    Ort
    Mannheim
    Beiträge
    14
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Also liegt es an der verwendeten Hardware.
    Ich habe es mal in Step7 mit einer CPU 314C-2DP und einem CP343-1 (ohne Lean) probiert. -> Es lässt sich erstmal eine S7-Verbindung ohne Fehlermeldung anlegen.
    Aber sobald entweder die alte CPU oder der alte CP projektiert ist, lässt sich keine S7-Verbindung mehr anlegen! Das ist ein eindeutiges Ergebnis.
    Am besten wäre also, eine CPU314C-2 PN/DP zu verwenden. Auch damit lässt sich eine S7-Verbindung anlegen. Und die alte Hardware wieder bei ebay verkaufen.

    Danke für Eure Hilfe. Mal schauen, was bei ebay an passender Hardware angeboten wird.

  7. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.291 Danke für 2.660 Beiträge

    Standard

    Hast Du auch mal versucht, in der Logo eine Client-Verbindung zur S7 anzulegen? Dabei wird in Step7 in NetPro NICHTS projektiert.
    (Ich weiß nicht ob das tatsächlich geht und habe leider keine LOGO da, um das mal für Dich auszuprobieren.)

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    KlausMA (03.06.2015)

  9. #6
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    @Harald
    Ich bin wirklich begeister, Siemens hat mich mal wieder, ausnahmsweise mal positiv, überrascht.
    Die Logo kann damit in dem Punkt hochoffiziell sogar mehr als eine S7-1200 (welche S7-Verbindungen auch nur als Server kann).

    Ich kann das zwar mangels zeuch ebenfalls nicht probieren, aber für den TE wäre das u.U. die Lösung, und das mit der bestehenden Hardware.

    Mfg
    Manuel
    Geändert von MSB (03.06.2015 um 18:19 Uhr)
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  10. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    KlausMA (03.06.2015)

  11. #7
    Registriert seit
    21.01.2015
    Ort
    Mannheim
    Beiträge
    14
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard

    In der Anleitung von Siemens zum Datenaustausch zwischen 300er CPU und LOGO!-Regler wird im LOGO!-Regler eine Client-Verbindung angelegt. Sogar mit Adressierung der Daten im Datenbaustein der 300er CPU. Aber auf CPU-Seite muß doch auch eine Verbindung angelegt sein, damit überhaupt Daten übertragen werden können? So ist es auf jeden Fall in der Anleitung von Siemens zum Datenaustausch zwischen 300er CPU und LOGO!-Regler vorgesehen.
    Ich kann es ja mal probieren, habe aber Zweifel, daß es funktioniert.

  12. #8
    Registriert seit
    21.01.2015
    Ort
    Mannheim
    Beiträge
    14
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Die geeignete CPU CPU314C-2 PN/DP wurde bei ebay gerade für 479 Euro verkauft. Da wurde ich leider überboten. Und das war schon relativ günstig für solch eine CPU. Das wird mir zu teuer.

    Ich habe aber eine ganz andere verückte Idee:
    - Kauf eines weiteren LOGO!-Reglers mit Netzwerkanschluß. Der wird im Keller neben der CPU 314 IFM plaziert. Dort tauschen die beiden Regler über deren Ein- und Ausgänge die wenigen Signale aus. Also direkt über Drahtverbindungen.
    - Der LOGO!-Regler im Keller tauscht dann die Daten über Netzwerk mit dem LOGO!-Regler in den Wohnung aus.
    Etwas umständlich, aber das sollte dann kein Problem mehr sein, da die LOGO!-Regler ja bereits für den einfachen Datenaustausch untereinander ausgelegt sind. Sowie deutlich preiswerter und ich muß nicht die gesamte Hardware austauschen. Ich denke, so werde ich es machen.

  13. #9
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.186
    Danke
    923
    Erhielt 3.291 Danke für 2.660 Beiträge

    Standard

    Zitat Zitat von KlausMA Beitrag anzeigen
    In der Anleitung von Siemens zum Datenaustausch zwischen 300er CPU und LOGO!-Regler wird im LOGO!-Regler eine Client-Verbindung angelegt. [...]
    Aber auf CPU-Seite muß doch auch eine Verbindung angelegt sein, damit überhaupt Daten übertragen werden können? So ist es auf jeden Fall in der Anleitung von Siemens zum Datenaustausch zwischen 300er CPU und LOGO!-Regler vorgesehen.
    Ich kann es ja mal probieren, habe aber Zweifel, daß es funktioniert.
    Ich habe keine Ahnung, warum die in dem Beispiel in der S7-300 eine Verbindung projektieren. Meiner Meinung nach ist das unnötig.

    Meistens sind S7-Verbindungen einseitige PUT/GET-Verbindungen, die nur auf dem Client projektiert werden. Am Server wird nichts projektiert, der antwortet einfach nur auf die Client-Anfragen. S7-Server-Support ist in allen aktuellen Siemens-Steuerungen schon eingebaut.

    Nun, da Siemens S7-Verbindungen in die Logo eingebaut hat um die Logo untereinander zu verbinden, muß die Logo zwangsläufig auch Client können. Und dann ist es eigentlich nur eine Parametrierungsfrage, auch mit einer S7-300 zu reden. (Es sei denn, das ist (aus preispolitischen Gründen?) unterdrückt.) Ich weiß nicht, ob es tatsächlich geht. Probiere es aus und berichte.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  14. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    KlausMA (04.06.2015)

  15. #10
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Was du noch wissen musst, das du in der Logo die S7-seitige TSAP 03.02 angeben musst.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  16. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    KlausMA (04.06.2015)

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 09.12.2012, 17:44
  2. Verbindung zu S7 CPU 314 CP343-1 Lean
    Von ditj_vitja im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 17.09.2010, 16:40
  3. Antworten: 0
    Letzter Beitrag: 09.05.2010, 20:06
  4. CPU 314 IFM und FB7 CP341
    Von S7_Mich im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 04.03.2009, 10:46
  5. CPU 314 mit CP340 projektieren Problem
    Von noeppkes im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 11.09.2007, 17:22

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •