Handbetrieb mit Servo (Zielposition wird nicht erreicht)

alex95wei

Member
Beiträge
5
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Guten Morgen Kollegen,
ich habe folgendes Problem :
Es geht um den Handbetrieb einer Servo-Achse, dabei wird über ein Bit die Richtung, Zielposition, Geschwindigkeiten, Rampen vorgeben sowie der Antriebsstart beschaltet. Beim Rücksetzten des Bits wird der Antriebsstart weggenommen.
Nun kommt das Fehlverhalten, dass der Antrieb nicht mit der vordefinierten Rampe abbremst sondern mit der Antriebshalt Rampe vom Umrichter, weil er ja seine Zielposition nicht erreicht und irgendwo unter seinem Fahrbefehl abgebrochen wird.
Hardware dazu ist ein BoschRexroth IndraDrive Cs in Verbindung mit einer Siemens CPU 1512SP

Hättet ihr eine Idee wie man das Problem beheben könnte ?

Mit freundlichen Grüßen Alex
 

jensemann

Well-known member
Beiträge
154
Punkte Reaktionen
34
Wenn mit Rücksetzen des Bits die Reglerfreigabe weggenommen wird, macht der Umrichter quasi einen Nothalt mit den im Umrichter definierten Werten. Wenn die Reglerfreigabe bleibt bis mindestens die Achse steht, wird sie auch mit den definierten Werten bremsen und sogar die Zielposition erreichen.
Also nur 1 Bit für Reglerfreigabe und Achsstart/-stop ist evtl nicht zielführend.
 
OP
A

alex95wei

Member
Beiträge
5
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Die Reglerfreigabe bleibt dauerhaft drauf außer halt wenn die Sicherheit unterbrochen wird.
Es wird bei meinem Projekt der Antriebsstart weggenommen und halt die Zielposition nicht erreicht (bewusst unterbrochen da es ja ein Handbetrieb ist und ich zwischen Min und Max Verfahrbereich stehen bleiben will)
Gibt es da eine Möglichkeit, dass ich mit einer definierten Rampe abbremsen kann und nicht mit der im Umrichter definierten ?

Vielen Dank schon mal für deine Antwort
 
Oben