MOVI-C Controller Probleme mit Netzwerk-Zugriff

Fluffi

Level-2
Beiträge
463
Reaktionspunkte
71
Zuviel Werbung?
-> Hier kostenlos registrieren
Ich habe aktuell das Problem, dass über die Feldbus-Schntitstelle Profinet zwar ohne Probleme die Kommunikation mit der SPS funktioniert, aber wenn ich über diese Schnittstelle mit Movisuite auf den Controller bzw. die Umrichter draufgehe ca. alle 2 Sekunden einen kurzen Verbindungsabbruch habe. Wenn ich die Engineering-Schnittstelle nutze dann habe ich keine Probleme. Ist das generell so bei dem Controller oder ist das eher ein Problem mit Timeouts und Priorisierungen?
Schlussendlich wird es aber nur ein Maschinennetz in der Anlage geben auf welches dann auch über einen VPN Router zugegriffen wird. Für die Konfiguration bzw. Fehleranalyse der Umrichter dann die Engineering-Schnittstelle zu nutzen welche in einem anderen Adressbereich sein müsste (?) wird dann sowieso nicht gehen. Daher möchte ich gerne nur die Feldbus-Schnittstelle verwenden.
Oder dürfen die Adressen des Feldbusses und der Engineering-Schnittstelle im gleichen Netz sein? Falls ja, wie stellt man dann in Movisuite explizit ein über welche IP auf den Controller zugegriffen wird? Es wird dann leider immer nur die des Feldbusses über Scan gefunden und verwendet.
 
Hallo Fluffi,

ich würde dir niemals empfehlen den MOVI-C Controller über PROFINET zum Engineering zu nutzen.
Ja das geht, aber ich habe da keine guten Erfahrungen gemacht.

Ja, der Feldbus und der Engineering können im gleichen Subnetz sein -> Mache ich standardmäßig.

So mache ich das:
Im Schaltschrank ist eigentlich immer ein Switch enthalten.
Ich packe den Engineering Port immer direkt auf einen freien Switch Port.
Das PROFINET befindet sich selbstverständlich auch auf diesen Switch und beide finden sich im gleichen Subnetz.

Um die Engineering Adresse (X80) passend einzustellen, gehe ich wie folgt vor (Gibt bestimmt noch andere Wege -> Speicherkarte):
Dazu setze ich über das TIA oder PRONETA den PROFINET Namen und die IP Adresse des X40 Anschlusses und Scanne das Gerät.
Anschließend gehe ich in die MOVISUITE -> Controller Einstellungen -> Kommunikation -> Engineering:
1720510908574.png
Mit Parameter setzen, sollte sich die Aktive Adresseinstellung auf deine IP-Adresse geändert haben.
Damit die MOVISUITE nun die Engineering IP-Adresse nun, ziehe ich den PROFINET ab.
Die MOVISUITE nimmt sich dann automatisch den Engineering Port.
Das kann man sich auch in der Netzansicht anschauen:
1720511373977.png

Nun wieder den PROFINET verbinden und fertig.

Ansonsten kannst du in den Kommunikationseinstellungen die Adressen eingrenzen:
1720511773820.png

Wenn ein Router in der Anlage vorhanden ist, kann ich dir die IP Forwarding Funktion empfehlen.

Ich hoffe, dass hilft erst einmal weiter.

Merian25
 
Zuviel Werbung?
-> Hier kostenlos registrieren
Damit die MOVISUITE nun die Engineering IP-Adresse nun, ziehe ich den PROFINET ab.
Die MOVISUITE nimmt sich dann automatisch den Engineering Port.
Und wie lässt sich die Zugangsadresse dauerhaft einstellen? Temporär mag hier dann der Engineering Port verwendet werden, aber sobald ein neuer Scan gemacht wird und man vielleicht nicht vor Ort ist oder die Profinet-Verbindung nicht mal eben abstecken kann, hat man wieder das Problem.
 
Ob man dies direkt einstellen kann, keine Ahnung.
Ich kenne da keinen direkten Parameter.
Das einzige, was ich kenne, ist das einstellen der Adressbereiche unter "Kommunikation konfigurieren".
Ich habe das gerade mal ausgetestet:
X80: 192.168.10.4
X40: 192.168.10.5

Wenn ich unter dem Adressbereich die 192.168.10.4 eintrage, favorisiert die MOVISUITE auch diese Adresse.
Wenn unter dem normalen Scan (ohne Adressbereich) die 192.168.10.5 gefunden wurde, nimmt die MOVISUITE nun (mit Adressbereich) automatisch die 192.168.10.4. Wird das Kabel am X80 entfernt und scannt, nimmt er wieder die 192.168.10.5. Wird das Kabel wieder an X80 angeschlossen, nimmt die MOVISUITE die X80 IP.

Jedenfalls wird die jeweilige IP Adresse in der Netzwerkansicht so angezeigt.

Beste Grüße
Merian25
 
Zuletzt bearbeitet:
Zuviel Werbung?
-> Hier kostenlos registrieren
Feste Einstellung der Engineering IP-Adresse geht über die Speicherkarte. Im Handbuch beschrieben.

5.1 Benutzerdefinierte IP-Adresse einstellen (optional)
HINWEIS
Das Umschalten zwischen Default-Adresse und benutzerdefinierter IP-Adresse erfolgt ggf. über den verbauten DIP-Schalter.
Der MOVI-C® CONTROLLER liest die für die Kommunikation zu verwendenden IP-Adressen aus der Datei SewPlcIp.xml aus. Diese Datei befindet sich auf der OMH-Speicherkarte im Verzeichnis "System".
Gehen Sie zum Ändern der IP-Adressen wie folgt vor:
1. Greifen Sie über die Engineering-Schnittstelle oder mittels eines Kartenlesegeräts auf das Dateisystem auf dem MOVI-C® CONTROLLER zu und navigieren Sie zum Verzeichnis "System".
2. Öffnen Sie die Datei SewPlcIp.Example.xml zur Bearbeitung in einem Editor.
3. Ersetzen Sie in der Datei die momentan angegebenen durch die von Ihnen gewünschten IP-Adressen.
4. Speichern Sie die Datei und schließen Sie den Editor.
5. Bennen Sie die bearbeitete Datei in SewPlcIp.xml um. Beim nächsten Hochfahren des MOVI-C® CONTROLLER werden die neuen Werte
übernommen und verwendet.
Nach dem ersten Hochfahren nach der Bearbeitung kann die Datei gelöscht oder wieder in SewPlcIp.Example.xml umbenannt werden.
HINWEIS: Wenn die Datei gelöscht wird, wird nicht automatisch wieder die
Default-Adresse (192.168.10.4) eingestellt


Warum nur so... Wer weiss. Muss ja alles anders sein bei Movisuite.
 
Zurück
Oben