TIA PLC-Meldetextlisten - gültige Sprache

MFreiberger

Level-3
Beiträge
2.753
Reaktionspunkte
720
Zuviel Werbung?
-> Hier kostenlos registrieren
Moin Zusammen,

ich bin mal wieder auf ein Problem gestoßen. Und zwar habe ich in TIA eine PLC-Meldetextliste exportiert, Zeilen bzw. Einträge hinzugefügt und wollte sie jetzt wieder importieren. Das wird mit dem Fehler
"Es wurde keine gültige Sprache für den Import gefunden."
beendet. Aber ich habe doch alles exportiert. Warum fehlt jetzt beim Import eine gültige Sprache?
Hatte das schon mal Jemand und kennt eine Lösung?

Vielen Dank

MFreiberger
 
Moin,

hast du zwischen Export und Import irgendeine Änderung mit den Sprachen (oder anderes Projekt geöffnet) gemacht? Soeben bei TIA 15.1 eine PLC-Meldetextliste angelegt, exportiert, gelöscht und wieder importiert - ohne Probleme.
 
Zuviel Werbung?
-> Hier kostenlos registrieren
Jedenfalls nicht bewusst.
Vergessen: ich arbeite mit TIA17

Ich hatte schon einmal einen ähnlich gelagerten Fall. Da hatte ich SCL-Quellen erzeugt und wollte sie wieder einlesen. Die hatte ich mit gedit geöffnet und gespeichert. Die Voreinstellung bei Gedit ist Zeilenende Unix/Linux. Damit kam TIA dann nicht mehr klar.
Aber das sollte doch hier kein Problem sein (Bearbeitung erfolgte mit Excel)? Jedenfalls wüsste ich gerade nicht, wo ich da gucken soll.
 
bei mir wird's ohne Probleme importiert - auch wenn bei neuen Zeilen der Bereich als Zahl und nicht als Text (Excel) angegeben wird.
1682493862804.png
 
Ist dir vlt. ein Steuerzeichen bei der Excel Bearbeitung mit in die Tabelle gerutscht? (Falls Excel das überhaupt zulässt.)

Was passiert, wenn du eine Exportierte Meldeliste ohne Excel Anpassung wieder importierst?
 
Steuerzeichen in Excel kann ich visuell nicht entdecken.
Die Frage ist: wie finde ich diese? Es sind halt auch schon einige Zeilen...
 
Zuviel Werbung?
-> Hier kostenlos registrieren
Speichern unter ... als CSV -> dann dürften ja nur noch die Steuerzeichen LF (10), CR (13), und evtl. Dateiende vorhanden sein.
Dann wieder speichern unter ... als name.xlsx

sehe gerade, da muss man due Arbeitsblätter einzeln abspeichern
 
Ich hatte die Meldetext mit Formeln zusammengestückelt. Danach habe ich sie zwar kopiert (als Werte eingesetzt) und die entsprechenden Spalten mit den Formeln gelöscht. Aber da ist irgendwas hängen geblieben.

Jetzt habe ich das Zusammenstückeln in einer separaten Tabelle gemacht, kopiert und in der Meldetext-XLSX als Werte eignefügt. Das hat jetzt auch funktioniert.

@Peter Wahlen Vielen Dank für die Denkanstösse!
 
Ich hatte die Meldetext mit Formeln zusammengestückelt. Danach habe ich sie zwar kopiert (als Werte eingesetzt) und die entsprechenden Spalten mit den Formeln gelöscht. Aber da ist irgendwas hängen geblieben.
Die kompletten Spalten gelöscht (Spalten markiert z.B. E bis H-> Kontext: Zellen löschen) oder nur Zellen markiert und entfernen gedrückt? Das kann ein Unterschied sein.

Edit: Das ist bestimmt ein Unterschied, weil bei der 2. Methode bleiben Zellenformatierungen erhalten.
 
Zurück
Oben