Probleme mit Wago I/O System bzw. I/O Pro 32

A

Anonymous

Guest
Zuviel Werbung?
->Hier kostenlos registrieren
Hy!

Hat jemand Erfahrung in Sachen SPS Programmierung für Wago I/O System 750 und der dazugehörigen Wago I/O Pro Software?

Habe eigentlich nur ein winzig kleines Problem, bei S5 oder S7 kinderleicht zu lösen, aber bei Wago fällt mir dies sehr schwer!

Versuche meine Funktionsbausteine (Blöcke) mittels OB1 (PLC_PRG) zu laden, klappt aber nicht!

Kann mir jemand weiterhelfen?

Danke!
 

Markus

Administrator
Teammitglied
Beiträge
5.213
Punkte Reaktionen
1.263
Zuviel Werbung?
->Hier kostenlos registrieren
wieso sollen dir alle mailen?
es ist besser die fragen hier zu klären, dann hat jeder was davon!

das hier ist ein FORUM und keine kontaktbörse für email freundschaften!
 

Oberchefe

Well-known member
Beiträge
1.951
Punkte Reaktionen
250
Deine Funktionsbausteine kannst Du als Bibliothek speichern, einfach ein Programm mit den gewünschten Funktionsbausteinen erstellen, speichern ("Speichern unter", lib2). Dann kannst Du bei jedem beliebigen Nachfolgeprojekt drauf zugreifen. Wenn Du möchtest, kann ich Dir mal ein Beispielprogramm dazu schicken.
 

Runtime

Active member
Beiträge
41
Punkte Reaktionen
0
Ich verstehe das Problem nicht so ganz ?

Das Wago I/O System wird doch mit Codesys Programmiert oder ?

Brauchst doch nur einen neuen Programmbaustein anzulegen und im PLC_PRG aufzurufen...

Gleiches gilt für die Bibiotheken - einfach Implementieren und aufrufen ....
 

M_o_t

Well-known member
Beiträge
148
Punkte Reaktionen
22
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo,

das PLC_PRG ersetzt den OB1, wenn's dir nicht gefällt kannst auch in der Taskkonfiguration eine eigenen Baustein aufrufen mit Zykluszeit und Priorität benannt.

Gruss
M_o_t
 

Rene-Ernest

New member
Beiträge
1
Punkte Reaktionen
0
Wago Systemabstürtze

Hallo zusammen

Ich habe nur so eine Frage wir setzten bei uns einige der WAGO 758 Module ein und haben massive Probleme damit, die IPC 758 hängen sich laufend auf und sind nur durch einen Cold Boot wieder zu Leben zu erwecken.
Wir hatten schon des öffteren einen Techniker und Consultant der Firma WAGO im Haus die dann immer wieder eine nach deren aussage Super stabilere Version der Firmware aus dem Hut gezaubert hatten, der Erfolg ist gleich null.
Kurz unsere Konfiguration:
Wago 758 IPC mit Klemmen Modulen
Netzanbindung
Hirschmann Industrie Switch RS20 mit SC 50nm Glasfaser
Die Spannungsversorgung wird durch Netzfiltermodule stabilisiert
 

gravieren

Well-known member
Beiträge
2.211
Punkte Reaktionen
237
Hi Anonymous

Lade dir mal ein Beispiel von meiner Homepage runter.

Z.b. Uhrzeit.


Da ist alles vorhanden, auch die Visualisierung.

Ich denke das ist deine nächste Frage.
 
Oben