TIA Siemens Autmation Tool, Basic Panel und NAT

maxder2te

Level-3
Beiträge
1.043
Reaktionspunkte
334
Zuviel Werbung?
-> Hier kostenlos registrieren
Hallo zusammen,

ich versuche aktuell mit dem Simatic Automation Tool V04.00.03.01 ein Software-Update auf ein Basic Kanel KTP 400 2. Generation zu bekommen. Das Problem dabei ist, dass das Panel hinter einem NAT-Gateway sitzt.

Folgende Konstellation:
PC (192.160.0.15) --> NAT-Router (192.168.0.101/192.168.100.201) --> KTP400 (192.168.100.105)
Im NAT-Router sind, so wie in der SAT-Hilfe angegeben die Ports 102 und 161 weitergeleitet.

Versucht man, das Panel manuell zur Geräteliste hinzuzufügen, wird es schlicht nicht erkannt. Schaut man sich den Datenverkehr mittels Wireshark an, kommt folgendes zu Tage:
  1. SAT sendet SNMP-Anfrage ans Panel (1.3.6.1.2.1.1.1.0)
  2. Panel antwortet mit "Linux honey 3.14.49 #1 Wed Aug 28 12:03:45 CEST 2019 armv7l"
  3. SAT sendet SNMP-Anfrage ans Panel (1.3.6.1.4.1.4196.1.1.5.2.100.1.8.26.0)
  4. Panel antwortet mit NULL
Dann ist der Einfügevorgang mit Fehler beendet, das Ereignisprotokoll liefert sie vielsagende Meldung
FEHLER:,14.02.2023,13:28,,,,Gerät einfügen,Das Gerät konnte nicht in die Gerätetabelle eingefügt werden. Details siehe Ereignisprotokoll.

Ersatzt man das Panel durch eine SPS (1512) dann klappt das Einfügen problemlos.

Kennt jemand dieses Verhalten? Ist das ein Bug des SAT?

Danke
lg

Edit: versucht man mittels ProSave über das NAT-Gerät auf das Panel zuzugreifen klappt das probemlos. Das SAT möchte ich verwenden, da es über eine API zum Fernsteuern verfügt.
 
Zuletzt bearbeitet:
Zurück
Oben