TC3 und canOpen Stepper

Netman1020

Level-2
Beiträge
15
Reaktionspunkte
0
Zuviel Werbung?
-> Hier kostenlos registrieren
Ich versuche schon seit geraumer Zeit einen Nanotec PD4-C5918L4204-E-08 als CanOpen Slave, über eine EL6751, als Achse in Twincat3 einzubinden.

Als Anleitung habe ich hier das benützt TC2 Nanotec, allerdings ohne Erfolg. Ich kann zwar den Encoder auslesen, aber der Motor dreht sich nicht.

Über die Nanotec eigene Software, läuft der motor tadellos.

Ich habe zwar schon einige Ethercat Antriebe in Betrieb genommen, aber CanOpen Stepper sind neu für mich.

Was mach ich falsch?

1711870603379.png
1711871432160.png
 
Zuletzt bearbeitet:
³
Bin schon mal etwas weiter gekommen, aber noch nicht am Ziel.
Video

Anhang anzeigen 76809
Anhang anzeigen 76810Anhang anzeigen 76811
Ist es wirklich so schwer eine einfache Fehlermeldung zu googleln?
Die 0x4650 bedeutet Antriebshardware nicht bereit.
Du versuchst die Achse einzuschalten obwohl sie nicht bereit ist.
Der Status "Bereit" muss anliegen ehe Du die Achse mit MC_Power in Regelung schaltest.
Findet überhaupt eine Kommunikation statt? Soweit der Motor einen Encoder hat, ändert sich die Position, wenn Du Ihn von Hand drehst?
 
Zuletzt bearbeitet:
Zuviel Werbung?
-> Hier kostenlos registrieren
Ok, was ist damit genau gemeint? Ich habe das Statusword, Controlword, Actual Position und Target Position, genau wie in der Anleitung verknüpft.
Na ja, ganz einfach, die Konfiguration der übertragenen Prozessdaten muss am Slave (Dem Motor Controller) und Deiner SPS gleich sein.
 
Die Emergency-Telegramme folgen einer Definition/Struktur. Das Gerät/Hersteller das es produziert sollte Aussagen darüber geben können
0x000 ist ein allgemeiner Fehler -> da lässt sich nichts ohne Gerätedoku sagen
0x81xx wird mit Communication im Standard definiert.

Prinzipiell muss ein DSP402 Gerät über das ControlWord mit verschiedenen Bits "hochgefahren" werden. 0x1, 0x6, 0x7 , 0xf.
So wie ich es sehe kommt vom Statusword aber dann ein "nee kann ich nicht/will ich nicht".

Die Ursache kann jetzt vielfältig sein. Entweder ist der Betriebsmode nicht korrekt im Antrieb gesetzt oder oder oder.
 
³

Ist es wirklich so schwer eine einfache Fehlermeldung zu googleln?
Die 0x4650 bedeutet Antriebshardware nicht bereit.
Du versuchst die Achse einzuschalten obwohl sie nicht bereit ist.
Der Status "Bereit" muss anliegen ehe Du die Achse mit MC_Power in Regelung schaltest.
Findet überhaupt eine Kommunikation statt? Soweit der Motor einen Encoder hat, ändert sich die Position, wenn Du Ihn von Hand drehst?
Die Encoder Position sehe ich und verändert sich auch beim manuellen drehen des Motors
 
Zuviel Werbung?
-> Hier kostenlos registrieren
nachdem im twincat sich der motor nicht "an schalten" lies, hab ich die Fehler über die Nanotec Software ausgelesen.
1712380804977.png
Ich weis jetzt nur nicht, was ich damit anfangen soll.
 
Naja, ich würde mal in der Nanotec Doku nachschauen was der Fehler bedeutet. Aber musst du nicht. Kannst auch einfach warten bis es dir jemand sagt...
 
Zuviel Werbung?
-> Hier kostenlos registrieren
nachdem im twincat sich der motor nicht "an schalten" lies, hab ich die Fehler über die Nanotec Software ausgelesen.
Anhang anzeigen 76969
Ich weis jetzt nur nicht, was ich damit anfangen soll.
Na, steht doch da, ihm fehlt das Heartbeat Signal.
Habe keinen CAN-Bus und kann im Moment auch nicht nachsehen, aber such mal in TwinCAT bei der CAN-Bus Konfig nach den Einstellungen.
 
Zurück
Oben