TwinCAT 3.1.4026 veröffentlicht

Ich habe jetzt alle Bibliotheken rausgelöscht. Trotzdem bleiben von den 99 Referenzen noch 30 übrig. Da aber die fehlenden Bibliotheken mehr als 500 Fehler erzeugen, sehe ich die "Ambiguous use of name ..." Fehler gar nicht, um zu sehen, wo diese übrigen 30 Referenzen sind. Das wird eine schwierige Geschichte. Hat jemand noch eine Idee?
 
Zuviel Werbung?
-> Hier kostenlos registrieren
Ich habe jetzt alle Bibliotheken rausgelöscht. Trotzdem bleiben von den 99 Referenzen noch 30 übrig. Da aber die fehlenden Bibliotheken mehr als 500 Fehler erzeugen, sehe ich die "Ambiguous use of name ..." Fehler gar nicht, um zu sehen, wo diese übrigen 30 Referenzen sind. Das wird eine schwierige Geschichte. Hat jemand noch eine Idee?
Ich würde da jetzt -157 empfehlen, sprich die Beckhoff Hotline, das die sich das mal per TeamViewer ansehen.
 
Auf jeden Fall werde ich mich dann bei unserem Supporter melden. Zuerst wollte ich alle anderen Möglichkeiten ausschöpfen, da solche Probleme beim Support immer etwas Zeit brauchen.
 
Hallo zusammen,

ich habe mir heute mal die 4026 installiert, soweit klappt es auch. Also das SPS-Projekt lies sich ohne Probleme konvertieren. Aber ich bekomme in der Online-Ansicht keine LREAL angezeigt (siehe Screenshot Zeile 107)
1715182708369.png

Also alles andere Dateitypen gehen, zu lange Strings werden abgeschnitten, aber der LREAL mit dem Wert 1.23 wird nicht angezeigt.

Hat jemand von euch dasselbe Problem, oder noch besser eine Lösung?
 
Ist die Anzeige denn bei Variablendeclaration korrekt? Falls ja, würde ich eher bei dem Fall auf ein LREAL Darstellungsproblem bei den dataTips tippen. Der Beckhoff Support hat dazu eine Info?
 
Was wird angezeigt, wenn du auf das kleine Dreieck klickst?
1715583451693.png

Der Mauszeiger ist im Screenshot nicht mit drauf. Stand aber auf der unteren Variablen. Hovern reicht, klicken bringt nix.

Erstaunlicherweise geht es aber nur mit testLreal2. Wenn ich mit der Maus über die obere oder mittlere Variable gehe, dann wird mir keine Hoverinfo angezeigt. Solange ich aber auf den Feldern bin flackert der Mauszeiger zwischen dem normalen Pfeil und dem Symbol für die Texteingabe.

In der Variablendeklaration passt alles.

Support hab ich noch nicht gefragt.

Ich nutze übrigens die 64bit-Shell. Vielleicht liegt es daran. Wenn es bei euch in der 32bit geht kann ich auf die wechseln.
 
Nein, ich bin im Testing-Feed. Ich muss aber zugeben, dass ich den Package Manager noch nicht genug verstehe, um dir jetzt sagen zu können, was im Testing und was im Stable verfügbar ist. Im Reiter "Available" habe ich das Dropdown für die Feeds, Im Reiter "Installed" ist es weg :rolleyes:. Aber da die TE2000 laut Homepage noch gar nicht unterstützt wird gehe ich mal davon aus, dass es noch keine Version in den Stable geschafft hat.
 
Ich habe nun die letzten Tage auch etwas Zeit gehabt die neue Version zu testen. Also hier ein bisschen Feedback:
1.) Eines einmal vorweg: Auf 32 Bit Win10 Systemen (die offiziell unterstützt werden) startet der Paketmanager nicht ohne Fehlermeldung (nur ein Fehlerbericht wird generiert laut Ereignisanzeige). Auf die Schnelle war nicht herauszufinden warum

2.) Die Idee des Paketmanagers ist grundsätzlich gut. Aber warum zur Hölle braucht das Ding 250MB Speicherplatz?
Und auch wenn ich nur die Pakete installiere, die ich brauche ist die Installation deutlich größer als noch "alles" bei 4024. Das läuft echt in die falsch Richtung.

3.) Eine Funktion einen Offline Installer zu generieren oder die Pakete manuell herunter zu laden haben ich bisher nicht gefunden. Soll ich da beim Kunden an der Anlage beim Updaten jedes Mal einen Hotspot machen? Bei den deutschen Mobilfunknetzen bin ich manchmal froh wenn ich an der Anlage telefonieren kann.

4.) HMI (TF1800): Es ist nur das Visualisierungsprofil für 4026 installiert d.h. 4024er Projekte können nicht übersetzt werden. Ändere ich das Visualisierungsprofil so lässt sich das Projekt nicht mehr auf eine 4024er Runtime einspiel (Segfault beim Starten). Auch der Remote Manager inkl. Wechsel auf 2024.56 löst das Problem nicht. Da man 4024 und 4026 auch nicht parallel installieren kann bleiben 2 Alternativen:
a) Alle Kunden Runtimes selbst bei nur minimalen Änderungen auf 4026 updaten (ohne Offline Installer) => Das nicht nicht praktikabel
b) Immer eine virtuelle 4024er Machine mit dabei haben, die ich dann beim Wechsel der IP Adresse auch immer umkonfigurieren darf. Wenn ich versuche das 4026er Projekt in 4024 zu öffnen habe ich das Problem, dass der Visualisierungsmanager defekt ist und ich wieder herumbasteln darf => Auch keine Lösung

Ich frage mich auch, ob das nun bei jeder neuen TwinCat3 Version der Fall ist. Möglicherweise bin ich nach 15 Jahren TwinCat 2 auch nur etwas verwöhnt was Inkompatiblitäten angeht.

5.) Einige Pfade haben sich geändert z.B. C:\Program Files (x86)\Beckhoff statt C:\TwinCat:
Ist zwar modern hat aber das Problem, dass alle internen Tools angepasst werden müssen

6.) Usermode Runtime: Das ist eine geniale Idee. Nun hat man endlich wieder ein virtuelles Testsystem ohne virtuelle Maschinen.
Im ersten Test hat es schon einmal grob funktioniert. Die .ini der Visualisierung musste manuell angepasst werden und es gibt noch gelegentliches Flackern von ein paar Steuerelementen (vermutlich ein Taskproblem) aber sonst funktioniert es.
Nachteil: Die Usermode Runtime verwendet andere Ordner wie die echte Runtime => Macht auch wieder etwas Kopfschmerzen für interne Tools
Einige Funktionen scheinen jedoch noch ein paar Probleme zu haben (bei mir NT_StartProcess und NT_Reboot). Habe das aber noch nicht genauer analysiert.

7.) Der Profiler hört sich sehr interessant an, da ich dann den ganzen Profilingcode aus dem SPS Programm entfernen kann.
Schade dass es da keine Testversion gibt denn bei dem Preis einfach auf Verdacht bestellen ist etwas teuer wenn noch nicht bekannt ist wie hoch der Overhead ist.

Fazit: So richtig kundentauglich ist das Ganze noch nicht. Ich werde wohl noch ein Jahr warten und es danach noch einmal probieren.
 
3.) Eine Funktion einen Offline Installer zu generieren oder die Pakete manuell herunter zu laden haben ich bisher nicht gefunden. Soll ich da beim Kunden an der Anlage beim Updaten jedes Mal einen Hotspot machen? Bei den deutschen Mobilfunknetzen bin ich manchmal froh wenn ich an der Anlage telefonieren kann.
Die Möglichkeit offline zu arbeiten gibt es:

Ist zwar etwas umständlich gelöst, aber funktioniert.
Ich würde mir wünschen, dass ich mit einem Befehl sagen kann "Lade alle Pakete runter, die für die installierten Komponenten notwendig sind", aber das habe ich irgendwie noch nicht gefunden.

Und dass 4024 und 4026 nicht kompatibel sind, das war ja so zu erwarten.

die XAR läuft bei mir bisher ganz gut, ich habe eher mit der HMI(TE2000) Probleme, die hängt manchmal. Da muss ich aber noch ein wenig forschen, was da schief läuft.
 
3.) Eine Funktion einen Offline Installer zu generieren oder die Pakete manuell herunter zu laden haben ich bisher nicht gefunden. Soll ich da beim Kunden an der Anlage beim Updaten jedes Mal einen Hotspot machen? Bei den deutschen Mobilfunknetzen bin ich manchmal froh wenn ich an der Anlage telefonieren kann.
Ja, den Download der Pakete gibt es schon; der Überblick, welche Pakete aber komplett nötig sind, sehe ich auch als Schwierigkeit.

4.) HMI (TF1800): Es ist nur das Visualisierungsprofil für 4026 installiert d.h. 4024er Projekte können nicht übersetzt werden. Ändere ich das Visualisierungsprofil so lässt sich das Projekt nicht mehr auf eine 4024er Runtime einspiel (Segfault beim Starten). Auch der Remote Manager inkl. Wechsel auf 2024.56 löst das Problem nicht. Da man 4024 und 4026 auch nicht parallel installieren kann bleiben 2 Alternativen:
a) Alle Kunden Runtimes selbst bei nur minimalen Änderungen auf 4026 updaten (ohne Offline Installer) => Das nicht nicht praktikabel
b) Immer eine virtuelle 4024er Machine mit dabei haben, die ich dann beim Wechsel der IP Adresse auch immer umkonfigurieren darf. Wenn ich versuche das 4026er Projekt in 4024 zu öffnen habe ich das Problem, dass der Visualisierungsmanager defekt ist und ich wieder herumbasteln darf => Auch keine Lösung
Noch nicht wirklich angeschaut...aber bringt der RM.4024.x die VisuProfile nicht? Und die RMs kannst Du in 4026 nachinstallieren...

5.) Einige Pfade haben sich geändert z.B. C:\Program Files (x86)\Beckhoff statt C:\TwinCat:
Ist zwar modern hat aber das Problem, dass alle internen Tools angepasst werden müssen
Man kann auch den Paket Installer noch auf den "alten" Pfad zwingen - ob im UI weiß ich gerade nicht, aber der CLI über "TwinCAT.Prep" -> "InstallationPath..." als "params" (wenn man den Punkt der IT-Security wirklich ignorieren möchte).
PS> tcpkg install twincat.prep --params "/InstallationPath:C:\TwinCAT"
 
Zuletzt bearbeitet:
Zuviel Werbung?
-> Hier kostenlos registrieren
TwinCAT 3.1.4026.6 ist jetzt im Stable Feed

Folgendes ist mir aufgefalle:
  • TwinCAT Project Compare ist jetzt vorhanden
  • TC2_SUPS immer noch nicht vorhanden
 
TwinCAT 3.1.4026.6 ist jetzt im Stable Feed

Folgendes ist mir aufgefalle:
  • TwinCAT Project Compare ist jetzt vorhanden
  • TC2_SUPS immer noch nicht vorhanden
Zum Thema Project Compare hätte ich mal eine Frage.Im SPS-Knoten funktionierte das Tool bis auf bestimmte Situationen eigentlich ganz gut, zumindest in ST, aber beim E/A-Knoten und anderen war es nicht wirklich zu gebrauchen.
Hat sich hier etwas getan? Ich sitze gerade an dem Update der Einführung zu TC3 und kann es im Moment nicht selber testen.
 
Zuletzt bearbeitet:
Zurück
Oben